Balabolka (Text-To-Speech)

Balabolka

Balabolka je program primárně určený k převodu textu na řeč prostřednictvím systému TTS (Text-To-Speech). Podporuje práci se všemi hlasovými syntézami, instalovanými ve vašem systému. Pomocí položky 'Otevřít' v menu 'Soubor' lze v programu zobrazit a editovat všechny běžné textové dokumenty. Nový dokument lze jednoduše vytvořit položkou 'Nový', která se nachází rovněž v menu 'soubor'.

Základní funkce čtení lze jednoduše ovládat pomocí tlačítek (Přehrát, Pozastavit, Zastavit), umístěných na nástrojové liště u horního okraje okna programu. Mezi další funkce patří např. čtení obsahu schránky, prohlížení dokumentů pokročilých formátů, možnost definovat vlastní barvy písma a pozadí či ovládání globálními horkými klávesami.

Podporované formáty souborů: AZW, AZW3, CHM, DjVu (DjVu+OCR), DOC, DOCX, EML, EPUB, FB2 (FB2.ZIP, FBZ), FB3, HTML, LIT, MD, MOBI, ODP, ODS, ODT, PDB, PDF, PPT, PPTX, PRC, RTF, TCR, WPD, XLS, XLSX. Pro rozšíření podpory o další (programem nepodporované) typy souborů lze použít rozhraní IFilter.

V programu zobrazený text je možné uložit jako zvukový soubor WAV, MP3, MP4, OGG, OPUS či WMA použitím položky 'Soubor / Uložit zvukový soubor' či 'Soubor / Uložit a převést na zvukové soubory' v hlavní nabídce.

Dále Balabolka podporuje ukládání synchronizovaného textu do externích souborů *.lrc či do ID3 tagů, jež jsou přímou součástí výsledných zvukových souborů. Je-li takový soubor přehráván v přehrávačích s podporou těchto formátů, je text zobrazován synchronně, podobně jako např. texty písní.

Program podporuje rozhraní Microsoft Speech API (SAPI) a Microsoft Speech Platform. U všech hlasů lze nastavit příslušné parametry, např. rychlost a výšku.

V zájmu zlepšení výslovnosti lze uplatnit Seznamy nahrazení. Tato funkce je užitečná v případech, kdy chce uživatel změnit výslovnost jednotlivých slov či slabik. Balabolka podporuje tři typy seznamů nahrazení:

  • pravidla pro úpravu výslovnosti tvořená pomocí regulárních výrazů, uložená v souborech s příponou *.rex;
  • soubory s příponou *.dic; tento formát je populární ve východní Evropě; zápis pravidel je velmi jednoduchý, soubor může obsahovat tisíce pravidel;
  • soubory s příponou *.bxd sdružují možnosti dvou předchozích formátů.

Soubory pro úpravu výslovnosti jsou uloženy ve složce Dokumenty\Balabolka. Je-li použit některý slovník, program během čtení zvýrazňuje celou větu či odstavec, v opačném případě je vždy zvýrazněno aktuální slovo.

Poznámka: Přenosná verze Balabolky ukládá soubory pro úpravu výslovnosti do podsložky Dictionaries ve složce programu.

* Balabolka je ruské slovo, volně přeloženo jako Kecálek.

WWW: balabolka.site

E-mail: crossa@list.ru

© 2006-2020 Ilya Morozov


Hlasy

Speech Application Programming Interface či SAPI je rozhraní, vytvořené společností Microsoft za účelem jednoduchého použití hlasových syntéz v aplikacích Windows. K dispozici jsou dvě hlavní verze tohoto rozhraní (SAPI 4 a SAPI 5), jež nejsou vzájemně kompatibilní.

SAPI 4 (Microsoft Speech API 4.0)

Hlasy rozhraní SAPI 4 pomalu zastarávají a jejich instalaci nedoporučujeme.

SAPI 5 (Microsoft Speech API 5.x)

RHVoice - free and open source speech synthesizer (it supports English, Esperanto, Georgian, Russian, Ukrainian, Kyrgyz and Tatar):

  • RHVoice

Yaroslav Kozak (Lvov, Ukraina) vytvořil ukrajinský hlas UkrVox:

  • UkrVox Igor

Ekho – free TTS engine (podporuje kantonštinu a mandarínštinu):

  • Ekho (čínština)

Abyste získali lepší kvalitu hlasu, můžete zakoupit produkty firem Acapela Group, Cepstral, IVONA či Speechtech. Jedná se o novou generaci hlasů, používající velké databáze hlasových vzorků. Výstupní kvalita těchto hlasů je na velmi dobré úrovni.

Komerční hlasy s vysokou kvalitou:

  • Acapela Group (demo)
  • Alfanum (demo)
  • Cepstral (demo)
  • IVONA (demo)
  • Nuance/Cerence (demo)
  • ReadSpeaker (demo)
  • Speechtech (demo)

V případě zájmu o zakoupení hlasové syntézy Speechtech se neváhejte obrátit na e-mailovou adresu obchod@adaptech.cz.

Microsoft Speech Platform

Microsoft Speech Platform je další možností pro vývoj a používání hlasových syntéz. Sestává z knihovny samotného rozhraní a knihoven pro rozpoznávání řeči a její syntézu. K dispozici jsou oddělené spustitelné soubory jazyků pro rozpoznávání a syntézu řeči. Verze jazyků musí odpovídat verzi Speech Platform, jež máte instalovánu.

Microsoft speech Platform nainstalujete následujícím způsobem:

  1. Stáhněte a nainstalujte Speech Platform Runtime
    (soubor 'x86_SpeechPlatformRuntime\SpeechPlatformRuntime.msi').
  2. Stáhněte a nainstalujte Jazykové balíčky pro použití se Speech Platform
    (názvy souborů začínající 'MSSpeech_TTS_').

Microsoft Speech Platform (verze 11.0) přináší podporu 26 jazyků a s nimi souvisejících hlasových syntéz. Značky XML jsou použitelné jak pro hlasy SAPI 5, tak pro Speech Platform.


Příkazový řádek

Balabolku lze ovládat i pomocí parametrů příkazového řádku.

balabolka.exe [-parametry] [název souboru] [zvukový soubor] [hlas]

Parametr hlas musí být definován následovně:

Jméno hlasu [rrychlost] [pvýška]

název souboru
otevřít soubor

-c
číst obsah schránky

-c jméno hlasu
zvolit příslušný hlas a číst obsah schránky

-m
spustit minimalizovaný

-r název souboru
otevřít soubor a číst od začátku

-r název souboru jméno hlasu
otevřít soubor, zvolit hlas a číst od začátku

-s název souboru zvukový soubor
otevřít soubor a číst do zvukového souboru (WAV, MP3, MP4, OGG či WMA)

-s název souboru zvukový soubor jméno hlasu
otevřít soubor, zvolit hlas a číst do zvukového souboru

-q
po skončení čtení ukončit program

Jméno hlasu může být určeno pouze jedním slovem, např. Mirek. Program automaticky vybere příslušný hlas ze seznamu všech sAPI 4 a sAPI 5 hlasů, instalovaných v systému.

Následující parametry lze použít současně:

-rm název souboru
spustit minimalizovaný a číst určený soubor

-rq název souboru
číst určený soubor a následně ukončit program

Příklady:

balabolka.exe kniha.txt

balabolka.exe kniha.txt mirek

balabolka.exe -rmq kniha.txt

balabolka.exe -sq "d:\knihy\kniha.txt" "d:\zvukové knihy\kniha.wav"

balabolka.exe -r "d:\knihy\kniha.txt" Mirek r180 p85

balabolka.exe -c Mirek

Namísto názvu souboru lze zadat i textový řetězec, je však třeba použít speciální modifikátor:

-n [řetězec]
tento parametr určuje, že příkazový řádek obsahuje textový řetězec namísto názvu souboru

Příklad:

balabolka.exe -n "textový řetězec"

balabolka.exe -rn "Program přečte tento text." Mirek

balabolka.exe -snq "Tento text bude uložen do zvukového souboru." "d:\zvukové knihy\kniha.mp3"


Kontrola pravopisu

Balabolka zahrnuje modul pro kontrolu pravopisu Common Speller API (CSAPI). CSAPI bylo vytvořeno pro použití se všemi aplikacemi společnosti Microsoft, jež obsahují kontrolu pravopisu. Aktuálně je CSAPI nabízeno mnoha výrobci a používáno jako součást Microsoft Office 97/2000 a dalších aplikací. Samotné CSAPI není přímou součástí Balabolky, nicméně máte-li instalován Microsoft Office, Balabolka automaticky detekuje přítomnost CSAPI a použije ho pro kontrolu pravopisu.

V okně programu lze použít kontextovou nabídku nástroje pro kontrolu pravopisu. Klikněte pravým tlačítkem na zvýrazněné slovo. Zobrazí se kontextová nabídka, jež vám umožní vybrat správné nahrazení pro opravu pravopisu uvedeného slova. Položka Přidat slovo do slovníku přidá dané slovo do uživatelského slovníku. Nenacházejí-li se ve slovníku návrhy pro opravu daného slova, v kontextové nabídce nebude nic zobrazeno.

Pro kontrolu pravopisu je možné použít rovněž příslušný dialog (položka menu 'Text / Kontrola pravopisu"). Následuje popis tlačítek tohoto dialogu:

  • Nahradit – nahradí aktuální slovo jeho opravenou variantou, vybranou v poli 'Návrhy'.
  • Nahradit vše – nahradí všechny výskyty vybraného slova v textu jeho opravenou variantou, vybranou v poli 'Návrhy'.
  • Ignorovat – přeskočí aktuální slovo a pokračuje k dalšímu výskytu chybného slova.
  • Ignorovat vše – přeskočí všechny výskyty aktuálního slova v textu a pokračuje k dalšímu výskytu chybného slova. Ignorované slovo bude následně považováno za správné po celou dobu běhu aktuální instance programu.
  • Přidat – přidá aktuální slovo do uživatelského slovníku.

'Uživatelský slovník' je textový soubor s příponou *.dic, obsahující skupinu slov. Hlavním důvodem pro uživatelský slovník je možnost definovat vlastní slova pro kontrolu pravopisu. Microsoft Office 97/2000 má uživatelský slovník v následujícím umístění: c:\Program Files\Common Files\Microsoft Shared\Proof\custom.dic.

Balabolka podporuje možnost definovat dva jazyky pro kontrolu pravopisu (zaškrtávací pole Druhý jazyk). Dialog pro kontrolu pravopisu je při použití druhého jazyka zakázán, pro kontrolu pravopisu lze použít pouze příslušnou kontextovou nabídku.

Balabolka může pro kontrolu pravopisu používatt Hunspell (hunspell.github.io). Hunspell je výchozím rozhraním pro kontrolu pravopisu v aplikacích OpenOffice.org a Mozilla Firefox.

Slovníky kontroly pravopisu pro Windows lze stáhnout na stránkách Balabolky.

Program podporuje i kontrolu pravopisu, jež je přímou součástí systému windows. Api pro kontrolu pravopisu je dostupné počínaje Windows 8.


Find and Replace Text

The program allows to search for text in the current document and replace it with different text. Most of special codes from Microsoft Word are supported for the non-printing characters (codes are case-sensitive):

^p
znaèka odstavce
^t
znak Tabulátoru
^nnn
znak ASCII (kde nnn je kód znaku)
^0 nnn
znak ANSI (kde 0 je nula a nnn je kód znaku)
^U nnnnn
znak Unicode (kde nnnnn je kód znaku)
^+
delší pomlèka (—)
^=
dlouhá pomlèka (–)
^^
znak Støíška
^s
nedìlitelná mezera
^?
kterýkoliv znak (platí pouze pro pole Najít)
^#
kterákoliv èíslice (platí pouze pro pole Najít)
^$
kterékoliv písmeno (platí pouze pro pole Najít)
^c
obsah schránky Windows (platí pouze pro pole Nahradit)
^&
obsah pole Najít (platí pouze pro pole Nahradit)


často kladené dotazy

Dotaz

Objevuje se chybová zpráva: "OLE error 80045042". Co znamená?

Odpověď

Tato chyba znamená, že Parser XML selhal kvůli špatné syntaxi. Je třeba prověřit syntaxi značek XML v textu. Je také možné, že některý úsek textu vypadá jako začátek značky XML. Nechcete-li používat značky XML, odstraňte z textu znaky "<" a ">" , případně je nahraďte slovy "menší než" a "větší než").

Dotaz

Kde mohu získat SAPI 4?

Odpověď

Abyste mohli používat hlasy SAPI 4, stáhněte a nainstalujte soubor Microsoft Speech API (824 kB). Můžete stáhnout a nainstalovat rovněž Microsoft Ovládací panel hlasů (840 kB). Ovládací panel hlasů SAPI 4 přidá ikonu do vašich Ovládacích panelů a umožní vám získat seznam instalovaných SAPI 4 hlasů a nastavovat jejich parametry.

Dotaz

Kde lze získat SAPI 5?

Odpověď

Windows XP a vyšší již SAPI 5 obsahují.

Dotaz

Jak zjistím, které hlasové syntézy mám instalované v počítači?

Odpověď

Všechny hlasové syntézy instalované v počítači jsou viditelné v ovládacím panelu převodu textu na řeč.

Dotaz

Jak mohu zajistit tichou instalaci Balabolky?

Odpověď

K instalaci Balabolky v tichém režimu můžete použít tichou instalaci. Tichá instalace je proveditelná pomocí parametru příkazového řádku -silent.

Dotaz

Otevírám soubor s příponou DjVu, nicméně program nezobrazuje žádný text. Co je špatně?

Odpověď

Formát DjVu byl vytvořen pro ukládání naskenovaných dokumentů. Soubor DjVu obsahuje obrazy stránek knih, časopisů atp. DjVu může rovněž obsahovat textovou vrstvu OCR.

Balabolka extrahuje text pouze z této vrstvy. Není-li přítomna, jedinou cestou k získání textu je použití externího programu pro zpracování OCR, např. FineReaderu.

Dotaz

V mém počítači jsou instalované dvě zvukové karty. Jak vybrat zařízení pro přehrávání syntézy textu?

Odpověď

Příslušné zařízení lze vybrat v Ovládacím panelu Převodu textu na řeč použitím tlačítka Zvukový výstup. Balabolka rovněž obsahuje položku hlavní nabídky 'Možnosti / Zvukový výstup'.

Dotaz

V mém počítači je instalována 64bitová verze Windows. Nainstaloval jsem 64bitovou verzi balíčku pro Microsoft Speech Platform a anglické hlasy. Nicméně seznam dostupných hlasů je stále prázdný. Kde je problém?

Odpověď

Balabolka je 32bitová aplikace. Pro funkčnost rozhraní Speech Platform je tedy třeba nainstalovat jeho 32bitovou verzi.

Dotaz

Hlas říká slovo "mezera" vždy, když text obsahuje nedělitelnou mezeru (ALT+0160). Jak to opravit?

Odpověď

Program může nedělitelné mezery automaticky nahrazovat běžnými mezerami. Zvolte položku hlavní nabídky 'Možnosti / Nastavení' a na kartě Čtení zaškrtněte pole Ignorovat znaky během čtení. Následně přidejte symbol nedělitelné mezery do seznamu ignorovaných znaků stiskem ALT a napsáním "0160" na numerickém bloku.

Dotaz

Jak mohu odstranit pomlčky na začátku odstavců?

Odpověď

Můžete použít položku hlavní nabídky 'úpravy / Nahradit". Do pole Najít napište ^p— a do pole Nahradit ^p. Program podporuje většinu speciálních kódů aplikace Microsoft Word:

^p
značka odstavce
^t
znak Tabulátoru
^nnn
znak ASCII (kde nnn je kód znaku)
^0 nnn
znak ANSI (kde 0 je nula a nnn je kód znaku)
^U nnnnn
znak Unicode (kde nnnnn je kód znaku)
^+
delší pomlčka (—)
^=
dlouhá pomlčka (–)
^^
znak Stříška
^s
nedělitelná mezera
^?
kterýkoliv znak (platí pouze pro pole Najít)
^#
kterákoliv číslice (platí pouze pro pole Najít)
^$
kterékoliv písmeno (platí pouze pro pole Najít)
^c
obsah schránky Windows (platí pouze pro pole Nahradit)
^&
obsah pole Najít (platí pouze pro pole Nahradit)

Dotaz

Co je Převod textu na řeč Google?

Odpověď

V překladači Google na webu je k dispozici tlačítko 'Poslech', jež převede přeložený text na řeč. Po stisknutí tohoto tlačítka začne váš webový prohlížeč stahovat soubor Mp3. Tato služba podporuje převod textu ne delšího než 100 znaků. Balabolka je schopna rozdělit větší text na malé úseky, z každého vytvořit zvukový soubor a ty následně opět spojit. Jsou podporovány formáty WAV, MP3 a OGG.

Dotaz

Pro převod titulků na zvukové soubory používám hlasy Espeak. Nicméně výsledný zvukový soubor obsahuje pouze hlas bez pomlk. Kde je problém?

Odpověď

Důrazně nedoporučuji pro převod titulků používat hlasy Espeak! Tyto hlasy nepodporují značku XML "silence". Tentýž problém se vyskytoval u starších verzí některých dalších hlasů. Pro převod titulků doporučuji používat nejlépe poslední verze komerčních hlasových syntéz (Cepstral, CereProc, IVONA, Speechtech atp.).

Dotaz

Nejsem spokojen s úrovní, na níž Balabolka extrahuje text ze souborů PDF. Mohu zpracovávat PDF nějakým jiným způsobem?

Odpověď

Extrakce textu z PDF dokumentů je komplikovaná, protože soubory PDF často neobsahují prostý text. Pro extrakci lze použít externí utilitu, např. program pdftotext.exe Xpdf. Soubor pdftotext.exe zkopírujte do podsložky "Utils" ve složce Balabolky, zvolte položku hlavní nabídky 'Možnosti / Import textu', karta 'Pokročilý import textu' a klikněte na tlačítko Přidat. Následně zadejte příkaz pro použití programu pdftotext.exe:

%BFolder%\utils\pdftotext.exe -q -nopgbrk -enc UTF-8 %Input% %Output%

Zadejte název konvertoru (např. "Konvertor XPDF"), příponu souborů ("PDF") a výstupní kódování ("UTF-8"). Po zaškrtnutí položky Použít namísto výchozí metody převodu pro tento typ souborů bude program schopen pro extrakci textu ze souborů PDF použít tuto externí utilitu.

Dotaz

Co je Spritz-Reader?

Odpověď

Spritz je nová technologie rychlého čtení. Podporuje rychlé čtení kdekoliv, při rychlostech od 100 do 1000 slov za minutu. Při běžném čtení je časově nejnáročnější hlavně pohyb očí mezi slovy a větami. Spritz zobrazuje slova na obrazovce způsobem, při němž je možné číst s co největším vyloučením pohybu očí.

Dotaz

Windows 10 obsahují nové hlasy Microsoft Jakub Mobile a Microsoft Zira Mobile, avšak v seznamu hlasů nejsou dostupné. Lze tyto hlasy nějak odemknout?

Odpověď

Ve výchozím stavu jsou hlasy Microsoft mobile uzamčeny pro použití přes SAPI 5. Odemknout je můžete jednoduchou úpravou registru. Stáhněte tento archiv, rozbalte soubor odpovídající vašemu jazyku a vaší verzi systému Windows ("mobile_x86.reg" pro 32bitovou a "mobile_x64.reg" pro 64bitovou verzi). Po uplatnění příslušného souboru budou hlasy Microsoft Mobile odemčeny pro použití přes běžné SAPI.

Dotaz

Některé dokumenty obsahují dlouhé adresy URL. Jak lze zajistit, aby Balabolka tyto adresy četla krátce?

Odpověď

Tento problém může být vyřešen použitím slovníku pro úpravu výslovnosti. Do souboru s příponou REX přidejte následující pravidlo:

((http|ftp|https)://)?(www\.)?([-a-zA-Z0-9@:%._\+~#\=]{2,256}\.[a-z]{2,6}\b)([-a-zA-Z0-9@:%_\+.~#?&//\=]*)=$4

Regulární výraz nahradí webovou adresu jménem domény (např. "adaptech.cz").

Dotaz

Mohu použít první řádek textu jako název zvukového souboru (např. "01 část 1.mp3", "02 část 2.mp3")?

Odpověď

Do pole "Vzor pro výstupní soubor" v okně "Převést a rozdělit na zvukové soubory" zapište %FirstLine%. Program nahradí tuto proměnnou prvním řádkem každého úseku textu. Pro změnu pozice pořadového čísla v názvu souboru použijte proměnnou %Number%.

Dotaz

Co je rozhraní IFilter?

Odpověď

Rozhraní IFilter pracuje s textovými dokumenty. Nabízí filtry pro extrakci textu z proprietárních formátů. Toto rozhraní používají např. fulltextové vyhledávače. IFiltry jsou dostupné pro Adobe PDF, WordPerfect a mnohé další populární formáty souborů. Instalační soubory I-filtrů lze získat od příslušných výrobců. Více informací lze získat např. na stránkách IFilter.org. Protože je Balabolka 32bitová aplikace, instalujte pouze 32bitové verze I-filtrů.

Dotaz

Jak změním hlas během čtení?

Odpověď

Použijte značky XML. Počáteční a koncovou značku je doporučeno zapisovat v rámci stejného odstavce. Příklad:

<voice required="Name=Jakub">Ahoj, jak se vede?</voice>
<voice required="Name=Mirek">Mám se fajn.</voice>

Dotaz

Mohu soubory vytvořené Balabolkou použít ve videích na YouTube?

Odpověď

Balabolka je freeware, takže zvukové soubory můžete vytvářet zdarma. Nicméně používáte-li komerční hlasy, budete muset kontaktovat výrobce příslušného hlasu a zakoupit licenci pro komerční použití či distribuci zvuku. Licence pro distribuci zvuku vám umožní použít hlas ve videích na Youtube.

Příkladem může být informace na stránkách společnosti Cepstral: "Osobní hlasy Cepstral jsou určeny pouze pro osobní použití a nejsou určeny pro distribuci zvuku. To znamená, že zvuky, které vytvoříte, jsou určeny pouze pro vaše osobní použití a nesmějí být sdíleny s dalšími osobami ani použity ve videích, prezentacích či na webových stránkách. Máte-li zájem o licenci pro distribuci zvuku, kontaktujte prosím prodejce."


Pravidla nahrazení

Panel slovníků

Za účelem zlepšení výslovnosti lze v programu použít speciální textový soubor (slovník) s pravidly nahrazení. Každý řádek tohoto souboru obsahuje jedno pravidlo nahrazení. Pravidla mohou být regulární výrazy (soubory s příponou *.rex) či vzory (soubory s příponou *.dic). Soubory s příponou *.bxd sdružují možnosti obou předchozích formátů.

Zvolí-li uživatel možnost 'číst', Balabolka dle použitých slovníků zjistí, která slova v textu vyžadují úpravu výslovnosti, a použije příslušná pravidla nahrazení. Upravený text je následně odeslán hlasové syntéze k jeho přečtení.

Pro zobrazení seznamu programem používaných slovníků použijte položku menu 'Vzhled / Zobrazit / Panel slovníků' či stiskněte klávesu F11. Napravo v hlavním okně se zobrazí seznam názvů souborů, rozdělený na dvě části:

  • Horní část – soubory se seznamy nahrazení
  • Dolní část – soubory se seznamy homografů

Různé hlasy mohou používat různé seznamy nahrazení. Požadované soubory lze vybrat z příslušného seznamu.

Pro vytvoření nového slovníku klikněte pravým tlačítkem na panel slovníků a v kontextové nabídce zvolte položku 'Nový'. Následně zadejte název souboru nového slovníku. Soubor bude uložen a jeho název se objeví v seznamu na panelu slovníků.

Chcete-li upravit seznam nahrazení, stačí v něm vybrat příslušný soubor a zvolit tlačítko 'Upravit'. Otevře se okno úprav seznamu nahrazení. Pro přidání nového pravidla nahrazení zadejte příslušné údaje do polí 'číst toto:' 'jako toto:' a stiskněte tlačítko 'Přidat'. Po přidání pravidel dokončete tento proces použitím tlačítka 'Uložit' a zavřete okno úprav.

Obecný seznam pravidel

Je-li v seznamu vybráno více souborů, pravidla z těchto slovníků budou programem automaticky sdružena do seznamu, umístěném v operační paměti počítače. Pro zobrazení tohoto seznamu klikněte pravým tlačítkem na panel slovníků a v kontextové nabídce zvolte položku 'Zobrazit seznam'.

Sdružování více slovníků do společného seznamu probíhá následovně:

  • Pravidla ze souborů s příponou *.bxd jsou přidána jedno po druhém, dle jejich umístění v souboru. Soubory jsou zpracovávány podle abecedy.
  • Totéž platí pro zpracování souborů s příponou *.rex.
  • Všechna pravidla ze souborů s příponou *.dic jsou přidávána dle prvního výskytu. Nejdříve pravidla rozlišující velikost písma, následně pravidla, jež velikost písma nerozlišují. Poté jsou pravidla znovu seřazenadle délky vzoru, delší jako první.

Pořadí pravidel v seznamu je důležité v případech, kdy může být použito více pravidel na stejné slovo v textu. Balabolka používá sekvenční nahrazování. To znamená, že druhé pravidlo v seznamu bude použito na text již upravený prvním pravidlem. Pořadí pravidel je proto velmi důležité.

Pravidla ze souborů s příponou *.rex budou použita přednostně. Pro kontrolu výsledku aplikace pravidel na aktuální dokument použijte položky hlavní nabídky 'Možnosti / Úprava výslovnosti / Zobrazit upravený text' a 'Možnosti / Úprava výslovnosti / Statistika nahrazení'.

Další nástroje

Pro nalezení dvojic pravidel aplikovaných na stejný text zvolte položku nabídky 'Možnosti / Úprava výslovnosti / Najít dvojice pravidel'. Zobrazí se pravidla, jež nebyla použita (pro úpravu příslušného textu již bylo použito jiné pravidlo).

Tyto úpravy jsou potřebné nejčastěji pro úpravu výslovnosti jmen osob, míst či zvířat, přezdívek, názvů organizací atp. Vyhledání těchto slov může být zajištěno použitím položky hlavní nabídky 'Možnosti / Úprava výslovnosti / Najít jména v textu'. Balabolka následně zobrazí tři seznamy s nalezenými slovy:

  • jména (slova vždy začínající velkým písmenem)
  • všechna slova začínající velkým písmenem
  • všechna slova nalezená v aktuálním dokumentu

Slova jsou při pohybu v seznamu automaticky čtena. Je-li některé slovo přečteno nesprávně, můžete vytvořit příslušnou úpravu výslovnosti přidáním nového pravidla do slovníku. Seznam nalezených jmen může být seřazen podle abecedy nebo podle množství výskytů v textu. Navíc lze zakázat zobrazování slov, jež se objevují v menší míře, dojde tím ke zrychlení kontroly příslušného seznamu nalezených slov.

Profily

Aktuální stav nastavení panelu lze uložit jako profil. K vytváření a úpravě profilů použijte položku hlavní nabídky 'Možnosti / Úprava výslovnosti / Profily'.


Soubory REX pro úpravu výslovnosti

Pro každý řádek souboru platí následující pravidla:

Druhá skupina znaků je fonetickým nahrazením výslovnosti první skupiny znaků.

Skupiny znaků jsou odděleny znakem 'Rovno' (=).

Berte na vědomí, že nahrazování textu probíhá v pořadí definovaném v souboru.

Příklad:

auto=vůz
vůz=kočár

auto se stane kočárem, což nemusí být žádoucí.

řádky s komentáři začínají znakem 'Křížek' (#) a jsou programem ignorovány.

První skupina znaků může obsahovat regulární výraz.

Vzory s regulárními výrazy nerozlišují velikost písma. Chcete-li definovat vzor rozlišující velikost písma, musíte na začátek řádku přidat symbol 'Dolar' ($).

Příklad:

#Ms=Mistrovství světa

Následují znaky a skupiny znaků, jež lze v tomto typu souborů použít.

Znak | Popis
\ | definuje následující znak jako řídicí, případně dává řídicímu znaku jeho původní podobu; např. "n" odpovídá znaku "n", "\n" odpovídá znaku pro nový řádek, skupina "\\" odpovídá "\", "\(" odpovídá "(" a "\=" odpovídá "="
^ | odpovídá začátku vstupu
$ | odpovídá konci vstupu
* | odpovídá předchozímu znaku 0 a vícekrát; např. "zo*" odpovídá "z" i "zoo"
+ | Odpovídá předchozímu znaku jednou a vícekrát; např. "zo+" odpovídá "zoo", ale ne "z"
? | odpovídá předchozímu znaku nula a jedenkrát; např. "o?soba?" odpovídá "sob" ve slově "osoba"
. | odpovídá kterémukoliv jednotlivému znaku s výjimkou znaku pro nový řádek
(vzor) | odpovídá vzoru a pamatuje si jeho výskyt; nalezený podřetězec lze získat použitím řídicího znaku $N, kde N je Ntý vzor uvedený v závorkách; pro získání znaků samotných závorek ( ) použijte "\(" či "\)"
x|y | odpovídá x nebo y; např. "k|slon" odpovídá "k" nebo "slon", "(s|k)lon" odpovídá "slon" nebo "klon"
{n} | n je celé kladné číslo, odpovídá přesnému počtu n; např. "d{2}" neodpovídá znaku "d" ve slově "voda", leč odpovídá dvěma znakům "d" ve slově "oddíl"
{n,} | n je celé kladné číslo, odpovídá výskytu nejméně n krát; např. "d{2,}" neodpovídá znaku "d" ve slově "voda", leč odpovídá všem znakům d ve slově "odddddíl"; "o{1,}" je totéž jako "o+"; "o{0,}" je totéž jako "o*"
{n,m} | m a n jsou celá kladná čísla, odpovídá nejméně n a maximálně m výskytů; např. "d{1,3}" odpovídá prvním třem znakům "d" ve slově "odddddíl"; "o{0,1}" je totéž jako "o?"
[xyz] | skupina znaků, odpovídá kterémukoliv z uvedených znaků; např. "[abc]" odpovídá znaku "a" ve slově "jak
[^xyz] | negativní skupina znaků, odpovídá všem znakům, jež nejsou obsažené; např. "[^abc]" odpovídá znaku "p" ve slově "plyn"
[a-z] | rozsah znaků, odpovídá kterémukoliv znaku v uvedeném rozsahu; např. "[a-z]" odpovídá kterémukoliv malému písmenu abecedy (a–z)
[^m-z] | negativní rozsah znaků, odpovídá všem znakům mimo uvedený rozsah; např. "[m-z]" odpovídá kterémukoliv znaku mimo rozsah m –z
\b | odpovídá hranici slova, což je pozice mezi slovem a mezerou; např. "las\b" odpovídá "las" ve slově "hlas", leč neodpovídá "las" ve slově "lasička"
\B | odpovídá opačné hranici slova; např. "ply\B" odpovídá "ply" ve výrazu "plný plyn"
\d | odpovídá znaku číslice, totéž jako [0-9]
\D | odpovídá kterémukoliv znaku, jenž není číslicí, totéž jako [^0-9]
\f | odpovídá znaku konce strany
\n | odpovídá znaku nový řádek
\r | odpovídá znaku návrat vozíku
\s | odpovídá všem oddělovačům (mezera, tabulátor, konec strany atp.), totéž jako "[ \f\n\r\t\v]"
\S | odpovídá všem znakům, jež nejsou oddělovač, totéž jako "[^ \f\n\r\t\v]"
\t | odpovídá znaku tabulátor
\v | odpovídá znaku svislý tabulátor
\w | odpovídá všem psaným znakům, včetně podtržení (_), totéž jako "[A-Za-z0-9_]"
\W | odpovídá všem krom psaných znaků, totéž jako "[^A-Za-z0-9_]"
\num | odpovídá num, kde num je kladné celé číslo; odkazujezpět na zapamatované výskyty; např. "(.)\1" odpovídá dvěma následujícím stejným znakům
\n | odpovídá n, kde n je osmičková řídicí sekvence; osmičkové řídicí sekvence musejí mít délku 1, 2 nebo 3 číslice; např. "\11" a "\011" obě odpovídají znaku tabulátor; "\0011" je totéž jako "\001" & "1"; osmičkové řídicí sekvence nesmějí přesáhnout hodnotu 256, pokud se tak stane, odpovídají výrazu pouze první dvě číslice; hodí se pro použití ASCII kódů v regulárních výrazech
\xn | odpovídá n, kde n je šestnáctková řídicí sekvence; šestnáctkové řídicí sekvence musejí mít délku přesně dvě číslice; např. "\x41" odpovídá "A"; hodí se pro použití ASCII kódů v regulárních výrazech
\x{n} | odpovídá n, kde n je šestnáctková řídicí sekvence; šestnáctkové řídicí sekvence musejí mít délku přesně dvě číslice; např. "\x{00dc}" odpovídá "Ü"; hodí se pro použití kódů Unicode v regulárních výrazech

Balabolka podporuje speciální operátory pro převod textu na malá či velká písmena.

Operátor | Popis
\U | Převede všechny následující znaky až do dalšího \L či \E na velká písmena.
\L | Převede všechny následující znaky až do dalšího \U či \E na malá písmena.
\E | Vypne převod velikosti písma.
\u | Převede následující znak na velké písmeno.
\l | Převede následující znak na malé písmeno.

Příklad:

(test)=\U$1\E

Převede "test" na "TEST".


Soubory Dic pro úpravu výslovnosti

Pro každý řádek souboru platí následující pravidla:

Druhá skupina znaků je fonetickým nahrazením výslovnosti první skupiny znaků.

Skupiny znaků jsou odděleny znakem 'Rovno' (=).

řádky s komentáři začínají znakem 'Křížek' (#) a jsou programem ignorovány.

Vzory nejsou citlivé na velikost písma. Chcete-li definovat vzor citlivý na velikost písma, musíte na začátek řádku přidat symbol 'Dolar' ($).

Příklad:

#Ms=Mistrovství světa

Ve výchozím stavu vzor odpovídá slovu či více slovům. Pro určení vztahu i k dalším znakům kolem vzoru použijte znak Hvězdička (*).

Příklad:

fys*=fyz

Tento vzor odpovídá vyřešení dříve psaných pojmů "Fysika", "fysický" atp. Dva po sobě následující speciální symboly ("#", "*", "=", "$") vyjadřují příslušný znak v jeho původní podobě.

Příklad:

**=hvězdička


Homografy

Některá slova, nazývaná homografy či homogramy, představují jeden z největších problémů pro systémy TTS. Homografy jsou zapsány stejně, avšak liší se ve významu a obvykle i ve výslovnosti. Příkladem může být slovo city. V českém kontextu je vyslovováno jako city, nicméně v anglickém jako sity. V češtině se čisté homografy vyskytují tam, kde je jedno ze slov cizího původu a zachovalo si alespoň částečně neobvyklou výslovnost. Příkladem může být slovo panický (vychází ze slov panic i panika).

U těchto typů slov je k dosažení správné výslovnosti potřeba dalších sémantických informací.

Výslovnost téhož slova může být odlišná rovněž z důvodu různého kontextu.

Heteronyma jsou speciálním druhem homografů. Jedná se o slova, jež jsou stejně zapsána, avšak liší se ve významu i ve výslovnosti. Všechna heteronyma jsou zároveň homografy, avšak ne všechny homografy jsou heteronymy. Mnoho heteronym spolu souvisý svým významem, zatímco jiná jsou kompletně odlišná.

Hledání správné výslovnosti vlastních jmen, především jsou-li převzata z dalších jazyků, je jedním z nejtěžších úkolů pro systémy TTS. Některá jména, např. Jim či Nice, jsou mnohoznačná i vzhledem ke kontextu závislém na velikosti písma, včetně pozice na začátku věty, jmen jako takových či samostatných slov. Např. věta Jim jim poskytl Gin je velmi problematická, protože slovo jim může být vysloveno jako /jim/ nebo /Džim/. Některá jména a místa mají rovněž speciální výslovnost, např. Leicester či Arkansas. Za účelem úpravy výslovnosti těchto druhů slov mohou být příslušná slova zahrnuta do specifických slovníků výjimek (soubory s příponou *.hmg, např. English.hmg).

Pro každý řádek souboru platí následující pravidla:

Druhá skupina znaků je fonetickým nahrazením výslovnosti první skupiny znaků.

Skupiny znaků jsou odděleny znakem 'Rovno' (=).

Výslovnosti jsou odděleny čárkami.

Příklad:

jim=jim,džim

Vzory nejsou citlivé na velikost písma. Chcete-li definovat vzor citlivý na velikost písma, musíte na začátek řádku přidat symbol 'Dolar' ($).

Příklad:

$Jim=džim,Jim

Balabolka podporuje seznamy výrazů pro každý homograf (karta "Výrazy s homografy" v editoru homografů). Tyto výrazy budou automaticky nahrazeny během vyhledávání homografů (položka hlavní nabídky 'Text / Najít homografy').

Příklad:

city=city,sity

žádné city=city
Manchester City=sity

Rozlišuje-li výraz velikost písma, musíte na začátek textu přidat symbol Dolar ($):

$Nice=Niis,Nais

$město Nice=Niis
nice to have=najs

Znak Hvězdička "*" může být použit namísto kteréhokoliv slova či jednoho a více znaků :

city=city,sity

nechci * hrát na city=city


Ovládací značky (SAPI 4)

Tato kapitola popisuje ovládací značky hlasové syntézy, jež mohou být vloženy do textu za účelem zlepšení výslovnosti čteného textu.

  • Zápis
  • Konvence
  • Chr
  • Com
  • Ctx (Tuto značku některé syntézy nemusejí podporovat.)
  • Dem (Nové v SAPI 4.0 – Tuto značku některé syntézy nemusejí podporovat.)
  • Emp (Tuto značku některé syntézy nemusejí podporovat.)
  • Eng
  • Mrk
  • Pau
  • Pit
  • Pra (Nové v SAPI 4.0 – Tuto značku některé syntézy nemusejí podporovat.)
  • Prn (Tuto značku některé syntézy nemusejí podporovat.)
  • Pro (Tuto značku některé syntézy nemusejí podporovat.)
  • Prt (Tuto značku některé syntézy nemusejí podporovat.)
  • RmS (Nové v SAPI 4.0 – Tuto značku některé syntézy nemusejí podporovat.)
  • RmW (Nové v SAPI 4.0 – Tuto značku některé syntézy nemusejí podporovat.)
  • RPit (Nové v SAPI 4.0 – Tuto značku některé syntézy nemusejí podporovat.)
  • RPrn (Nové v SAPI 4.0 – Tuto značku některé syntézy nemusejí podporovat.)
  • RSpd (Nové v SAPI 4.0 – Tuto značku některé syntézy nemusejí podporovat.)
  • Rst (Nové v SAPI 4.0)
  • Spd
  • Vce (Tuto značku některé syntézy nemusejí podporovat.)
  • Vol

Hlasová syntéza obvykle úspěšně převádí na mluvenou řeč samostatná slova. Avšak jakmile syntéza vyslovuje konkrétní větu, kvalita převodu klesá, protože syntéza často nemůže přesně napodobit rytmus, modulaci, přízvuk či přesné načasování lidské řeči.

Projev výsledného hlasu může být vylepšen použitím ovládacích značek hlasové syntézy za účelem lepšího napodobení skutečného znění lidského hlasu.

Tato kapitola popisuje ovládací značky, které mohou být použity pro změnu parametrů převodu textu na řeč. Všechny značky jsou volitelné s výjimkou záložky (značka Mrk), která musí být podporována.

Zápis

Ovládací značky hlasové syntézy se řídí těmito obecnými pravidly zápisu:

  • Všechny značky začínají a končí znakem zpětné lomítko (\).
  • Znak zpětné lomítko (\) není možné použít uvnitř značky.
  • Lichý počet zpětných lomítek (\) v označeném textu vede k nedefinovanému chování rozhraní.
  • Značky nerozlišují velikost písma. Např. \vce\ je totéž jako \VCE\.
  • Značky rozlišují mezery. Např. \Rst\ není totéž jako \ Rst \.

Pro vložení znaku zpětného lomítka (\) do označeného textu, avšak mimo samotnou značku, použijte dva znaky zpětného lomítka (\\).

Chce-li program přečíst např. název souboru "c:\windows\system\test.txt", měly by znaky zpětných lomítek (\) být zdvojeny takto: "c:\\windows\\system\\test.txt").

Příklady:

  • code\ ctx="e-mail" \ – bude zpracováno jako značka "e-mail".
  • \ctx="e-mail" – bude ignorováno, protože jde o neuzavřenou značku na konci dokumentu.
  • \\ctx="e-mail"\\ – vysloví "Backslash c t x equals e-mail back-slash".
  • \\\\\\\\ctx="e-mail"\\\\\\\\ – vysloví "backslash backslash backslash backslash c t x equals e-mail backslash backslash backslash backslash".
  • \ctm="e-mail"\ – bude ignorováno, protože jde o neznámou značku.

Narazí-li hlasová syntéza na neznámou značku, bude tato značka ignorována.

Konvence

V této sekci se používají následující typografické konvence.

Příklad | Popis
Chr | Použití tučného písma indikuje klíčová slova změny tónu řeči.
string | Použití kurzívy indikuje zástupné symboly pro informaci, kterou poskytujete vy, např. řetězec znaků nebo kontextový řetězec.
[[option]] | Dvojité hranaté závorky indikují volitelné položky.
[[option...]] | Tři tečky (značka výpustky) následující za položkou indikují, že mohou následovat další položky stejného typu.
"C" | Uvozovky se používají pro uzavření řetězců.

Chr

\Chr=string[[,string...]]\

Nastaví charakter hlasu.

Příklad: \Chr="Angry"\

Parametr | Popis
string | Řetězec, který specifikuje charakter hlasu.

Jako výchozí charakter hlasu je nastavena hodnota "Normální" a hlas bude znít normálním tónem. Ačkoli značka Chr neumožňuje tak specifické nastavení jako v případě, kdy změny tónu, přízvuk, nástup hlasivkového tónu nebo kvalita šepotu jsou nastavovány samostatně, je použití tohoto nastavení jednodušší a hlasová syntéza s ním poskytuje flexibilnější a inteligentnější odpověď.

V rámci jedné značky lze specifikovat několik charakterů hlasu oddělených čárkami. V závislosti na svých schopnostech nemusí hlasová syntéza podporovat všechny charaktery hlasu, které jsou zde uvedeny, nebo může naopak podporovat i zde neuvedené charaktery hlasu. Mezi běžné charaktery hlasu patří následující:

"Angry", "Business", "Calm", "Depressed", "Excited", "Falsetto", "Happy", "Loud", "Monotone", "Perky", "Quiet", "Sarcastic", "Scared", "Shout", "Tense", "Whisper"

Com

\Com=string\

Vloží do textu komentář. Komentáře nejsou převáděny na řeč.

Příklad: \com="Toto je komentář."\

Parametr | Popis
string | Text komentáře

Ctx

\Ctx=string\
Poznámka: Některé hlasové syntézy nemusí tuto značku podporovat.

Nastaví kontext pro text, který následuje, a ten určí, jak mají být symboly vysloveny.

Příklad: \ctx="Unknown"\

Parametr | Popis
string | Řetězec, který určuje kontext.

Tímto parametrem může být jeden z následujících řetězců:

Kontextový řetězec | Popis
"Address" | Adresy nebo telefonní čísla
"C" | Kód v programovacím jazyce C nebo C++
"Document" | Textový dokument
"E-Mail" | E-mail
"Numbers" | Čísla, data, časy atd.
"Spreadsheet" | Tabulkový dokument
"Unknown" | Kontext je neznámý (výchozí)
"Normal" | Normální/výchozí režim řeči

Dem

\Dem\
Poznámka: Některé hlasové syntézy nemusí tuto značku podporovat.

Další slovo vysloví bez důrazu.

Emp

\Emp\
Poznámka: Některé hlasové syntézy nemusí tuto značku podporovat.

Další slovo vysloví s důrazem.

Příklad: the \Emp\truth, the \Emp\whole truth, and nothing \Emp\but the truth.

Eng

\Eng;GUID:command\
\Eng:command\

Vloží příkaz specifický pro konkrétní hlasovou syntézu, který ovlivní pouze hlasovou syntézu s konkrétním globálně jedinečným identifikátorem (GUID). U dalších následných značek určených pro danou hlasovou syntézu lze GUID vynechat. Je třeba ho uvést až pro značku, která je určena pro jinou hlasovou syntézu.

Parametr | Popis
GUID | Globálně jedinečný identifikátor hlasové syntézy
command | Příkaz určený speciálně pro zadanou hlasovou syntézu

Mrk

\Mrk=number\

Indikuje záložku v textu.

Příklad: \Mrk=75000\

Parametr | Popis
number | Číslo záložky

Značka Mrk akceptuje desítkovou soustavu. Záložka s číslem nula (\Mrk=0\) je vyhrazena.

Pau

\Pau=number\

Pozastaví hlasový výstup po zadanou dobu v milisekundách.

Příklad: \Pau=1000\

Parametr | Popis
number | Počet milisekund, po který se má hlasový výstup pozastavit.

Pit

\Pit=number\

Nastaví základní hodnotu výšky hlasu režimu převodu textu na řeč na hodnotu zadanou v hertzích (Hz).

Příklad: \Pit=90\

Parametr | Popis
number | Výška hlasu v hertzích

Skutečná výška hlasu se pohybuje nad a pod touto základní hodnotou.

Pra

\Pra=value\
Poznámka: Některé hlasové syntézy nemusí tuto značku podporovat.

Nastaví rozsah výšky hlasu.

Parametr | Popis
value | Rozsah výšky hlasu v hertzích

Prn

\Prn=text=pronunciation\
Poznámka: Některé hlasové syntézy nemusí tuto značku podporovat.

Poskytuje hlasové syntéze fonetický ekvivalent určitého textu.

Příklad: \Prn=tomato=tomaato\

Parametr | Popis
text | Text, který se má vyslovit.
pronunciation | Fonetický ekvivalent pro vyslovení určitého textu

Použijete-li značku Prn bez zadání výslovnosti slova (\Prn=text\), vrátí se změny výslovnosti zpět; to znamená, že slovo bude vysloveno s původní výslovností.

Tato značka je platná pouze pro hlasové syntézy, které podporují mezinárodní fonetickou abecedu. Hlasová syntéza by měla novou výslovnost nadále používat v aktuálním režimu převodu textu na řeč a měla by ji uložit do svého slovníku pro pozdější použití. Pokud již položka ve slovníku pro dané slovo existuje, značka Prn bude pro dané slovo ignorována.

Pro

\Pro=number\
Poznámka: Některé hlasové syntézy nemusí tuto značku podporovat.

Aktivuje a deaktivuje prozodická pravidla, která ovlivňují výšku hlasu, rychlost řeči a hlasitost nezávisle na ovládacích značkách vložených v textu. Prozodická pravidla jsou aplikována hlasovou syntézou.

Příklad: \Pro=0\

Parametr | Popis
number | Číslo, které označuje, zda se mají prozodická pravidla aktivovat nebo deaktivovat. Nastavení čísla 1 (výchozí nastavení) prozodická pravidla aktivuje. Nastavení čísla 0 prozodická pravidla deaktivuje.

Prt

\Prt=string\
Poznámka: Některé hlasové syntézy nemusí tuto značku podporovat.

Určuje slovní druh následujícího slova.

Příklad: \prt= "Abbr" \

Parametr | Popis
string | Řetězec, který označuje slovní druh.

Tímto parametrem může být jeden z následujících řetězců:

String | Popis
"Abbr" | Zkratka
"Adj" | Přídavné jméno
"Adv" | Příslovce
"Card" | Základní číslovka
"Conj" | Spojka
"Cont" | Stažený tvar
"Det" | Determinátor
"Interj" | Citoslovce
"N" | Podstatné jméno
"Ord" | Řadová číslovka
"Prep" | Předložka
"Pron" | Zájmeno
"Prop" | Vlastní jméno
"Punct" | Znaménko
"Quant" | Kvantifikátor
"V" | Sloveso

RmS

\RmS=number\
Poznámka: Některé hlasové syntézy nemusí tuto značku podporovat.

Nastaví režim čtení na hláskování každého písmene každého slova nebo jej vypne. Tuto značku nepodporují všechny hlasové syntézy. Konzistentnější výsledky lze tedy získat spíše standardizací vlastního textu a uvedením mezer mezi písmeny.

Parametr | Popis
number | Číslo, které udává, zda se má hláskovat každé písmeno každého slova. Číslo 1 nastaví režim čtení na hláskování každého písmene každého slova. Číslo 0 (výchozí nastavení) režim hláskování každého písmene každého slova deaktivuje.

RmW

\RmW=number\
Poznámka: Některé hlasové syntézy nemusí tuto značku podporovat.

Nastaví slyšitelnou pauzu mezi jednotlivá slova nebo tuto funkci vypne. Tuto značku nepodporují všechny hlasové syntézy. Konzistentnější výsledky lze tedy získat spíše standardizací vlastního textu a vložením mezer mezi slova.

Parametr | Popis
number | Číslo, které udává, zda se má mezi jednotlivá slova vložit slyšitelná pauza. Číslo 1 nastaví režim čtení na vložení slyšitelné pauzy mezi jednotlivá slova. Číslo 0 (výchozí nastavení) režim vložení slyšitelné pauzy mezi jednotlivá slova deaktivuje.

RPit

\RPit=value\
Poznámka: Některé hlasové syntézy nemusí tuto značku podporovat.

Nastaví relativní výšku hlasu.

Parametr | Popis
value | Relativní výška hlasu. Výchozí/původní nastavení pro hlas je 100.

RPrn

\RPrn=value\
Poznámka: Některé hlasové syntézy nemusí tuto značku podporovat.

Nastaví rozsah relativní výšky hlasu.

Parametr | Popis
value | Rozsah relativní výšky hlasu. Výchozí/původní nastavení pro hlas je 100.

RSpd

\RSpd=value\
Poznámka: Některé hlasové syntézy nemusí tuto značku podporovat.

Nastaví relativní rychlost řeči. Výchozí/původní nastavení pro hlas je 100.

Parametr | Popis
value | Relativní rychlost řeči. Výchozí/původní nastavení pro hlas je 100.

Rst

\Rst\

Obnoví výchozí nastavení hlasové syntézy pro aktuální režim shodné s tím, jaké měl při svém vytvoření.

Spd

\Spd=number\

Nastaví základní hodnotu průměrné rychlosti řeči režimu převodu textu na řeč na hodnotu zadanou jako počet slov za minutu.

Příklad: \Spd=120\

Parametr | Popis
number | Základní hodnota průměrné rychlosti řeči uvedená jako počet slov za minutu.

Vce

\Vce=charact=value[[,charact=value]]\
Poznámka: Některé hlasové syntézy nemusí tuto značku podporovat.

Hlasová syntéza dostane pokyn, že má změnit hlas řeči na takový hlas, který splňuje zadané charakteristiky.

Parametr | Popis
charact | Jedna z charakteristik uvedených v tabulce níže.
value | Řetězec, který specifikuje charakteristiku.

Pořadí charakteristik určuje jejich důležitost. Hlasová syntéza vybere takový hlas, který nejvíce odpovídá charakteristikám uvedeným na začátku seznamu.

Argument charact=value může být jakýkoliv z následujících:

  • Language=language. Požaduje, aby hlasová syntéza hovořila v zadaném jazyce.
  • Accent=accent. Požaduje, aby hlasová syntéza hovořila se zadaným přízvukem. Pokud je například zadán jazyk = "English" a přízvuk = "French", hlasová syntéza bude hovořit anglicky s francouzským přízvukem.
  • Dialect=dialect. Požaduje, aby hlasová syntéza hovořila v zadaném dialektu.
  • Gender=gender. Nastaví, zda má hlasová syntéza hovořit mužským, ženským nebo neutrálním hlasem. "Male", "Female" nebo "Neutral".
  • Speaker=speakername. Nastaví jméno hlasu nebo hodnotu NULL, pokud jméno hlasu není důležité.
  • Age=age. Určuje stáří hlasu z níže uvedeného seznamu.
  • Style=style. Osobnost hlasu – například. "Business", "Casual", "Computer", "Excited" nebo "Singsong".
Řetězec stáří | Popis
"Baby" | Stáří asi 1 rok
"Toddler" | Stáří asi 3 roky
"Child" | Stáří asi 6 let
"Adolescent" | Stáří asi 14 let
"Adult" | Stáří mezi 20 až 60 lety
"Elderly" | Stáří asi 60 let

Vol

\Vol=number\

Nastaví základní hodnotu hlasitosti řeči pro režim převodu textu na řeč.

Příklad: \Vol=32768\

Parametr | Popis
number | Základní hodnota hlasitosti

Úroveň hlasitosti představuje lineární rozmezí od 0 (absolutní ticho) po 65535 (maximální hlasitost monofonního zvuku). Jako výchozí je nastavena hodnota 65535.

Zadáte-li hodnotu vyšší než 65535, hlasová syntéza bude předpokládat, že chcete nastavit levý a pravý kanál samostatně, a převede hodnotu na dvě hodnoty – nižší hodnotu použije pro levý kanál a vyšší hodnotu pro pravý kanál. Zadáte-li například hodnotu 65536, nastaví se pro levý kanál maximální základní hlasitost a pravý kanál bude nastaven na minimum.


Značky XML (SAPI 5)

SAPI 5 synthesis markup je kolekce rozšiřujících značek XML, jež je možné vložit do textu za účelem úpravy jeho syntézy. Tyto značky, jež přinášejí funkce jako např. ovládání hlasitosti či změnu přízvuku, jsou automaticky detekovány XML parserem rozhraní SAPI. V případě špatné struktury XML může program zobrazit chybovou zprávu.

Každý prvek XML sestává z úvodní značky <Značka> a koncové značky </Značka> a obsahu mezi těmito značkami. Značky XML nerozlišují velikost písma.

Všechny prvky XML musejí být správně vnořeny.

Nesprávné vnoření:

<značka1><značka2> text </značka1></značka2>

Správné vnoření:

<značka1><značka2> text </značka2></značka1>

Prvek XML musí být vždy otevřen i uzavřen stejnou značkou XML.

Pro vložení značek XML do textu použíjte položku hlavní nabídky 'Text / Vložit značku XML'. Počáteční a koncová značka XML bude vložena před a za vybraný text.

Značky XML SAPI se dělí do několika kategorií.

  • Ovládání stavu hlasu
  • Přímé vložení položky
  • Ovládání kontextu hlasu
  • Výběr hlasu
  • Vlastní výslovnost

Ovládání stavu hlasu

SAPI TTS XML podporuje pět značek, jež ovládají stav aktuálního hlasu (volume, rate, pitch, emph a spell).

Volume

Značka Volume ovládá hlasitost hlasu. Může být prázdná, v tom případě ovlivní všechen následující text, či má-li obsah, vztahuje se pouze na něj.

Značka Volume má jeden požadovaný atribut (Level). Jeho hodnota může být v rozsahu 0–100. Hodnoty mimo tento rozsah budou příslušně oříznuty.

<volume level="50"> Tento text bude vysloven hlasitostí 50. <volume level="100"> Tento text bude vysloven hlasitostí 100. </volume> </volume>
<volume level="80"/> Všechen následující text bude vysloven hlasitostí 80.

Hodnota 100 reprezentuje výchozí hlasitost hlasu. Nižší hodnoty určují procenta této výchozí hodnoty. Hlasitost 50 tedy odpovídá padesáti procentům celkové hlasitosti.

Rate

Značka Rate určuje rychlost hlasu. Může být prázdná, v tom případě ovlivní všechen následující text či má-li obsah, vztahuje se pouze na něj.

Značka Rate má dva atributy, Speed a AbsSpeed, musí být přítomen minimálně jeden z nich. Hodnota obou těchto atributů musí být v rozsahu -10–10. Hodnoty mimo tento rozsah budou příslušně oříznuty. Atribut AbsSpeed řídí absolutní rychlost hlasu, takže hodnota 10 vždy odpovídá hodnotě 10, hodnota 5 hodnotě 5.

<rate absspeed="5">Tento text bude přečten rychlostí 5. <rate absspeed="-5"> Tento text bude přečten rychlostí -5. </rate> </rate>
<rate absspeed="10"/> Všechen následující text bude přečten rychlostí 10.

Atribut Speed řídí relativní rychlost hlasu. Hodnota absolutní rychlosti je součtem současné rychlosti a relativní hodnoty.

<rate speed="5"> Tento text bude přečten rychlostí 5. <rate speed="-5"> Tento text bude přečten rychlostí 0. </rate> </rate>

Hodnota 0 určuje výchozí rychlost hlasu. Kladné hodnoty jsou rychlejší a záporné pomalejší.

Pitch

Značka Pitch řídí výšku hlasu. Může být prázdná, v tom případě ovlivní všechen následující text či má-li obsah, vztahuje se pouze na něj.

Značka Pitch má dva atributy, Middle a AbsMiddle, musí být přítomen minimálně jeden z nich. Hodnota obou těchto atributů musí být v rozsahu -10 - 10. Hodnoty mimo tento rozsah budou příslušně oříznuty.

Atribut AbsMiddle řídí absolutní výšku hlasu, takže hodnota 10 vždy odpovídá hodnotě 10, hodnota 5 hodnotě 5.

<pitch absmiddle="5"> Tento text bude přečten výškou 5. <pitch absmiddle="-5"> Tento text bude přečten výškou -5. </pitch> </pitch>
<pitch absmiddle="10"/> Všechen následující text bude přečten výškou 10.

Atribut Middle řídí relativní výšku hlasu. Hodnota absolutní výšky je součtem současné výšky a relativní hodnoty.

<pitch middle="5">Tento text bude přečten výškou 5. <pitch middle="-5">Tento text bude přečten výškou 0.</pitch> </pitch>

Hodnota 0 určuje výchozí výšku hlasu. Kladné hodnoty jsou vyšší a záporné nižší.

Emph

Značka Emph přikazuje hlasu zdůraznit slovo či úsek textu. Tato značka nesmí být prázdná. Následující slovo bude zdůrazněno.

<emph> haló </emph>!

Způsob zdůraznění se může lišit dle použité hlasové syntézy.

Spell

Značka Spell přikazuje hlasu hláskovat daný text namísto používání běžných pravidel pro zpracování slov a vět, pravidel normalizace textu atp. Všechny znaky včetně interpunkčních znamének, čísel a podobně by měly být nahrazeny odpovídajícími slovy. Značka nesmí být prázdná.

<spell> Tato slova budou vyhláskována. </spell>
Tato slova hláskována nebudou.

Značky pro přímé vložení položky

Pro přímé vkládání položky jsou podporovány 3 značky: Silence, Pron, a Bookmark.

Silence

Značka Silence do výstupního zvukového proudu vkládá v milisekundách definovanou pomlku. Značka musí být prázdná a musí mít jeden atribut, Msec.

500 milisekund ticha<silence msec="500"/> právě proběhlo.

Pron

Značka Pron vkládá definovanou výslovnost. Hlas zpracuje sekvenci fonémů přesně tak, jak jsou určeny. Značka může být prázdná, ale může mít i obsah. Je-li obsah přítomen, bude interpretován s definovanou výslovností.

Značka Pron má jeden atribut, Sym. Jeho hodnotou je řetězec mezerami oddělených fonémů.

<pron sym="h eh l l ow & w er l l d "/>
<pron sym="h eh l l ow & w er l l d"> hello world </pron>

Použití fonémů je popsáno zde.

Bookmark

Značka Bookmark do výstupního zvukového proudu vkládá událost záložky. Událost dává aplikaci vědět, že v textu bylo dosaženo umístění, jež odpovídá dané záložce. Značka musí být prázdná.

Značka Bookmark má jeden atribut, Mark. Jeho hodnotou je řetězec. Tato hodnota může být následně použita pro rozlišení událostí záložek. Každá z nich bude obsahovat hodnotu řetězce odpovídající příslušné značce záložky.

Zde dojde k výskytu události

<bookmark mark="záložka 1"/>

a další zde

<bookmark mark="záložka 2"/>

Značky pro ovládání kontextu hlasu

Kontext hlasu určují dvě značky: PartOfSp a Context. Díky těmto značkám může hlas určit, jak zacházet se zpracovávaným textem. Způsob zpracování obou těchto značek se může lišit v závislosti na použitém hlasu.

PartOfSp

Značka PartOfSp určuje hlasu způsob zpracování části uvedeného textu, typicky jednoho či více slov. Výsledkem je možnost vyslovit jedno slovo více způsoby v závislosti na jeho kontextu. Značka PartOfSp nesmí být prázdná.

Značka PartOfSp má jeden atribut, Part. Jeho hodnotou je řetězec, odpovídající SAPI part of speech. Jsou podporovány pouze části definované v SAPI: "Unknown", "Noun", "Verb", "Modifier", "Function", "Interjection".

<partofsp part="noun"> A </partofsp> is the first letter of the alphabet.

Did you <partofsp part="verb"> record </partofsp> that <partofsp part="noun"> record </partofsp>?

Context

Značka Context předává hlasu způsob, jímž může interpretovat speciální položky jako data, čísla či hodnoty měny. Použití této značky pomáhá příslušnému hlasu rozlišit např. rozličné interpretace formátu data. Značka Context nesmí být prázdná.

Značka Context má jeden atribut, Id. Jeho hodnotou je řetězec definující kontext určeného textu. Několik kontextů je definováno v SAPI. Tyto obecně definované kontexty by měly být platné pro všechny SAPI hlasy, nicméně lze použít kterýkoliv řetězec. Více informací vám poskytne dokumentace k příslušnému hlasu.

<context id="date_mdy"> 03/04/01 </context> bude přečteno jako March fourth, two thousand one.
<context id="date_dmy"> 03/04/01 </context> bude přečteno jako April third, two thousand one.
<context id="date_ymd"> 03/04/01 </context> bude přečteno jako April first, two thousand three.

Předdefinované typy kontextů jsou popsány zde.

Značky pro výběr hlasu

Pro výběr hlasu jsou definovány dvě značky: Voice a Lang.

Voice

Značka Voice vybírá hlas na základě jeho atributů: Age, Gender, Language, Name, Vendor, a VendorPreferred. Může být prázdná, v tom případě změní hlas pro všechen následující text, či má-li obsah, vztahuje se změna hlasu pouze na něj.

Značka Voice má dva atributy: Required a Optional. Atributy aktuálního hlasu jsou vždy přidávány jako volitelné. To znamená, že hlas, který více odpovídá aktuálnímu hlasu, bude mít při výběru přednost před méně odpovídajícími hlasy.

Není-li nalezen hlas, jenž odpovídá všem vyžadovaným atributům, ke změně hlasu nedojde.

Tato věta bude přečtena výchozím hlasem. <voice required="Gender=Female;Age!=Child"> Tuto větu přečte dospělá žena, je-li jako hlas přítomna. <voice required="Age=Teen"> Tuto větu přečte hlas s atributem Adolescent, nicméně je-li přítomen mužský i ženský hlas tohoto typu, bude ženský hlas použit přednostně. </voice> </voice>

Lang

Značka Lang vybírá hlas čistě na základě jeho atributu Language. Může být prázdná, v tom případě změní hlas pro všechen následující text, či má-li obsah, vztahuje se změna hlasu pouze na něj.

Značka Lang má jeden atribut, LangId. Jeho hodnotou je Id jazyka (LANGID), např. 405 (čeština), 41B (slovenčina), 409 (Americká angličtina) nebo 411 (japonština). Berte na vědomí, že tato čísla jsou šestnáctková, nicméně bez typického prefixu "0x".

Značka Lang je zkrácenou variantou značky Voice s vyžadovaným atributem obsahujícím "Language=xxx", takže následující příklady by měly mít stejný výsledek:

<voice required="Language=405"> Tato věta by měla být přečtena hlasem podporujícím češtinu. </voice>
<lang langid="409"> A U.S. English voice should speak this. </lang>

Vlastní výslovnost

Vlastní výslovnost je alternativou k použití značky výslovnosti s atributy DISP a PRON. Použití značek vlastní výslovnosti je následující:

<p disp="disp" pron="pron">word</p>

Může být zapsáno jako:

<p>/disp/word/pron;</p>

Pro větší upřesnění: Chcete-li rozpoznat slovo hello pouze tehdy, je-li vysloveno jako ah, a zobrazit greeting, je-li rozpoznáno, běžně byste použili něco jako:

<p disp="greeting" pron="ah">hello</p>

Totéž s použitím vlastní výslovnosti bude vypadat následovně:

<p>/greeting/hello/ah;</p>


Definice kontextových značek (SAPI 5)

Kontextová značka určuje normalizaci bloku textu. Její specifikace určuje předdefinované atributy SAPI (ID) kontextové značky. Tato ID jsou zapsána jako řetězce. SAPI neprovádí kontrolu parametrů předaných jeho rozhraní, program může určit normalizační ID, specifické pro konkrétní rozhraní hlasové syntézy. řetězce, specifické pro rozhraní hlasové syntézy, začínají jménem rozhraní příslušného hlasu za účelem vyloučení záměn napříč rozhraními.

Příklad:

<context id="My_Context"> text </context>

Přesná implementace těchto hodnot závisí na příslušném rozhraní hlasové syntézy, použitém v SAPI 5. Za účelem vynucení dané normalizace mohou vývojáři aplikací zvolit normalizaci textu, použít jinou značku SAPI či ID, příslušející konkrétnímu rozhraní. Každá kontextová značka může obsahovat více než jeden řetězec.

Příklad:

<context id="date_mdy"> 12/21/99 11/21/99 10/21/99 </context>

bude normalizováno na "December twenty first nineteen ninety nine November twenty first nineteen ninety nine October twenty first nineteen ninety nine."

Podporovány jsou následující předdefinované typy kontextů:

  • Date
  • Time
  • Number
  • Web
  • E-mail
  • Address

Date

Tento kontext určuje, že číslo předané rozhraní je datum. Obecný formát data je číslo [oddělovač] číslo [oddělovač] číslo či číslo [oddělovač] číslo, kde oddělovačem může být '.', '/' či '-' a kde jsou čísla typicky v rozsahu 01-12 pro měsíce a 01-31 pro dny. Rok je obecně dvou či čtyřčíselný.

Následují správné typy řetězců pro data:

date_mdy

Datum bude normalizováno tak, že první skupina číslic je měsíc, druhá den a třetí rok. V případě, že rok je dvoučíselný, rozhraní jej bude chápat jako dvoučíselný a čtyřčíselný jako čtyřčíselný.

Příklad:

<context id="date_mdy">12/21/99</context>

bude normalizováno na "December twenty first ninety nine"
či "December twenty first nineteen ninety nine"

<context id="date_mdy">12/21/1999</context>

bude normalizováno na "December twenty first nineteen ninety nine"

date_dmy

Datum bude normalizováno tak, že první skupina číslic je den, druhá měsíc a třetí rok. V případě, že rok je dvoučíselný, rozhraní jej bude chápat jako dvoučíselný a čtyřčíselný jako čtyřčíselný.

Příklad:

<context id="date_dmy">21.12.99</context>

bude normalizováno na "December twenty first ninety nine"
či "December twenty first nineteen ninety nine"

<context id="date_dmy">21-12-1999</context>

bude normalizováno na "December twenty first nineteen ninety nine"

date_ymd

Datum bude normalizováno tak, že první skupina číslic je rok, druhá měsíc a třetí den. V případě, že rok je dvoučíselný, rozhraní jej bude chápat jako dvoučíselný a čtyřčíselný jako čtyřčíselný.

Příklad:

<context id="date_ymd">99-12-21</context>

bude normalizováno na "December twenty first ninety nine"
či "December twenty first nineteen ninety nine"

<context id="date_ymd">1999.12.21</context>

bude normalizováno na "December twenty first nineteen ninety nine"

date_ym

Datum bude normalizováno tak, že první skupina číslic je rok a druhá měsíc. V případě, že rok je dvoučíselný, rozhraní jej bude chápat jako dvoučíselný a čtyřčíselný jako čtyřčíselný.

Příklad:

<context id="date_ym">99-12</context>

bude normalizováno na "December ninety nine"
či "December nineteen ninety nine"

<context id="date_ym">1999.12</context>

bude normalizováno na "December nineteen ninety nine"

date_my

Datum bude normalizováno tak, že první skupina číslic je měsíc a druhá rok. V případě, že rok je dvoučíselný, rozhraní jej bude chápat jako dvoučíselný a čtyřčíselný jako čtyřčíselný.

Příklad:

<context id="date_my">12/99</context>

bude normalizováno na "December ninety nine"
či "December nineteen ninety nine"

<context id="date_my">12/1999</context>

bude normalizováno na "December nineteen ninety nine"

date_dm

Datum bude normalizováno tak, že první skupina číslic je den a druhá měsíc.

Příklad:

<context id="date_dm">21.12</context>

bude normalizováno na "December twenty first"

date_md

Datum bude normalizováno tak, že první skupina číslic je měsíc a druhá den.

Příklad:

<context id="date_md">12/21</context>

bude normalizováno na "December twenty first"

date_year

Datum bude normalizováno tak, že zadané číslo je rok.

Příklad:

<context id="date_year">1999</context>

bude normalizováno na "nineteen ninety nine"

<context id="date_year">2001</context>

bude normalizováno na "Two thousand one"

chs_date_ymdhm

Text, který určuje datum, je normalizován tak, že první skupina číslic je rok, druhá měsíc, třetí den, čtvrtá hodina a pátá minuta. V případě, že rok je dvoučíselný, rozhraní jej bude chápat jako dvoučíselný a čtyřčíselný jako čtyřčíselný. Formát času musí určovat hodinu jako číslo v rozsahu 00–23 a minuty jako číslo v rozsahu 01–59.

Tato kontextová značka je specifická pro čínštinu.

Time

Tento kontext určuje, že číslo předané rozhraní je čas. Obecný formát času je číslo [oddělovač] číslo [oddělovač] číslo či číslo [oddělovač] číslo kde oddělovačem může být ':', ' ' ' či ' " '. Čísla jsou typicky v rozsahu 01–24 pro hodiny a 01–59 pro minuty a vteřiny.

Je-li 0 přítomna v číslech v rozsahu 01–09, může být rozhraním ignorována či normalizována na "oh". Rozhraní může do normalizovaných časů umístit řetězec "and".

time

Příklad:

<context id="time">12:30</context>

bude normalizováno na "twelve thirty"

<context id="time">01:21</context>

bude normalizováno na "one twenty one"
či "oh one twenty one"

<context id="time">1'21"</context>

bude normalizováno na "one minute twenty one seconds"
či "one minute and twenty one seconds"

chs_time_hms

Text určující čas je normalizován tak, že první skupina číslic je hodina, druhá minuta a třetí vteřina.

Tato kontextová značka je specifická pro čínštinu.

chs_time_hm

Text určující čas je normalizován tak, že první skupina číslic je hodina a druhá minuta.

Tato kontextová značka je specifická pro čínštinu.

Number

number_cardinal

Text je normalizován jako číslo s použitím regulárního formátu jednotek, desítek atp. Rozhraní do normalizovaného textu může umístit řetězec "and".

Příklad:

<context id="number_cardinal">3432</context>

bude normalizováno na "three thousand four hundred thirty two"

<context id="number_cardinal">3432</context>

bude normalizováno na "three thousand four hundred and thirty two"

number_digit

Text je normalizován dle číslic, jedna po druhé.

Příklad:

<context id="number_digit">3432</context>

bude normalizováno na "three four three two"

number_fraction

Text je normalizován jako fraktál.

Příklad:

<context id="number_fraction">3/15</context>

bude normalizováno na "three fifteenths" či "three over fifteen"

number_decimal

Text je normalizován jako desítková hodnota.

Příklad:

<context id="number_decimal">423.1243</context>

bude normalizováno na "four hundred and twenty three point one two four three"

phone_number

Text je normalizován jako telefonní číslo. Implementace je ponechána na vývojářích hlasových syntéz. Může být upřesněna v dalších verzích rozhraní SAPI.

currency

Text je normalizován jako měna. Implementace je ponechána na vývojářích hlasových syntéz. Může být upřesněna v dalších verzích rozhraní SAPI.

Příklad:

<context id="currency">$34.90</context>

bude normalizováno na "thirty four dollars and ninety cents"

chs_number_percentage

Text je normalizován jako hodnota v procentech.

Tato kontextová značka je specifická pro čínštinu.

chs_number_scientific

Text je normalizován jako vědecká notace.

Tato kontextová značka je specifická pro čínštinu.

chs_phone_postal

Telefonní číslo a poštovní adresa je téměř totožná se značkou number_cardinal. Jediným rozdílem je, že "1" je čtena jako "yao1".

Tato kontextová značka je specifická pro čínštinu.

Web

Text je normalizován jako URL. Implementace je ponechána na vývojářích hlasových syntéz. Může být upřesněna v dalších verzích rozhraní SAPI.

web_url

Příklad:

<context id="web_url">www.Microsoft.com</context>

bude normalizováno na "w w w dot Microsoft dot com"

E-mail

Text je normalizován jako e-mailová adresa. Implementace je ponechána na vývojářích hlasových syntéz. Může být upřesněna v dalších verzích rozhraní SAPI.

e-mail_address

Příklad:

<context id="e-mail_address">someone@microsoft.com</context>

bude normalizováno na "Someone at Microsoft dot com"

Address

Text je normalizován jako adresa. Implementace je ponechána na vývojářích hlasových syntéz. Může být upřesněna v dalších verzích rozhraní SAPI.

address

Příklad:

<context id="address">One Microsoft Way, Redmond, WA, 98052</context>

bude normalizováno na "One Microsoft Way Redmond Washington nine eight zero five two"

address_postal

Text je normalizován jako poštovní adresa. Implementace je ponechána na vývojářích hlasových syntéz. Může být upřesněna v dalších verzích rozhraní SAPI.

Příklad:

<context id="address_postal">A2C 4X5</context>

bude normalizováno na "A 2 C 4 X 5"


Universal Tags

It is recommended to use the control tags for SAPI 4 and the XML tags for SAPI 5 and Microsoft Speech Platform. But in addition Balabolka supports its own universal tags to modify the speech synthesis.

Audio

Balabolka podporuje vkládání odkazů na externí zvukové soubory (audio klipy) do textu. Pro výběr souborů použijte položku hlavní nabídky 'Text / Audio klip'.

Podporované formáty: WAV, MP3, OGG.

Značka audio klipu vypadá následovně:

{{Audio=D:\Zvuky\ring.wav}}

Lze použít i relativní cestu ke zvukovému souboru. Relativní cesta je cesta k umístění souborů vzhledem k aktuálnímu dokumentu. Příklad:

{{Audio=..\moje zvuky\ring.mp3}}

Při nalezení značky audio klipu Balabolka pozastaví čtení, přehraje příslušný zvuk a opět čtení obnoví. Během převodu do zvukových souborů budou audio klipy zahrnuty na příslušná místa ve výsledných souborech.

Voice

If it is necessary to change a voice or its properties during reading aloud, a special tag can be used for SAPI 5 and Microsoft Speech Platform (SAPI 4 voices will ignore this tag).

The tag format:

{{Voice=Name;Rate;Pitch;Volume}}

  • Name - the name of a voice (one word or the part of a word is enough);
  • Rate - the rate of a voice (values range from -10 to 10);
  • Pitch - the pitch of a voice (values range from -10 to 10);
  • Volume - the volume (values range from 0 to 100).

A tag applies to all subsequent text. The values are separated by semicolons. For example:

This text will be spoken by the default voice of Balabolka. {{Voice=Kimberly;0;0;100}} The voice 'Kimberly' will read the other text.

The tag's content is case insensitive. Values for some properties can be omitted:

{{voice=eric;;;50}}

{{Voice=Hans;-1}}

{{Voice=Rachel}}

To return to the default voice, use this tag:

{{Voice=}}

Warning! It is impossible to switch between SAPI 5 voices and voices of the Microsoft Speech Platform.

Pause

Lze do výstupního zvukového souboru vložit definovaný počet milisekund ticha. Příklad:

120 ms ticha. {{Pause=120}} Právě proběhlo.


Fonetické abecedy

Fonetická abeceda obsahuje seznam písmen, číslic a znaků, známých jako fonémy. Foném reprezentuje jedinečný zvuk v mluveném jazyce. Fonémy lze použít pro jednoznačné určení výslovnosti slova v konkrétním jazyce. Pro tento účel hlasové syntézy podporují obecně definované fonetické abecedy.

  • International Phonetic Alphabet (IPA)
  • Speech API (SAPI) Phone Set
  • Universal Phone Set (UPS)

International Phonetic Alphabet (IPA) je systém fonetického zápisu, založený primárně na latinské abecedě, určené jako standart pro reprezentaci zvuků mluveného jazyka. Tuto fonetickou abecedu je možné použít pro určení výslovnosti kteréhokoliv jazyka.

První jazyky pro převod textu na řeč prostřednictvím počítačem definované výslovnosti slov s použitím SAPI Phone Setu byly vytvořeny společností Microsoft. Foném sestává z jednoho či více znaků fonetické abecedy, popisující diskrétní zvuky mluveného jazyka. Následující jazyky používají k popsání svých zvuků SAPI Phone Set: čínština, angličtina, francouzština, němčina, japonština, španělština.

V průběhu času Microsoft vyvinul Universal Phone Set (UPS), strojově čitelnou fonetickou abecedu, založenou na mezinárodní fonetické abecedě (IPA). Abeceda UPS je mnohem výkonnější fonetickou abecedou než SAPI Phone Set. Může být použita pro popis zvuků kteréhokoliv nového jazyka a je mnohem jednodušší přiřadit ji k dalším strojově čitelným fonetickým abecedám, jako např. X-SAMPA, SAMPA či ASCII-IPA.

Uživatel tvoří výslovnost použitím značky výslovnosti XML. Zde jsou např. dva fonetické přepisy, jež mohou být hlasovou syntézou použity k vyslovení slova "hello" v americké angličtině:

<pron sym="h eh - l ow 1"/>

<pron sym="H EH S1 L O"/>

První z příkladů používá fonémy SAPI phone setu. "1" je symbol pro důraz. Určuje, která slabika by měla být zdůrazněna. Fonémy jsou odděleny mezerou a "-" odděluje slabiky ve slově. 'Druhý příklad používá fonémy z Universal Phone Setu. Písmena určují vyslovované úseky tvořící slovo. "S1" je symbol pro důraz. Určuje, která slabika by měla být zdůrazněna.

Protože fonetické abecedy SPS a UPS v současné době nepodporují češtinu, ponecháváme jejich referenční příručky převážně v Anglické podobě.

The current versions of IVONA voices do not support SAPI phonemes. The PRON tag is ignored. It is recommended to use the Speech Synthesis Markup Language (SSML) tag to provide a phonetic pronunciation for the specific text.

<phoneme alphabet="ipa" ph="təˈmeɪtoʊ">tomato</phoneme>

The PHONEME tag can be shortened:

<phoneme alphabet="ipa" ph="pəˈteɪtoʊ"/>

The SSML tag supports phonetic alphabets:

  • International Phonetic Alphabet (IPA)
  • Extended Speech Assessment Methods Phonetic Alphabet (X-SAMPA)

IPA symbols are difficult to enter from the keyboard. Balabolka allows to choose characters from the list of IPA symbols. Also the application can convert words to IPA symbols. The phonetic transcriptions are supported for languages:

  • English
  • French
  • German
  • Italian
  • Polish
  • Portuguese
  • Russian
  • Spanish
  • Turkish
  • Ukrainian

Text should be written in lower case; the capital vowels can be used to indicate a primary stress in words.


SAPI Phone Set

Microsoft Speech API využívá fonetickou abecedu k vyjádření řeči formou fonémů. Ve fonetické abecedě jsou definovány všechny fonémy používané daným jazykem spolu s jejich vlastnostmi a daty potřebnými k výslednému výstupu formou zvuků. Uživatelé mohou tvořit výslovnosti slov, jež nejsou aktuálně ve slovníku, používáním fonémů uvedených v následujících tabulkách. Soubor fonémů sestává z fonetické reprezentace (SYM).

Uživatel může vložit SYM reprezentaci pro vytvoření výslovnosti použitím značky výslovnosti XML. Každý záznam fonému by měl být oddělen mezerou.

Příklad. Výslovnost slova "hello":

<pron sym="h eh l ow"/>

Za účelem upřesnění výsledné podoby mohou být k výslovnosti přidány značky pro důraz či značky slabik.

Příklad. Výslovnost slova "hello" s použitím značky důrazu a slabiky:

<pron sym="h eh - l ow 1"/>

SAPI Phone Set je použitelný pro následující jazyky:

  • Angličtina Spojené státy
  • Francouzština
  • Němčina
  • Italština
  • Španělština
  • Čínština
  • Japonština

Fonémy pro Angličtinu Spojené státy

Symbol fonému | Příklad | Transkripce
1 | Primární přízvuk |
2 | Sekundární přízvuk |
- | Hranice slabiky (pomlčka) |
& | Hranice slova |
! | Zakončení věty (vykřičník) |
, | Zakončení věty (čárka) |
. | Zakončení věty (tečka) |
? | Zakončení věty (otazník) |
_ | Ticho (podtržení) |
aa | father | f aa 1 dh er
ae | cat | k ae 1 t
ah | but | b ah 1 t
ao | bought | b ao 1 t
aw | house | h aw 1 s
ax | about | ax b aw 1 t
ay | bite | b ay 1 t
b | book | b uh 1 k
ch | catch | k eh 1 ch
d | done | d ah 1 n
dh | breathe | b r i dh
eh | bet | b eh 1 t
er | bird | b er 1 d
ey | ate | ey 1 t
e@ | fairly | f e@ 1 l i
f | fog | f ao 1 g
g | good | g uh 1 d
h | hello | h eh l ow 1
ih | bit | b ih 1 t
iy | beat | b iy 1 t
i@ | here | h i@ 1
jh | jump | jh ah 1 mp
k | cat | k ae 1 t
l | lot | l aa 1 t
m | Mom | m aa 1 m
n | nod | n aa 1 d
ng | sing | s ih 1 ng
ow | boat | b ow 1 t
oy | boy | b oy 1
p | pot | p aa 1 t
r | rat | r ae 1 t
s | sit | s ih 1 t
sh | shut | sh ah 1 t
t | top | t aa 1 p
th | thick | th ih 1 k
uh | book | b uh 1 k
uw | boot | b uw 1 t
v | various | v eh 1 r i ih s
w | won | w ah 1 n
y | you | y uw 1
z | zoo | z uw 1
zh | casual | k ae 1 zh uw ah l

Fonémy pro Francouzštinu

Symbol fonému | Příklad | Transkripce
1 | Primární přízvuk |
2 | Sekundární přízvuk |
- | Hranice slabiky (pomlčka) |
& | Hranice slova |
! | Zakončení věty (vykřičník) |
, | Zakončení věty (čárka) |
. | Zakončení věty (tečka) |
? | Zakončení věty (otazník) |
_ | Ticho (podtržení) |
a | patte | p a 1 t
aan | abandon | a b aan d aon 1
ao | comme | k ao 1 m
aon | bon | b aon 1
ax | le | l ax 1
b | bouche | b u 1 sh
ch | charlie | ch a 1 r l i
d | dame | d a 1 m
dz | jeudi | j oe dz i 1
e | marché | m a r sh e 1
eh | chère | sh eh 1 r
ehn | main | m ehn 1
eo | feu | f eo 1
f | fille | f i 1 j
g | garde | g a 1 r d
i | libre | l i 1 b r
j | pierre | p j e 1 r
jh | George | jh ao 1 r jh
k | chique | sh i k
l | langage | l aan g a 1 zh
m | mois | m w a 1
n | nonne | n ao 1 n
ng | shopping | sh ao p i 1 ng
nj | campagne | k aan p a 1 nj
o | animaux | a n i m o 1
oe | leur | l oe 1 r
oen | parfum | p a r f oen 1
p | pile | p i 1 l
q | hacher | q a sh e 1
r | route | r u t
s | adresser | a d r e s e 1
sh | chaise | sh eh 1 z
t | technique | t eh k n i 1 k
ts | énergétique | e n eh r zh e ts i 1 k
u | doux | d u 1
ue | une | ue 1 n
uh | Bush | b uh 1 sh
v | vive | v i 1 v
w | boire | b w a 1 r
yw | huile | yw i 1 l
z | zone | z ao 1 n
zh | juste | zh ue 1 s t

Fonémy pro Němčinu

Symbol fonému | Příklad | Transkripce
1 | Primární přízvuk |
2 | Sekundární přízvuk |
- | Hranice slabiky (pomlčka) |
& | Hranice slova |
! | Zakončení věty (vykřičník) |
, | Zakončení věty (čárka) |
. | Zakončení věty (tečka) |
? | Zakončení věty (otazník) |
_ | Ticho (podtržení) |
a | Achtung | q a 1 x t uh ng
A | Name | n A 1 m ah
aan | Chance | sh aan 1 s ah
ah | bitte | b ih 1 t ah
ao | Hoffnung | h ao 1 f n uh ng
aon | Pompon | p aon 1 p aon 1
aw | Raum | rq aw 1 m
ay | Zeit | ts ay 1 t
b | besonders | b ah z ao 1 n d e@ s
c | China | c i 1 n A
ch | deutsch | d oy 1 ch
d | das | d a 1 s
e | mehr | m e 1 r
eh | Enkel | q eh 1 ng k el
EH | erklären | q eh r k l EH 1 rq en
ehn | Bassin | b a s ehn 1
el | Einzelnen | q ay 1 n ts el n en
em | einem | q ay 1 n em
en | einen | q ay 1 n en
er | Surfer | s er 1 f e@
ey | Display | d ih s p l ey 1
e@ | Kindern | k ih 1 n d e@ n
f | Fall | f a 1 l
g | glaube | g l aw 1 b ah
h | Haupt | h aw 1 p t
i | sieben | z i 1 b en
ih | immer | q ih 1 m e@
j | ja | j A 1
jh | Dschungel | jh uh 1 ng el
k | Kultur | k uh l t u 1 r
l | lieber | l i 1 b e@
m | mein | m ay 1 n
n | Name | n A 1 m ah
ng | Junge | j uh 1 ng ah
o | oder | q o 1 d e@
oe | öffnete | q oe 1 f n ah t ah
OE | Österreich | q OE 1 s t ah rq ay c
oen | Parfum | p a r f oen 1
oy | Europa | q oy rq o 1 p A
p | Parlament | p a r l a m eh 1 n t
pf | Pflicht | pf l ih 1 c t
q | aber | q A 1 b e@
r | Berliner | b eh r l i 1 n e@
rq | Runde | rq uh 1 n d ah
s | Szene | s ts e 1 n ah
sh | sprach | sh p rq A 1 x
t | tol | t ao 1 l
ts | Zimmer | ts ih 1 m e@
u | Uhren | q u 1 rq en
ue | hübsch | h ue 1 p sh
UE | über | q UE 1 b e@
uh | Schutz | sh uh 1 ts
v | wichtig | v ih 1 c t ih c
w | Mademoiselle | m a d ah m w a z eh 1 l
x | Buch | b u 1 x
z | selbst | z eh 1 l p s t
zh | Spionage | sh p i o n A 1 zh ah

Fonémy pro Italštinu

Symbol fonému | Příklad | Transkripce
1 | Primární přízvuk |
2 | Sekundární přízvuk |
- | Hranice slabiky (pomlčka) |
& | Hranice slova |
! | Zakončení věty (vykřičník) |
, | Zakončení věty (čárka) |
. | Zakončení věty (tečka) |
? | Zakončení věty (otazník) |
_ | Ticho (podtržení) |
a | campo | k a 1 m p o
ao | nove | n ao 1 v e
b | barra | b a 1 rr a
ch | percento | p e r ch eh 1 n t o
d | mondo | m o 1 n d o
dz | zeta | dz eh 1 t a
e | venire | v e n i 1 r e
eh | lento | l eh 1 n t o
f | fine | f i 1 n e
g | gruppi | g r u 1 p i
i | si | s i
j | funzione | f u n ts j o 1 n e
jh | generazione | jh e n e r a ts j o 1 n e
k | economia | e k o n o m i 1 a
l | libri | l i 1 b r i
ll | gli | ll i
m | mai | m a 1 i
n | nord | n ao r d
nj | signor | s i 1 nj ao r
o | otto | ao 1 t t o
p | primo | p r i 1 m o
r | arrivederci | a rr i v e d e 1 r ch i
rr | arrivederci | a rr i v e d e 1 r ch i
s | sinistra | s i n i 1 s t r a
sh | scienza | sh eh 1 n ts a
t | tre | t r eh
ts | grazie | g r a 1 ts j e
u | punto | p u 1 n t o
v | venti | v e 1 n t i
w | Washington | w a 1 sh i ng t o n
z | svolta | z v o 1 l t a

Fonémy pro Španělštinu

Symbol fonému | Příklad | Transkripce
1 | Primární přízvuk |
2 | Sekundární přízvuk |
- | Hranice slabiky (pomlčka) |
& | Hranice slova |
! | Zakončení věty (vykřičník) |
, | Zakončení věty (čárka) |
. | Zakončení věty (tečka) |
? | Zakončení věty (otazník) |
_ | Ticho (podtržení) |
a | aquí | a k i 1
b | Brasil | b r a s i 1 l
ch | Chile | ch i 1 l e
d | grande | g r a 1 n d e
e | este | e 1 s t e
f | función | f u n s xi o 1 n
g | segundo | s e g u 1 n d o
i | identidad | i d e n t i d a 1 d
j | yo | j o 1
k | casa | k a 1 s a
l | los | l o 1 s
ll | llamada | ll a m a 1 d a
m | manos | m a 1 n o s
n | no | n o 1
nj | año | a 1 nj o
o | bueno | b xu e 1 n o
p | para | p a 1 r a
r | para | p a 1 r a
rr | radio | rr a 1 d xi o
s | solo | s o 1 l o
sh | Bush | b u 1 sh
t | importante | i m p o r t a 1 n t e
u | uno | u 1 n o
w | Hollywood | o 1 l i w u d
x | general | x e n e r a 1 l
xi | iogur | xi o g u 1 r
xu | puedo | p xu e 1 d o

Fonémy pro Čínštinu

Symbol fonému | Příklad
- | Hranice slabiky (pomlčka)
! | Zakončení věty (vykřičník)
& | Hranice slova
, | Zakončení věty (čárka)
. | Zakončení věty (tečka)
? | Zakončení věty (otazník)
_ | Ticho (podtržení)
+ | Primární přízvuk
* | Sekundární přízvuk
1 | Zvuk 1
2 | Zvuk 2
3 | Zvuk 3
4 | Zvuk 4
5 | Zvuk 5
a | a 1 fei 1 (růž)
ai | ai 4 ren 2 (milenec)
an | an 1 quan 2 (bezpečný)
ang | ang 1 zang 1 (špinavý)
ao | jiao 1 ao 4 (hrdý)
ba | ba 4 ba 5 (táta)
bai | bai 2 se 4 (bílá)
ban | mu 4 ban 3 (deska)
bang | bang 3 jia 4 (únos)
bao | yong 1 bao 4 (objetí)
bei | bei 3 fang 1 (sever)
ben | ben 4 dan 4 (hlupák)
beng | beng 4 tiao 4 (skok)
bi | bi 2 zi 5 (nos)
bian | bian 4 hua 5 (změna)
biao | biao 3 ge 2 (stůl)
bie | li 2 bie 2 (přenechat)
bin | bin 1 ke 4 (host)
bing | shi 4 bing 1 (voják)
bo | bo 2 dou 4 (zápas)
bu | bu 4 xing 2 (chodit)
ca | ca 1 gan 1 (utírat)
cai | cai 1 ce 4 (odhadovat)
can | can 1 jia 1 (spojit)
cang | cang 1 ying 5 (letět)
cao | cao 1 chang 3 (hřiště)
ce | ce 4 liang 2 (měřit)
cen | cen 1 ci 1 (nerovnoměrné)
ceng | ceng 2 jing 1 (jednou)
cha | jian 3 cha 2 (zkontrolovat)
chai | chai 1 hui 3 (zbourat)
chan | chan 3 ye 4 (průmysl)
chang | jing 1 chang 2 (často)
chao | chao 1 yue 4 (překročit)
che | qi 4 che 1 (automobil)
chen | chen 2 jiu 4 (starý)
cheng | cheng 2 che 1 (jízda)
chi | chi 2 dao 4 (pozdě na)
chong | chong 1 man 3 (plný)
chou | chou 2 hen 4 (nenávist)
chu | chu 2 fa 3 (rozdělení)
chuai | chuai 3 ce 4 (odhadovat)
chuan | lun 2 chuan 2 (loď)
chuang | chuang 4 ye 4 (vybojovat si)
chui | tie 3 chui 2 (kladivo)
chun | chun 1 tian 1 (jaro)
chuo | wo 4 chuo 4 (špinavý)
ci | ci 2 qi 4 (porcelán)
cong | cong 2 lin 2 (křoví)
cou | jin 3 cou 4 (kompaktní)
cu | cu 4 xiao 1 (podpora prodeje)
cuan | tao 2 cuan 4 (utéct)
cui | cui 1 cu 4 (tisknout)
cun | xiang 1 cun 1 (země)
cuo | cuo 4 wu 4 (chyba)
da | da 4 (velký)
dai | dai 4 biao 3 (delegát)
dan | dan 4 shi 4 (ale)
dang | dang 1 ran 2 (jistě)
dao | dao 1 (nůž)
de | de 5 (funkční slovo)
dei | dei 3 (muset)
den | den 4 (vytrhnout)
deng | ban 3 deng 4 (dřevěná stolička)
di | di 2 que 4 (jistě)
dia | dia 3 (koketní hlas)
dian | dian 3 (tečka)
diao | diao 4 (viset)
die | die 1 dao 3 (spadnout)
ding | jue 2 ding 4 (rozhodnout)
diu | diu 1 qi 4 (vyhodit)
dong | dong 1 fang 1 (východ)
dou | zhan 4 dou 4 (usilovat)
du | du 4 jue 2 (zastavit)
duan | duan 3 (krátký)
dui | dui 4 (vpravo)
dun | ting 2 dun 4 (zastavit)
duo | duo 1 yu 2 (zbytečný)
e | e 4 (hladový)
ei | ei 4 (ano)
en | en 1 hui 4 (laskavost)
er | er 3 (ucho)
fa | fa 1 zhan 3 (vývoj)
fan | fan 4 (rýže)
fang | fang 2 jian 1 (pokoj)
fei | fei 1 (moucha)
fen | fen 1 bie 2 (samostatný)
feng | feng 1 (vítr)
fo | fo 2 (buddha)
fou | fou 3 ding 4 (odmítnutí)
fu | fu 4 qin 1 (otec)
ga | gan 1 ga 4 (trapný)
gai | ying 1 gai 1 (měl by)
gan | gan 1 jing 4 (čistota)
gang | gang 1 cai 2 (pouze)
gao | gao 1 (vysoký)
ge | pin 3 ge 2 (znak)
gei | gei 3 yu 3 (dát)
gen | gen 1 (kořen)
geng | geng 4 jia 1 (mnohem více)
gong | gong 1 ren 2 (pracovník)
gou | zu 2 gou 4 (dost)
gu | gu 4 xiang 1 (rodné město)
gua | xi 1 gua 1 (meloun)
guai | qi 2 guai 4 (zvláštní)
guan | guan 1 bi 4 (zavřít)
guang | guang 1 (světlo)
gui | gui 3 (duch)
gun | gun 4 (tyč)
guo | guo 4 qu 4 (minulost)
ha | ha 1 (zvuk smíchu)
hai | hai 2 zi 5 (dítě)
han | chu 1 han 4 (sladký)
hang | hang 2 xing 2 (plachtění)
hao | hao 3 (dobrý)
he | he 2 (řeka)
hei | hei 1 (černá)
hen | hen 3 (velmi)
heng | heng 2 xiang 4 (orientace na šířku)
hong | hong 2 (červená)
hou | hou 2 zi 5 (opice)
hu | hu 2 xu 1 (medvěd)
hua | hua 4 (obrázek)
huai | huai 4 (špatný)
huan | huan 2 jing 4 (životní prostředí)
huang | huang 2 se 4 (žlutá)
hui | hui 1 huang 2 (lesk)
hun | hun 2 zhuo 2 (blátivý)
huo | huo 3 (oheň)
ji | ji 2 shi 2 (včas)
jia | jia 4 qi 1 (prázdniny)
jian | jian 3 dan 1 (jednoduchý)
jiang | jiang 1 (řeka)
jiao | jiao 1 tong 1 (provoz)
jie | jie 2 ri 4 (svátek)
jin | jin 3 zhang 1 (napětí)
jing | gan 1 jing 4 (čistota)
jiong | jiong 3 po 4 (zahanbený)
jiu | jiu 3 (devět)
ju | ju 4 zi 5 (věta)
juan | juan 3 qu 1 (kudrnatý)
jue | jue 2 ding 4 (rozhodnout)
jun | jun 1 dui 4 (armáda)
ka | ka 3 che 1 (nákladní auto)
kai | kai 3 xuan 2 (triumf)
kan | kan 4 (vidět)
kang | di 3 kang 4 (odolávat)
kao | kao 3 shi 4 (test)
ke | ke 3 (žíznivý)
kei | kei 1 (vynadat)
ken | ken 3 ding 4 (ujistit)
keng | keng 1 hai 4 (polapit)
kong | kong 1 qi 4 (vzduch)
kou | kou 3 (ústa)
ku | jian 1 ku 3 (útrapy)
kua | kua 1 jiang 3 (chválit)
kuai | kuai 4 (rychle)
kuan | kuan 1 kuo 4 (otevřenost)
kuang | kong 1 kuang 4 (prázdný)
kui | kui 1 qian 4 (dlužit)
kun | kun 4 nan 2 (tvrdý)
kuo | kuo 4 da 4 (zvětšit)
la | la 4 jiao 1 (feferonka)
lai | lai 2 (přijít)
lan | lan 2 se 4 (modrá)
lang | lang 2 (vlk)
lao | lao 3 (starý)
le | kuai 4 le 4 (šťastný)
lei | lei 2 (hrom)
leng | leng 3 ku 4 (nezlomnost)
li | li 2 (hruška)
lia | lia 2 (dvě)
lian | lian 3 (obličej)
liang | li 4 liang 4 (napájení)
liao | zuo 2 liao 4 (koření)
lie | lin 3 lie 4 (závažný)
lin | lin 3 lie 4 (závažný)
ling | ling 2 mu 4 (mauzoleum)
liu | liu 2 dong 4 (tok)
lo | lo 5 (funkční slovo)
long | long 2 (drak)
lou | lou 4 (únik)
lu | lu 4 di 4 (země)
luan | hun 4 luan 4 (chaos)
lue | ce 4 lue 4 (taktika)
lun | yi 4 lun 4 (diskutovat)
luo | xia 4 luo 4 (místo pobytu)
lv | lv 4 se 4 (zelená)
ma | ma 3 (kůň)
mai | mai 2 zang 4 (pohřbít)
man | man 3 zu 2 (uspokojit)
mang | cong 1 mang 2 (spěchat)
mao | mao 1 (kočka)
me | shen 2 me 5 (co)
mei | mei 2 you 3 (ne)
men | wo 3 men 2 (my)
meng | meng 4 (sen)
mi | hun 1 mi 2 (kóma)
mian | mian 4 ji 5 (plocha)
miao | miao 4 (chrám)
mie | mie 4 jue 2 (vyhlazení)
min | ren 2 min 2 (lidé)
ming | ming 2 bai 2 (srozumitelnost)
miu | huang 1 miu 4 (nesmyslný)
mo | mo 4 shui 3 (inkoust)
mou | mou 2 lue 4 (lest)
mu | mu 4 biao 1 (cíl)
na | na 4 li 3 (tam)
nai | nai 3 nai 5 (babička)
nan | nan 2 fang 1 (jih)
nang | nang 2 kuo 4 (zahrnovat)
nao | re 4 nao 4 (temperament)
ne | mu 4 ne 4 (znecitlivělý)
nei | nei 4 bu 4 (uvnitř)
nen | nen 4 lv 4 (světle zelená)
neng | neng 2 gou 4 (schopný)
ni | ni 3 (ty)
nian | nian 2 (rok)
niang | gu 1 niang 5 (dívka)
niao | niao 3 (pták)
nie | nie 4 (kousnout)
nin | nin 2 (ty)
ning | an 1 ning 2 (mír)
niu | niu 2 (býk)
nong | nong 2 min 2 (farmář)
nou | nou 4 (pletí)
nu | nu 3 li 4 (snažit)
nuan | wen 1 nuan 3 (teplý)
nue | nue 4 dai 4 (týrání)
nuo | nuo 4 yan 2 (slib)
nv | nv 3 zi 3 (žena)
o | o 5 (funkční slovo)
ou | ou 1 yang 2 (čínské křestní jméno)
pa | hai 4 pa 4 (vyděšený)
pai | pai 4 qian 3 (poslat)
pan | pan 4 tu 2 (zrádce)
pang | pang 2 da 4 (obrovský)
pao | pao 3 (běh)
pei | pei 2 ban 4 (doprovodit)
pen | pen 2 di 4 (pánev)
peng | peng 2 pai 4 (příval)
pi | pi 2 fu 1 (kůže)
pian | qi 1 pian 4 (podvod)
piao | piao 4 liang 4 (hezký)
pie | pie 1 kai 1 (odložit)
pin | pin 2 fan 2 (frekvence)
ping | ping 2 zi 5 (láhev)
po | po 4 huai 4 (poškození)
pou | pou 2 (podržet něco v dlani)
pu | pu 2 tao 5 (hrozny)
qi | qi 3 qiu 2 (žadonit)
qia | qia 4 dang 4 (vhodný)
qian | qian 1 xu 1 (skromnost)
qiang | qiang 2 da 4 (výkonný)
qiao | qiao 3 miao 4 (vynalézavost)
qie | xiu 1 qie 4 (plachost)
qin | qin 1 zi 4 (osobně)
qing | qing 1 song 1 (lehký)
qiong | qiong 2 (chudoba)
qiu | qiu 2 fan 4 (vězeň)
qu | qu 1 dong 4 (pohon)
quan | quan 2 bu 4 (vše)
que | que 4 ding 4 (zaručit)
qun | qun 2 zhong 4 (dav)
ran | ran 2 hou 4 (pak)
rang | tu 3 rang 3 (půda)
rao | wei 2 rao 4 (okolí)
re | re 4 (horko)
ren | ren 2 lei 4 (člověk)
reng | reng 2 ran 2 (stejný)
ri | ri 4 chu 1 (východ slunce)
rong | rong 2 yao 4 (sláva)
rou | niu 2 rou 4 (hovězí)
ru | ru 2 guo 3 (jestli)
ruan | rou 2 ruan 3 (měkký)
rui | rui 4 zhi 4 (chytrý)
run | shi 1 run 4 (vlhkost)
ruo | ruo 4 xiao 3 (malost)
sa | sa 1 (tři)
sai | bi 3 sai 4 (konkurovat)
san | fen 1 san 4 (rozptýlit se)
sang | sang 4 (zemřít)
sao | da 3 sao 3 (zametat)
se | yan 2 se 4 (barva)
sen | sen 1 lin 2 (les)
seng | seng 1 lv 3 (mnich)
sha | sha 1 chang 3 (bojiště)
shai | ri 4 shai 4 (být vystaven slunci)
shan | shan 4 liang 2 (laskavost)
shang | shang 4 mian 4 (nahoře)
shao | shao 4 nian 2 (mládež)
she | she 2 (had)
shei | shei 2 (kdo)
shen | shen 2 me 5 (co)
sheng | sheng 1 yin 1 (hlas)
shi | shi 4 fei 1 (spor)
shou | shou 3 (ruka)
shu | shu 4 mu 4 (strom)
shua | shua 1 zi 5 (kartáč)
shuai | shuai 1 da 3 (bít)
shuan | men 2 shuan 1 (západka)
shuang | shuang 1 (pár)
shui | shui 3 (voda)
shun | shun 4 li 4 (dobře)
shuo | shuo 1 (říkat)
si | si 4 (čtyři)
song | song 4 bie 2 (rozloučení)
sou | sou 1 cha 2 (hledat)
su | su 4 du 4 (rychlost)
suan | suan 4 fa 3 (výpočet)
sui | sui 1 ran 2 (ačkoliv)
sun | sun 3 shi 1 (ztráta)
suo | suo 3 yi 3 (takže)
ta | ta 1 men 2 (oni)
tai | tai 4 (také)
tan | tan 2 hua 4 (hovor)
tang | tang 2 (cukr)
tao | tao 2 pao 3 (utéci)
te | te 4 bie 2 (zvláštní)
tei | tei 1 (velmi)
teng | ben 1 teng 2 (výtržnost)
ti | ti 1 zi 5 (žebřík)
tian | tian 1 (nebe)
tiao | tiao 4 yue 4 (skočit)
tie | tie 3 (železo)
ting | ting 1 (poslouchat)
tong | tong 3 yi 1 (sjednotit)
tou | tou 2 (hlava)
tu | tu 3 di 4 (země)
tuan | tuan 2 jie 2 (ztuhnout)
tui | tui 1 dong 4 (tlačit)
tun | tun 2 ji 1 (hromadit)
tuo | tuo 1 yi 1 (svléknout)
wa | qing 1 wa 1 (žába)
wai | wai 4 mian 4 (venku)
wan | wan 4 (deset tisíc)
wang | si 3 wang 2 (smrt)
wei | wei 3 da 4 (skvělý)
wen | wen 2 hua 4 (kultura)
weng | lao 3 weng 1 (stařec)
wo | wo 3 (I)
wu | wu 2 lun 4 (bez ohledu na to, co)
xi | xi 1 fang 1 (západ)
xia | xia 4 mian 4 (spodek)
xian | xian 4 zai 4 (nyní)
xiang | xiang 4 (jako)
xiao | xiao 3 (malý)
xie | xie 3 (psát)
xin | xin 1 (nový)
xing | xing 2 dong 4 (čin)
xiong | xiong 2 (medvěd)
xiu | xiu 1 xi 5 (přestávka)
xu | xu 1 yao 4 (potřebovat)
xuan | xuan 1 bu 4 (prohlásit)
xue | xue 3 (sníh)
xun | xun 2 wen 4 (žádat)
ya | ya 4 zhou 1 (Asie)
yan | yan 4 zi 5 (polknout)
yang | tai 4 yang 2 (slunce)
yao | yao 1 qiu 2 (požadovat)
ye | ye 2 ye 5 (dědeček)
yi | yi 1 (jedna)
yin | yin 1 yue 4 (hudba)
ying | ying 1 gai 1 (měl by)
yo | yo 5 (funkční slovo)
yong | yong 3 yuan 3 (navždy)
you | you 2 yu 2 (vzhledem k)
yu | yu 2 (ryba)
yuan | yuan 2 lai 2 (dříve)
yue | yue 4 (měsíc)
yun | yun 2 (mrak)
za | za 2 luan 4 (nepořádek)
zai | zai 4 jian 4 (sbohem)
zan | zan 2 men 5 (náš)
zang | ang 1 zang 1 (špinavý)
zao | zao 3 chen 2 (ráno)
ze | ze 2 ren 4 (odezva)
zei | zei 2 (zloděj)
zen | zan 4 yang 2 (chválit)
zeng | zeng 1 jia 1 (přidat)
zha | zha 4 dan 4 (bomba)
zhai | qian 4 zhai 4 (dlužit)
zhan | zhan 4 li 4 (stát)
zhang | zhang 1 kai 1 (otevřít)
zhao | zhao 1 huan 4 (povolat)
zhe | zhe 4 li 3 (zde)
zhei | zhei 5 (toto)
zhen | zhen 1 zheng 4 (reálné)
zheng | zheng 4 yi 4 (spravedlnost)
zhi | yi 4 zhi 4 (zabránit)
zhong | zhong 1 guo 2 (Čína)
zhou | si 4 zhou 1 (kolem)
zhu | zhu 1 (prase)
zhua | zhua 1 (popadnout)
zhuai | zhuai 4 (táhnout)
zhuan | zhuan 1 (cihla)
zhuang | zhuang 1 (předstírat)
zhui | zhui 1 (honička)
zhun | zhun 3 (přesný)
zhuo | zhuo 1 (stůl)
zi | zi 4 (charakter)
zong | zong 3 (celkem)
zou | zou 3 (jít)
zu | zu 1 (nájemné)
zuan | zuan 4 (diamant)
zui | zui 4 (většina)
zun | zun 1 (respekt)
zuo | zuo 4 (sedět)

Fonémy pro Japonštinu (Katakana)

Symbol | Fonetika | Unicode | Poznámky
' |  | U+0027 | Pozice přízvuku
+ |  | U+002B | Hranice přízvuku
| |  | U+007C | Hranice fráze
. |  | U+002E | Konec věty (standardní)
? |  | U+003F | Konec věty (tázací)
! |  | U+0021 | Konec věty (vykřičník)
_ |  | U+005F | Jedna mora pauza
゜ |  | U+309C | Poloznělý zvuk
ァ | a | U+30A1 | Modifikátor
ア | a | U+30A2 |
ィ | i | U+30A3 | Modifikátor
イ | i | U+30A4 |
ゥ | u | U+30A5 |
ウ | u | U+30A6 |
ェ | e | U+30A7 | Modifikátor
エ | e | U+30A8 |
ォ | o | U+30A9 | Modifikátor
オ | o | U+30AA |
カ | ka | U+30AB |
ガ | ga | U+30AC |
キ | ki | U+30AD |
ギ | gi | U+30AE |
ク | ku | U+30AF |
グ | gu | U+30B0 |
ケ | ke | U+30B1 |
ゲ | ge | U+30B2 |
コ | ko | U+30B3 |
ゴ | go | U+30B4 |
サ | sa | U+30B5 |
ザ | za | U+30B6 |
シ | shi | U+30B7 |
ジ | ji | U+30B8 |
ス | su | U+30B9 |
ズ | zu | U+30BA |
セ | se | U+30BB |
ゼ | ze | U+30BC |
ソ | so | U+30BD |
ゾ | zo | U+30BE |
タ | ta | U+30BF |
ダ | da | U+30C0 |
チ | chi | U+30C1 |
ヂ | di | U+30C2 | Zastaralé – použít 30B8
ッ | q | U+30C3 |
ツ | tsu | U+30C4 |
ヅ | du | U+30C5 | Zastaralé – použít 30BA
テ | te | U+30C6 |
デ | de | U+30C7 |
ト | to | U+30C8 |
ド | do | U+30C9 |
ナ | na | U+30CA |
ニ | ni | U+30CB |
ヌ | nu | U+30CC |
ネ | ne | U+30CD |
ノ | no | U+30CE |
ハ | ha | U+30CF |
バ | ba | U+30D0 |
パ | pa | U+30D1 |
ヒ | hi | U+30D2 |
ビ | bi | U+30D3 |
ピ | pi | U+30D4 |
フ | hu | U+30D5 |
ブ | bu | U+30D6 |
プ | pu | U+30D7 |
ヘ | he | U+30D8 |
ベ | be | U+30D9 |
ペ | pe | U+30DA |
ホ | ho | U+30DB |
ボ | bo | U+30DC |
ポ | po | U+30DD |
マ | ma | U+30DE |
ミ | mi | U+30DF |
ム | mu | U+30E0 |
メ | me | U+30E1 |
モ | mo | U+30E2 |
ャ | ya | U+30E3 | Modifikátor
ヤ | ya | U+30E4 |
ュ | yu | U+30E5 | Modifikátor
ユ | yu | U+30E6 |
ョ | yo | U+30E7 | Modifikátor
ヨ | yo | U+30E8 |
ラ | ra | U+30E9 |
リ | ri | U+30EA |
ル | ru | U+30EB |
レ | re | U+30EC |
ロ | ro | U+30ED |
ヮ | wa | U+30EE | Modifikátor
ワ | wa | U+30EF |
ヰ | wi | U+30F0 | Zastaralé – použít 30A4
ヱ | we | U+30F1 | Zastaralé – použít 30A8
ヲ | wo | U+30F2 |
ン | nn | U+30F3 |
ヴ | vu | U+30F4 |
ヵ | ka | U+30F5 |
ヶ | ke | U+30F6 |
ヷ | va | U+30F7 |
ヸ | vi | U+30F8 |
ヹ | ve | U+30F9 |
ヺ | vo | U+30FA |
・ |  | U+30FB | Tečka uprostřed
ー |  | U+30FC | Prodloužený zvuk
ヽ |  | U+30FD | Iterace
ヾ |  | U+30FE | Znělá iterace


Universal Phone Set

Mezinárodní sada fonémů (Universal Phone Set – UPS) pro Speech API (SAPI) je strojově čitelná sada fonémů, která je založena na mezinárodní fonetické abecedě (IPA).

Zásady vytváření sady UPS

Pro výběr štítků SAPI a ID fonémů pro UPS byli použity následující principy vytváření.

  1. Sada UPS zahrnuje sadu znaků IPA 1993 Unicode a navíc několik dalších fonémů SAPI včetně štítků některých suprasegmentálních jevů, které se používají ve značkovacích jazycích pro hlasové syntézy, ale nenachází se v IPA.
    • Ve většině případů funguje mezi UPS a IPA jednoznačné mapování. V těchto případech může ID fonému SAPI jednoduše použít šestnáctkovou hodnotu Unicode IPA.
    • V některých případech může být sada UPS nadřazená sadě IPA. Sada UPS například obsahuje některé unikátní štítky fonémů pro běžně používané zvuky, jako jsou dvojhlásky a nazální samohlásky, se kterými IPA zachází jako se složeninami. Tyto složeniny jsou reprezentovány pomocí symbolu složeniny "+". S tímto symbolem se zachází stejně jako s jakýmkoliv jiným fonémem, proto musí být ve slovníku oddělený mezerami: složenina A a B se zapisuje A + B, nikoliv AB nebo A+B. ID fonému SAPI těchto složenin se tvoří sekvencí ID fonémů, ze kterých je složenina vytvořena.
  2. Výslovnost UPS se skládá z řetězce fonémů UPS, které jsou vzájemně odděleny mezerami. SAPI nerozlišuje mezi segmentálními fonémy a diakritikou, suprasegmentálními jevy a tóny, a proto je třeba je také oddělit prázdnými znaky jako jakýkoliv jiný foném SAPI.
  3. Štítky fonémů UPS nemusí používat pouze štítky fonémů SAPI z americké angličtiny, španělštiny, francouzštiny, němčiny, japonštiny nebo čínštiny; ale tam, kde je to možné, se stávající štítky SAPI mohou použít opakovaně. Pro vytváření názvů štítků fonémů byly použity dva postupy:
    • Sada fonémů UPS zohledňuje všude tam, kde je to možné, pravopis, ale není nijak speciálně zaměřená na angličtinu.
    • Štítky fonémů dodržují pravidla značení platné pro všechny fonetické třídy (např. laxní samohlásky používají znak "H" například v 'IH', 'UH' a 'AH').
  4. Sada fonémů UPS rozlišuje velká a malá písmena. Štítky fonémů UPS jsou definovány pomocí řetězců znaků ASCII.
    • Segmentální fonémy (souhlásky, samohlásky, mlaskavky a ražené souhlásky) jsou vyjádřeny velkými abecedními symboly. Ty mohou mít odlišnou délku od jednoho do tří znaků. Obecně platí, že pro častější fonémy se používají kratší symboly.
    • Diakritika je vyjádřena malými abecedními symboly v délce tří znaků.
    • Suprasegmentální jevy a tóny se mohou lišit v délce a obsahují neabecední znaky.

Sada UPS by se měla používat pro všechny jazyky podporované společností Microsoft kromě sedmi jazyků, které v současnosti podporuje SAPI: čínština, angličtina (Spojené státy), francouzština, němčina, italština, japonština, španělština.

Symbol pro vázání složenin

Sada UPS nabízí unikátní štítky fonémů pro běžné složené zvuky, jako jsou polosykavky (afrikáty) a nazální samohlásky. V některých jazycích se však mohou vyskytovat i méně časté složené zvuky a ty musí být ve slovnících SAPI zastoupeny. Sada UPS nabízí slučovací nebo vázající symbol "+", který lze použít k popisu zvuků složených z jakýchkoliv dvou fonémů.

Německá polosykavka "PF", dvojhláska "AI" a nazální samohláska "AN" jsou v sadě UPS zastoupeny jako unikátní fonémy. Mohly by však být prezentovány i formou složenin. Znamená to tedy, že příklady "PF" a "P + F" jsou ekvivalentní, ale odlišné od sekvence fonémů "P F".

Unikátní foném | Složenina
PF | P + F
AI | A + I

Nazální samohláska "AN" může být popsána také pomocí samohlásky "O" s diakritickým znaménkem pro nazálu. Všechna diakritická znaménka musí následovat až po segmentálním fonému, takže "A nas" a "A + nas" jsou ekvivalentní. Preferuje se první z uvedených příkladů, neboť SAPI si nevynucuje žádný konkrétní způsob použití "+" nebo diakritických znamének.

Unikátní foném | Složenina
AN | A nas
AN | A + nas

Souhlásky

Toto je výčet a křížové odkazy fonémů souhlásek používaných třemi fonetickými abecedami.

Pravidla značení souhlásek UPS

Symboly souhlásek mohou mít délku jednoho, dvou nebo tří znaků. Štítky v délce jednoho znaku se používají pro vysoce frekventované jazykově univerzální souhlásky. Obecně platí, že první znak označuje místo a znělost a druhý označuje způsob artikulace. Pravidla značení se převádějí mezi jednotlivými fonetickými třídami následujícími způsoby:

Pravidla pro značení místa artikulace a znělosti:

  • U dentálních a alveolárních souhlásek se používá D pro znělé a T pro neznělé.
  • Pro alveolární souhlásky se používá N pro nazály a R pro aproximanty.
  • U labiodentálních souhlásek se používá V pro znělé a F pro neznělé.
  • Pro velární souhlásky se používá G pro znělé a K pro neznělé, NG pro nazály.
  • Pro bilabiální souhlásky se používá B pro znělá a P pro neznělá ploziva, M pro nazály.
  • Pro laterální souhlásky se používá L.
  • Pro uvulární souhlásky se používá Q.
  • Pro faryngální souhlásky se používá H.
  • Pro palatální souhlásky se používá X pro neznělé a Y pro znělé.

Pravidla pro značení způsobu artikulace:

  • Způsob artikulace je vyjádřen volbou symbolu štítku (jedním znakem): například M představuje nazálu.
  • Zdvojení prvního symbolu označuje trylky.
  • Pro frikativy se používá H.
  • Pro aproximanty se používá X.
  • Pro retroflexní souhlásky se používá R.

Tabulka souhlásek

Uvedeny jsou dvě tabulky, z nichž každá obsahuje výčet jiné kategorie souhláskových fonémů:

  • Souhlásky
  • Afrikáty

Sloupce tabulky obsahují následující informace:

  • UPS. Štítek fonému dle mezinárodní sady fonémů Microsoft (UPS).
  • IPA. Štítek fonému dle mezinárodní fonetické abecedy (IPA).
  • Unicode. Hodnota Unicode dle sady fonémů IPA.
  • Popis dle IPA. Tento sloupec popisuje funkční charakteristiky fonému, jako je místo artikulace, způsob artikulace, typ fonace a mechanismus proudění vzduchu.
  • ASCII-IPA. Ekvivalentní foném dle sady fonémů ASCII-IPA pro referenci.
  • X-SAMPA. Ekvivalentní foném dle X-SAMPA pro referenci.
  • Příklad. Slovo, které foném používá a ilustruje jeho zvuk.
  • Jazyk. Jazyk, do kterého příkladové slovo patří.

Souhláskové fonémy

Souhlásky (konsonanty) jsou řečové zvuky, které se vyslovují s kompletním (neznělé) nebo částečným uzavřením hlasového ústrojí.

UPS | IPA | Unicode | Popis IPA | ASCII-IPA | X-SAMPA | Příklad | Jazyk
P | p | U+0070 | {blb,stp,vls} | p | p | put | Angličtina
B | b | U+0062 | {blb,stp,vcd} | b | b | big | Angličtina
M | m | U+006D | {blb,nas} | m | m | mat | Angličtina
BB | ʙ | U+0299 | {blb,trl,vcd} | B<trl> | B\ |  |
PH | ɸ | U+0278 | {blb,frc,vls} | P | p\ |  |
BH | β | U+03B2 | {blb,frc,vcd} | B | B | kabra | Španělština
MF | ɱ | U+0271 | {lbd,nas} | M | F |  |
F | f | U+0066 | {lbd,frc,vls} | f | f | fork | Angličtina
V | v | U+0076 | {lbd,frc,vcd} | v | v | vat | Angličtina
VA | ʋ | U+028B | {lbd,apr,vcd} | r<lbd> | v\ |  |
TH | θ | U+03B8 | {dnt,frc,vls} | T | T | thin | Angličtina
DH | ð | U+00F0 | {dnt,frc,vcd} | D | D | then | Angličtina
T | t | U+0074 | {alv,stp,vls} | t | t | talk | Angličtina
D | d | U+0064 | {alv,stp,vcd} | d | d | dig | Angličtina
N | n | U+006E | {alv,nas} | n | n | no | Angličtina
RR | r | U+0072 | {alv,trl,vcd} | r<trl> | r | torre, rojo | Španělština
DX | ɾ | U+027E | {alv,flp,vcd} | * | 4 | butter | Angličtina Spojené státy
S | s | U+0073 | {alv,frc,vls} | s | s | sit | Angličtina Spojené státy
Z | z | U+007A | {alv,frc,vcd} | z | z | zap | Angličtina Spojené státy
LSH | ɬ | U+026C | {alv,lat,frc,vls} |  | K |  |
LH | ɮ | U+026E | {alv,lat,frc,vcd} | z<lat> | K\ | caballo | Španělština/Zulu
RA | ɹ | U+0279 | {alv,apr} | r | r\ | puro | Španělština
L | l | U+006C | {alv,lat,apr,vcd} | l | l | lid | Angličtina Spojené státy
L vel | ɫ | U+026B | {alv,lat,apr,vcd} vel |  | 5 |  |
SH | ʃ | U+0283 | {pla,frc,vls} | S | S | she | Angličtina Spojené státy
SH pal | ʆ | U+0286 | {pla,frc,vls} pal |  |  |  |
ZH | ʒ | U+0292 | {pla,frc,vcd} | Z | Z | pleasure | Angličtina Spojené státy
ZH pal | ʓ | U+0293 | {pla,frc,vcd} pal |  |  |  |
TR | ʈ | U+0288 | {rfx,stp,vls} | t. | t` |  |
DR | ɖ | U+0256 | {rfx,stp,vcd} | d. | d` |  |
NR | ɳ | U+0273 | {rfx,nas,vcd} | n. | n` |  |
DXR | ɽ | U+027D | {rfx,flp,vcd} | *. | r` |  |
SR | ʂ | U+0282 | {rfx,frc,vls} | s. | s` |  |
ZR | ʐ | U+0290 | {rfx,frc,vcd} | z. | z` |  |
R | ɻ | U+027B | {rfx,apr,vcd} | r. | r\` | red | Angličtina Spojené státy
LR | ɭ | U+026D | {rfx,lat,vcd} | l. | l` |  |
RR rho | ɼ | U+027C | {rfx,trl} |  |  |  |
CT | c | U+0063 | {pal,stp,vls} | c | c |  |
JD | ɟ | U+025F | {pal,stp,vcd} | J | J\ |  |
NJ | ɲ | U+0272 | {pal,nas,vcd} | J |  | oignon | Francouzština
C | ç | U+00E7 | {pal,frc,vls} | C | C | sicher | Němčina
CJ | ʝ | U+029D | {pal,frc,vcd} | C<vcd> | j\ |  |
J | j | U+006A | {pal,apr,vcd} | j | j | yard | Angličtina Spojené státy
LJ | ʎ | U+028E | {pal,lat,apr,vcd} | l^ | L | gli | Italština
W | w | U+0077 | {lbv,apr,vcd} | w | w | with | Angličtina Spojené státy
K | k | U+006B | {vel,stp,vls} | k | k | cut | Angličtina Spojené státy
G | g | U+0067 | {vel,stp,vcd} | g | g | gut | Angličtina Spojené státy
NG | ŋ | U+014B | {vel,nas} | N | N | sing | Angličtina Spojené státy
X | x | U+0078 | {vel,frc,vls} | x | x | mujer | Španělština
GH | ɣ | U+0263 | {vel,frc,vcd} | Q | G | luego | Španělština
GA | ɰ | U+0270 | {vel,apr,vcd} | j<vel> | M\ |  |
GL | ʟ | U+029F | {vel,lat,vcd} | L | L\ |  |
QT | q | U+0071 | {uvl,stp,vls} | q | q |  |
QD | ɢ | U+0262 | {uvl,stp,vcd} | G | G\ |  |
QN | ɴ | U+0274 | {uvl,nas,vcd} | n" | N\ |  |
QQ | ʀ | U+0280 | {uvl,trl,vcd} | - | R\ |  |
QH | χ | U+03C7 | {uvl,frc,vls} | X | X |  |
RH | ʁ | U+0281 | {uvl,frc,vcd} | g" | R | rond | Francouzština
HH | ħ | U+0127 | {phr,frc,vls} | H | X\ |  |
HG | ʕ | U+0295 | {phr,frc,vcd} | H<vcd> | ?\ |  |
GT | ʔ | U+0294 | {glt,stp,vls} | ? | ? |  |
H | h | U+0068 | {glt,frc,vls} | h | h | help | Angličtina Spojené státy
WJ | ɥ | U+0265 | {lbp,apr,vcd} | j<rnd> | H | huit;juin | Francouzština

Afrikáty

Afrikáty (polosykavky) jsou souhlásky vznikající prvotním krátkým závěrem (jako exploziva) s následným uvolněním (jako frikativa).

Sada SAPI UPS obsahuje explicitní fonémy pro nejfrekventovanější afrikáty v hlavních jazycích. Specifikace IPA Unicode některé z těchto fonémů zahrnuje, ale ne všechny.

Tabulka obsahuje základní fonémy (složeniny UPS), které po svém složení vytvářejí výsledný explicitní foném (UPS).

UPS | Složenina UPS | IPA | Unicode | Popis IPA | Příklad | Jazyk
PF | P + F | p.f |  | {lbd,aff,vls} | Pfahl | Němčina
TS | T + S | t.s / ʦ | U+02A6 | {den,aff,vls} | Zahl | Němčina
CH | T + SH | t.ʃ / ʧ | U+02A7 | {pla,aff,vls} | chin | Angličtina
JH | D + ZH | d.ʒ / ʤ | U+02A4 | {pla,aff,vcd} | joy | Angličtina
JJ | J + J | j.j |  | {pal,aff,vcd} | hielo | Španělština
DZ | D + Z | d.z / ʣ | U+02A3 | {den,aff,vcd} | zona | Italština
CC | T + SC | t.ɕ / ʨ | U+02A8 | {pla,aff,vls} |  | mandarínská čínština
TSR | T + SR | t.ʂ |  | {rfx,aff,vls} |  | mandarínská čínština
JC | D + ZC | d.ʑ / ʥ | U+02A5 | {pla,aff,vcd} |  |

Existuje řada dalších afrikát nebo složených souhlásek, které mohou jiné jazyky vyžadovat. Například italština obsahuje asi 20 geminačních (párových) souhlásek. Sada UPS tyto speciální fonémy nezahrnuje, ale umožňuje jejich definování pomocí symbolu "+" nebo diakritického znaménka pro délku "lng" v případě párových souhlásek.

Samohlásky

Toto je výčet a křížové odkazy fonémů samohlásek používaných třemi fonetickými abecedami.

Pravidla značení samohlásek dle UPS

Pravidla značení samohlásek dle UPS jsou navržena tak, aby byly fonémy pokud možno intuitivní a udržela se fonetická podobnost mezi jednotlivými třídami. Štítky se řídí těmito pravidly:

  • Pro kardinální nebo hlavní samohlásky se používají štítky v délce jednoho znaku.
  • Pro nekardinální samohlásky a běžné dvojhlásky se používají štítky v délce dva znaky.
  • Maximální délka štítku je tři znaky.
  • Štítky pro středové samohlásky obsahují znak X, například AX, IX, UX.
  • Štítky pro samohlásky v zavřené slabice (obvykle po ní musí následovat souhláska v přízvučné slabice) obsahují H, například IH, UH.
  • U nebo O znamená rty zaokrouhlení rtů, například u AU, AO, EU.

Tabulka samohlásek

Uvedeny jsou čtyři tabulky, z nichž každá obsahuje výčet jiné kategorie samohláskových fonémů:

  • Jednoduché samohlásky
  • Dvojhlásky
  • Německé dvojhlásky
  • Nazály

Fonémy jednoduchých samohlásek (monoftongy)

Jednoduché samohlásky (monoftong – doslova "jeden zvuk" nebo "jeden tón") jsou ty, jejichž počáteční a konečná artikulační pozice je poměrně fixní a neklouže nahoru nebo dolů na novou artikulační pozici.

UPS | IPA | Unicode | Popis IPA | ASCII-IPA | X-SAMPA | Příklad | Jazyk
I | i | U+0069 | {hgh,fnt,unr,vwl} | I | i | feel | Angličtina
Y | y | U+0079 | {hgh,fnt,rnd,vwl} | Y | y | du | Francouzština
IX | ɨ | U+0268 | {hgh,cnt,unr,vwl} | i" | I\ |  |
YX | ʉ | U+0289 | {hgh,cnt,rnd,vwl} | U" | } |  |
UU | ɯ | U+026F | {hgh,bck,unr,vwl} | u- | M |  |
U | u | U+0075 | {hgh,bck,rnd,vwl} | u | u | too | Angličtina
IH | ɪ | U+026A | {smh,fnt,unr,vwl} | I | I | fill | Angličtina
YH | ʏ | U+028F | {smh,fnt,rnd,vwl} | I. | Y | hübsch | Němčina
UH | ʊ | U+028ª | {smh,bck,rnd,vwl} | U | U | book | Angličtina
E | e | U+0065 | {umd,fnt,urd,vwl} | e | e | ses | Francouzština
EU | ø | U+00F8 | {umd,fnt,rnd,vwl} | Y | 2 | blöd | Němčina
EX | ɘ | U+0258 | {umd,cnt,urd,vwl} | @<umd> | @\ |  |
OX | ɵ | U+0275 | {umd,cnt,rnd,vwl} |  | 8 |  |
OU | ɤ | U+0264 | {umd,bck,urd,vwl} | o- | 7 |  |
O | o | U+006F | {umd,bck,rnd,vwl} | o | o | go | Angličtina
AX | ə | U+0259 | {mid,cnt,unr,vwl} | @ | @ | ago | Angličtina
AX rho | ɚ | U+025ª | {mid,cnt,rho,vwl} | R |  | forensic | Angličtina
EH | ɛ | U+025B | {lmd,fnt,unr,vwl} | E | E | pet | Angličtina
OE | œ | U+0153 | {lmd,fnt,rnd,vwl} | W | 9 | plötzlich | Němčina
ER | ɜ | U+025C | {lmd,cnt,unr,vwl} | V" | 3 | bird | Angličtina Velká Británie
ER rho | ɝ | U+025D | {lmd,cnt,unr,rho,vwl} | @. |  | bird | Angličtina Spojené státy
UR | ɞ | U+025E | {lmd,cnt,rnd,vwl} | O" | 3\ |  |
H | ʌ | U+028C | {lmd,bck,unr,vwl} | V | V | cut | Angličtina
AO | ɔ | U+0254 | {lmd,bck,rnd,vwl} | O | O | dog | Angličtina
AE | æ | U+00E6 | {sml,fnt,unr,vwl} | & | { | cat | Angličtina
AEX | ɐ | U+0250 | {sml,cnt,unr,vwl} | 6 |  | Besser | Němčina
A | a | U+0061 | {low,fnt,unr,vwl} | a | a | valle | Španělština
AOE | ɶ | U+0276 | {low,fnt,rnd,vwl} | &. | & |  |
AA | ɑ | U+0251 | {low,bck,unr,vwl} | A | A | father | Angličtina
Q | ɒ | U+0252 | {low,bck,rnd,vwl} | A. | Q | hot | Angličtina

Fonémy dvojhlásek (diftongy)

Kromě monoftongů jsou v řadě jazyků obsaženy také diftongy (dvojhlásky) nebo dokonce triftongy (trojhlásky). Dvojhlásky (diftong – doslova "dva zvuky" nebo "dva tóny") jsou samohlásky, které mění během artikulace svou zvukovou strukturu, obsahují "polovokál", dochází při nich k plynulému pohybu jazyka z jedné artikulační polohy do druhé, například u anglických slov eye, boy nebo cow.

Dvojhlásky a trojhlásky mohou být v UPS prezentovány jako složenina samohlásek s využitím symbolu "+". Sada UPS nicméně obsahuje fonémy pro běžné dvojhlásky, což zlepšuje čitelnost slovníků. Níže uvedená tabulka obsahuje jak složeniny ze dvou fonémů s využitím symbolu "+", tak i následné fonémy UPS.

Složenina UPS | UPS | IPA | X-SAMPA | Příklad | Jazyk | Příklad | Jazyk
E + I | EI | e.ɪ | eI | late | Angličtina | late | Angličtina
A + UH | AU | ɑ.ʊ | aU | foul | Angličtina | Haus | Němčina
AO + I | OI | ɔ.ɪ | OI | toy | Angličtina | Kreuz | Němčina
A + I | AI | ɑ.ɪ | ai | bite | Angličtina | Eis | Němčina
I + AX | IYX | i.ə | i:6 | Tier | Němčina | fear | Angličtina
Y + AX | UYX | y.ə | y:6 | Tür | Němčina |  |
EH + AX | EHX | ɛ.ə | E6 | Berg | Němčina | stairs | Angličtina
U + AX | UWX | u.ə | u:6 | Kur | Němčina | lure | Angličtina
O + AX | OWX | o.ə | o:6 | Ohr | Němčina | boa | Angličtina
AO + AX | AOX | ɔ.ə | O6 | dort | Němčina | four | Angličtina

Německé dvojhlásky

Německý jazyk má několik středových dvojhlásek, které nemají přiřazen explicitní UPS foném a musí být prezentovány ve formě složenin fonémových hlásek. Fonetickou kompletnost doplňuje použití diakritického znaménka "lng".

Složenina UPS | IPA | X-SAMPA | Příklad | Jazyk
IH + AX | ɪ.ə | I6 | Wirt | Němčina
YH + AX | ʏ.ə | Y6 | Türke | Němčina
EY lng + AX | e.ə | e:6 | schwer | Němčina
EH lng + AX | ɛ:.ə | E:6 | Bär | Němčina
EU lng + AX | ø.ə | 2:6 | Föhr | Němčina
OE + AX | œ.ə | 96 | Wörter | Němčina
A lng + AX | a.ə | a:6 | Haar | Němčina
A + AX | a.ə | a6 | hart | Němčina
UH + AX | ʊ.ə | U6 | kurz | Němčina

Fonémy nazálních hlásek

Sada UPS obsahuje fonémy čtyř nazálních samohlásek. Tyto fonémy obsahuje následující tabulka spolu s příklady francouzských slov.

Složenina | UPS | X-SAMPA | Příklad | Jazyk
E nas | EN | e~ | vin | Francouzština
A nas | AN | a~ | vent | Francouzština
O nas | ON | o~ | bon | Francouzština
OE nas | OEN | 9~ | brun | Francouzština

Diakritické fonémy

Toto je výčet a křížové odkazy diakritických fonémů používaných třemi fonetickými abecedami.

Diakritický foném

Diakritické fonémy se používají k modifikaci segmentálních fonémů (samohlásek, souhlásek, mlaskavek a ražených souhlásek) pomocí dalších fonetických informací. Diakritické fonémy nelze použít samostatně. Diakritické fonémy vždy modifikují předcházející segmentální foném. Segmentální symbol může být následován libovolným počtem diakritických fonémů.

UPS | IPA | Unicode | Popis IPA | ASCII-IPA | X-SAMPA
+ | ͡ | U+0361 | Vázání |  | _
adv | o̟ | U+031F | Přednější |  | _+
api | t̺ | U+033A | Apikální |  | _a
asp | tʰ | U+02B0 | Přídech | ^lt;h> {asp} | _h
atr | e̘ | U+0318 | Posun kořene jazyka dopředu |  | _A
bvd | b̤ | U+0324 | Dyšná fonace |  | _t
cen | ë | U+0308 | Střednější | " | _"
cvd | b̰ | U+0330 | Třepená fonace |  | _k
den | t̪ | U+032A | Dentální | [ / {dnt} | _d
ejc | pʼ | U+02BC | Ražená | {ejc} | _>
lab | tʷ | U+02B7 | Labializovaná | <w> {lzd} | _w
lam | t̻ | U+033B | Laminální |  | _m
lar | dˡ | U+02E1 | Laterální ploze |  | _l
lla | n̼ | U+033C | Lingvolabiální |  | _N
low | e̞ | U+031E | Snížená |  | _o
lrd | o̜ | U+031C | Méně zaokrouhlená |  | _c
mcn | e̽ | U+033D | Střednější a středovější |  | _x
mrd | o̹ | U+0339 | Více zaokrouhlená |  | _O
nar | d̚ | U+031A | Bez slyšitelné ploze |  | _}
nas | ñ | U+0303 | Nazalizovaná | ~ / <nzd> | ~ / _~
nsr | oⁿ | U+207F | Nosní ploze |  | _n
nsy | n̯ | U+032F | Neslabičná |  | _^
pal | tʲ | U+02B2 | Palatalizovaná | ; / {pzd} | '
phr | nˤ | U+02E4 | Faryngalizovaná |  | _?\
rai | e̝ | U+031D | Zvýšená |  | _r
ret | o̱ | U+0331 | Zadnější |  | _-
rho | ə˞ | U+02DE | Zabarvení do r |  | `
rtr | e̙ | U+0319 | Posun kořene jazyka dozadu |  | _q
syl | n̩ | U+0329 | Slabikotvorná | {syl} | = / _=
vcd | s̬ | U+032C | Znělá |  | _v
vel | tˠ | U+02E0 | Velarizovaná | {vzd} | _G
vls | n̊ | U+030A | Neznělá |  | _0
vph | l̴ | U+0334 | Velarizovaná nebo faryngalizovaná | {fzd} | _e

Suprasegmentální jevy

Toto je výčet a křížové odkazy fonémů suprasegmentálních jevů používaných třemi fonetickými abecedami.

Suprasegmentální fonémy

Suprasegmentální jevy popisují jevy v jazyce přesahující úroveň jednotlivých souhlásek a samohlásek, jako prozódie, tón, délku hlásek a přízvuk.

První sada suprasegmentálních symbolů včetně mapy "propojení" přímo na sadu suprasegmentálních jevů dle IPA s hodnotami IPA Unicode. Tato sada obsahuje délku diakritických znamének – dlouhé, polodlouhé a extra-krátké. Délka se ve fonematice používá často, takže značky délky by mohly patřit také do tabulky diakritických znamének. Z tohoto důvodu jsou štítky diakritiky uvedeny malými písmeny.

Zbývající suprasegmentální symboly se v sadě UPS používají k popisu intonačních kontur ve značkovacích jazycích hlasových syntéz ("prompt" dokumenty SSML). Tyto symboly UPS byly vytvořeny přidáním prefixu s podtržítkem k původním štítkům SAPI. Díky tomu jsou snadněji identifikovatelné jako třída a omezí se tím jakákoliv nejednoznačnost v odlišení od jiných symbolů IPA. Například starý symbol SAPI pro zakončení věty "!" je v IPA symbolem pro alveolární mlaskavku.

UPS | IPA | Unicode | Popis IPA | X-SAMPA | Ekvivalent SAPI
S1 | ˈ | U+02C8 | Primární přízvuk | " | 1
S2 | ˌ | U+02CC | Sekundární přízvuk | % | 2
. | . | U+002E | Slabičný předěl | . |
_| | | | U+007C | Malá pauza | | |
_|| | ‖ | U+2016 | Velká pauza | || |
lng | ː | U+02D0 | Dlouhá | : |
hlg | ˑ | U+02D1 | Polodlouhá | :\ |
xsh | ˘ | U+02D8 | Extra-krátká | _X |
_^ | ‿ | U+203F | Vázání (absence pauzy) | -\ |
_! |  |  | Intonace – vykřičník |  | ! Zakončení věty (vykřičník)
_& |  |  | Intonace - pokračovací |  | & Hranice slova
_, |  |  | Intonace - nekoncová stoupavá |  | , Zakončení věty (čárka)
_s |  |  | Ticho |  | _ Ticho (podtržení)
_. | ↘ | U+2198 | Intonace – klesavá | <F> | . Zakončení věty (tečka)
_? | ↗ | U+2197 | Intonace - tázací stoupavá | <R> | ? Zakončení věty (otazník)

Mlaskavky a ražené souhlásky

Toto je výčet a křížové odkazy fonémů mlaskavek a ražených souhlásek používaných třemi fonetickými abecedami.

Fonémy mlaskavek a ražených souhlásek

IPA používá k popisu ražených souhlásek diakritická znaménka, ale pro mlaskavky a imploziva má vytvořeny speciální fonémy. Mlaskavky a ražené souhlásky jsou neznělé souhlásky, zatímco imploziva mohou být částečně znělé.

UPS | IPA | Unicode | Popis IPA | X-SAMPA
PCK | ʘ | U+0298 | blb,clk | O\
TCK | ǀ | U+01C0 | dnt,clk | |\
NCK | ! | U+0021 | alv,clk | !\
CCK | ǂ | U+01C2 | pla,clk | =\
LCK | ǁ | U+01C1 | alv,lat,clk | |\|\
BIM | ɓ | U+0253 | blb,imp,vcd | b_<
DIM | ɗ | U+0257 | dnt-alv,imp,vcd | d_<
QIM | ʛ | U+029B | uvl,imp,vcd |
QIM vls | ʠ | U+02A0 | uvl,imp,vls |
GIM | ɠ | U+0260 | vel,imp,vcd | g_<
JIM | ʄ | U+0284 | pal,imp,vcd |
P ejc | pʼ | 0070 02BC | blb,ej | b_>
T ejc | tʼ | 0074 02BC | dnt-alv, ej | t_>
K ejc | kʼ | 006B 02BC | vel ej | g_>
S ejc | sʼ | 0073 02BC | alv fric ej | s_>
QT ejc | qʼ | 0071 02BC | uvl,ej |

Tóny

Toto je výčet a křížové odkazy fonémů tónů používaných třemi fonetickými abecedami.

Fonémy tónů

Tón popisuje využívání výšky řečových zvuků v hlásky k rozlišení lexikálního nebo gramatického významu. Lexikální tóny mohou následovat po samohlásce nebo také po slabikotvorné souhlásce. Mohou být formovány z jednoduchých úrovní na univerzální škále, která má maximálně pět úrovní kontrastu, nebo se může jednat o kontury složené ze sekvencí tónů. Sekvence tří tónů by měla být pro popis jakékoliv tónové kontury dostatečná.

IPA obsahuje soubor lexikálních tónů a tónových kontur. V sadě UPS naleznete pět lexikálních tónů nacházejících se v IPA a dále vzestup a sestup tónu. Všechny tónové kontury mohou být v sadě UPS prezentovány formou tónových složenin.

Sada UPS neobsahuje tonální symboly pro následující symboly IPA: extra nízký, vysoký, střední, nízký, extra nízký. Všechny tyto symboly mohou být definovány v sadě UPS pomocí tónových sekvencí. Stoupavá intonace a klesavá intonace jsou ekvivalenty k jevům "intonace – sestup" a "intonace – vzestupná otázka" v sadě UPS ("Suprasegmentální jevy").

UPS | IPA | Unicode | Popis IPA | X-SAMPA
T5 | e̋ | U+030B | Extra vysoký | _T
T4 | é | U+0301 | Vysoký | _H
T3 | ē | U+0304 | Střední | _M
T2 | è | U+0300 | Nízký | _L
T1 | ȅ | U+030F | Extra nízký | _B
T- | ↓ | U+2193 | Pokles tónu | !
T+ | ↑ | U+2191 | Vzestup tónu | ^

Ostatní fonémy

Toto je výčet a křížové odkazy málo používaných fonémů, které nejsou uvedeny v jiných tabulkách fonémů, ale jsou používané třemi fonetickými abecedami.

Ostatní fonémy

UPS | IPA | Unicode | Popis IPA | ASCII-IPA | X-SAMPA
WH | ʍ | U+028D | lbv,frc,vls | w<vls> | W
ESH | ʜ | U+029C | epl,frc,vls |  | H\
EZH | ʢ | U+02A2 | epl,frc,vcd |  | <\
ET | ʡ | U+02A1 | epl,stp |  | >\
SC | ɕ | U+0255 | pla,frc,vls |  | s\
ZC | ʑ | U+0291 | pla,frc,vcd |  | z\
LT | ɺ | U+027A | alv,lat,flp | *<lat> | l\
SHX | ɧ | U+0267 | simultánní SH a X |  | x\
HZ | ɦ | U+0266 | glt,frc,vcd |  | h\