Balabolka (Text-To-Speech)

Balabolka

Balabolka je program, určený primárne k prevodu textu na reč prostredníctvom systému TTS (Text-To-Speech). Podporuje prácu so všetkými hlasovými syntézami, inštalovanými vo vašom systéme. Pomocou položky 'Otvoriť' v ponuke 'Súbor' je možné v programe zobraziť a editovať všetky bežné textové dokumenty. Nový dokument je možné jednoducho vytvoriť položkou 'Nový', taktiež v ponuke 'súbor'.

Základné funkcie čítania je možné jednoducho ovládať pomocou tlačidiel (Prehrať, pozastaviť, Zastaviť), umiestnených na nástrojovej lište pri hornom okraji okna programu. Medzi ďalšie funkcie patrí napr. čítanie obsahu schránky, prezeranie dokumentov pokročilých formátov, možnosť definovať vlastné farby písma a pozadia či ovládanie globálnymi klávesovými skratkami.

Podporované formáty súborov: AZW, AZW3, CHM, DjVu (DjVu+OCR), DOC, DOCX, EML, EPUB, FB2 (FB2.ZIP, FBZ), FB3, HTML, LIT, MD, MOBI, ODP, ODS, ODT, PDB, PDF, PPT, PPTX, PRC, RTF, TCR, WPD, XLS, XLSX. Pre rozšírenie podpory o ďalšie (programom nepodporované) typy súborov je možné použiť rozhranie IFilter.

V programe zobrazený text je možné uložiť ako zvukový súbor WAV, MP3, MP4, OGG, OPUS či WMA použitím položky 'Súbor / Uložiť zvukový súbor' či 'Súbor / Uložiť a konvertovať na zvukové súbory' v hlavnej ponuke.

Ďalej Balabolka podporuje ukladanie synchronizovaného textu do externých súborov *.lrc či do ID3 značiek, ktoré sú priamou súčasťou výsledných zvukových súborov. Ak je takýto súbor prehrávaný v prehrávačoch s podporou týchto formátov, je text zobrazovaný synchronizovane, podobne ako napr. texty piesní.

Program podporuje rozhranie Microsoft Speech API (SAPI) a Microsoft Speech Platform. U všetkých hlasov je možné nastaviť príslušné parametre, napr. rýchlosť a výšku.

V záujme zlepšenia výslovnosti je možné uplatniť Zoznamy nahradení. Táto funkcia je užitočná v prípadoch, kedy používateľ chce zmeniť výslovnosť jednotlivých slov či slabík. Balabolka podporuje tri typy zoznamov nahradení:

  • pravidlá pre úpravu výslovnosti tvorené pomocou regulárnych výrazov, uložené v súboroch s príponou *.rex;
  • súbory s príponou *.dic; tento formát je populárny vo východnej Európe. Zápis pravidiel je veľmi jednoduchý, súbor môže obsahovať tisíce pravidiel;
  • súbory s príponou *.bxd združujú možnosti dvoch predchádzajúcich formátov.

Súbory pre úpravu výslovnosti sú uložené v priečinku Dokumenty\Balabolka. Ak je použitý niektorý slovník, program behom čítania zvýrazňuje celú vetu či odsek, v opačnom prípade je zvýraznené vždy aktuálne slovo.

Poznámka. Prenosná verzia Balabolky ukladá súbory pre úpravu výslovnosti do podpriečinku Dictionaries v priečinku programu.

* Balabolka je ruské slovo, voľne preložené ako tárajko.

WWW: balabolka.site

E-mail: crossa@list.ru

© 2006-2020 Ilya Morozov


Hlasy

Speech Application Programming Interface či SAPI je rozhranie, vytvorené spoločnosťou Microsoft za účelom jednoduchého použitia hlasových syntéz v aplikáciách Windows. K dispozícii sú dve hlavné verzie tohto rozhrania (SAPI 4 a SAPI 5), ktoré nie sú vzájomne kompatibilné.

SAPI 4 (Microsoft Speech API 4.0)

Hlasy rozhrania SAPI 4 však pomaly zastarávajú a ich inštaláciu neodporúčame.

SAPI 5 (Microsoft Speech API 5.x)

Yaroslav Kozak (Lvov, Ukrajina) vytvoril ukrajinský hlas UkrVox:

  • UkrVox Igor

Ekho - free TTS engine (podporuje kantončinu a mandarínčinu):

  • Echo (čínština)

Aby ste získali lepšiu kvalitu hlasu, môžete zakúpiť produkty firiem Acapela Group, Cepstral, IVONA či Speechtech. Jedná sa o novú generáciu hlasov, používajúcu veľké databázy hlasových vzoriek. Výstupná kvalita týchto hlasov je na veľmi dobrej úrovni.

Komerčné hlasy s vysokou kvalitou:

  • Acapela Group (demo)
  • Alfanum (demo)
  • Cepstral (demo)
  • IVONA (demo)
  • Nuance/Cerence (demo)
  • ReadSpeaker (demo)
  • Speechtech (demo)

V prípade záujmu o zakúpenie hlasovej syntézy Speechtech sa neváhajte obrátiť na e-mailovú adresu obchod@adaptech.cz.

Microsoft Speech Platform

Microsoft Speech Platform je ďalšou možnosťou pre vývoj a používanie hlasových syntéz. Pozostáva z knižnice samotného rozhrania a knižníc pre rozpoznávanie reči a jej syntézu. K dispozícii sú oddelené spustiteľné súbory jazykov pre rozpoznávanie a syntézu reči. Verzie jazykov musia zodpovedať verzii Speech Platform, ktorú máte inštalovanú.

Microsoft speech Platform nainštalujete nasledujúcim spôsobom:

  1. Stiahnite a nainštalujte Speech Platform Runtime
    (súbor 'x86_SpeechPlatformRuntime\SpeechPlatformRuntime.msi').
  2. Stiahnite a nainštalujte Jazykové balíčky pre použitie so Speech Platform
    (názvy súborov začínajúce 'MSSpeech_TTS_').

Microsoft Speech Platform verzia 11.0 prináša podporu 26 jazykov a s nimi súvisiacich hlasových syntéz. Značky XML sú použiteľné pre hlasy Sapi 5 aj pre Speech Platform.


Príkazový riadok

Balabolku je možné ovládať i pomocou parametrov príkazového riadku.

balabolka.exe [-parametre] [názov súboru] [zvukový súbor] [hlas]

Parameter hlas musí byť definovaný nasledovne:

Meno hlasu [rrýchlosť] [pvýška]

názov súboru
otvoriť súbor

-c
čítať obsah schránky

-c meno hlasu
zvoliť príslušný hlas a čítať obsah schránky

-m
spustiť minimalizovaný

-r názov súboru
otvoriť súbor a čítať od začiatku

-r názov súboru meno hlasu
otvoriť súbor, zvoliť hlas a čítať od začiatku

-s názov súboru zvukový súbor
otvoriť súbor a čítať do zvukového súboru (WAV, MP3, MP4, OGG či WMA)

-s názov súboru zvukový súbor meno hlasu
otvoriť súbor, zvoliť hlas a čítať do zvukového súboru

-q
po skončení čítania ukončiť program

Meno hlasu môže byť určené len jedným slovom; Napr.: Miro. Program automaticky vyberie príslušný hlas zo zoznamu všetkých sapi 4 a sapi 5 hlasov inštalovaných v systéme.

Nasledujúce parametre je možné použiť súčasne:

-rm názov súboru
spustiť minimalizovaný a čítať určený súbor

-rq názov súboru
čítať určený súbor a následne ukončiť program

Príklady:

balabolka.exe kniha.txt

balabolka.exe kniha.txt miro

balabolka.exe -rmq kniha.txt

balabolka.exe -sq "d:\knihy\kniha.txt" "d:\zvukové knihy\kniha.wav"

balabolka.exe -r "d:\knihy\kniha.txt" Miro r180 p85

balabolka.exe -c Miro

Namiesto názvu súboru je možné zadať i textový reťazec, je však treba použiť špeciálny modifikátor:

-n [reťazec]
tento parameter určuje, že príkazový riadok obsahuje textový reťazec namiesto názvu súboru

Príklad:

balabolka.exe -n "textový reťazec"

balabolka.exe -rn "Program prečíta tento text." Miro

balabolka.exe -snq "Tento text bude uložený do zvukového súboru." "d:\zvukové knihy\kniha.mp3"


Kontrola pravopisu

Balabolka zahrňuje modul pre kontrolu pravopisu Common Speller API (CSAPI). CSAPI bolo vytvorené pre použitie so všetkými aplikáciami spoločnosti Microsoft, ktoré obsahujú kontrolu pravopisu. Aktuálne je CSAPI ponúkané mnohými výrobcami a používané ako súčasť Microsoft Office 97 / 2000 a ďalších aplikácií. Samotné CSAPI nie je priamou súčasťou Balabolky, no jednako ak máte inštalovaný Microsoft Office, Balabolka automaticky zistí prítomnosť CSAPI a použije ho pre kontrolu pravopisu.

V okne programu je možné použiť kontextovú ponuku nástroje pre kontrolu pravopisu. Kliknite pravým tlačidlom na zvýraznené slovo. Zobrazí sa kontextová ponuka, ktorá vám umožní vybrať správne nahradenie pre opravu pravopisu uvedeného slova. Položka Pridať slovo do slovníku pridá dané slovo do používateľského slovníku. Ak sa nenachádzajú v slovníku návrhy pre opravu daného slova, v kontextovej ponuke nebude nič zobrazené.

Pre kontrolu pravopisu je možné použiť aj príslušný dialóg (Položka ponuka 'Text / Kontrola pravopisu"). Nasleduje popis tlačidiel tohto dialógu:

  • Nahradiť - nahradí aktuálne slovo jeho opraveným variantom, vybraným v poli 'Návrhy'.
  • Nahradiť všetko - nahradí všetky výskyty vybraného slova v texte jeho opraveným variantom, vybraným v poli 'Návrhy'.
  • Ignorovať - preskočí aktuálne slovo a pokračuje k ďalšiemu výskytu chybného slova.
  • Ignorovať všetko - preskočí všetky výskyty aktuálneho slova v texte a pokračuje k ďalšiemu výskytu chybného slova. Ignorované slovo bude následne považované za správne po celú dobu behu aktuálnej inštancie programu.
  • Pridať - pridá aktuálne slovo do používateľského slovníku.

'Používateľský slovník' je textový súbor s príponou *.dic. obsahujúci skupinu slov. Hlavným dôvodom pre používateľský slovník je možnosť definovať vlastné slová pre kontrolu pravopisu. Microsoft Office 97/2000 má používateľský slovník v nasledujúcom umiestnení: c:\Program Files\Common Files\Microsoft Shared\Proof\custom.dic.

Balabolka podporuje možnosť definovať dva jazyky pre kontrolu pravopisu (začiarkavacie pole Druhý jazyk). Dialóg pre kontrolu pravopisu je pri použití druhého jazyka zakázaný, pre kontrolu pravopisu je možné použiť len príslušnú kontextovú ponuku.

Balabolka môže pre kontrolu pravopisu používať Hunspell (hunspell.github.io). Hunspell je predvoleným rozhraním pre kontrolu pravopisu v aplikáciách OpenOffice.org a Mozilla Firefox.

Slovníky kontroly pravopisu pre Windows je možné stiahnuť na stránkach Balabolky.

Program podporuje i kontrolu pravopisu, ktorá je priamou súčasťou systému Windows. Api pre kontrolu pravopisu je dostupné od Windows 8.


Find and Replace Text

The program allows to search for text in the current document and replace it with different text. Most of special codes from Microsoft Word are supported for the non-printing characters (codes are case-sensitive):

^p
Paragraph mark
^t
Tab character
^nnn
ASCII character (where nnn is the character code)
^0 nnn
ANSI character (where 0 is zero and nnn is the character code)
^U nnnnn
Unicode character (where nnnnn is the character code)
^+
Em dash ( — )
^=
En dash ( – )
^^
Caret character
^s
Nonbreaking space
^?
Any character (in the Find what box only)
^#
Any digit (in the Find what box only)
^$
Any letter (in the Find what box only)
^c
Microsoft Windows Clipboard contents (in the Replace with box only)
^&
Contents of the Find what box (in the Replace with box only)


často kladené dotazy

Často pokladané otázky

Dotaz

Objavuje sa chybová správa: "OLE error 80045042". Čo znamená?

Odpoveď

Táto chyba znamená, že Parser XML zlyhal kvôli chybnej syntaxi značiek XML v texte. Je tiež možné, že niektorý úsek textu vypadá ako začiatok značky XML. Ak nechcete používať značky XML, odstráňte z textu znaky "<" a ">" , prípadne ich nahraďte slovami "menší ako" a "väčší ako").

Dotaz

Kde môžem získať SAPI 4?

Odpoveď

Aby ste mohli používať hlasy SAPI 4, stiahnite a nainštalujte súbor Microsoft Speech API (824 KB). Môžete stiahnuť a nainštalovať rovnako Microsoft Ovládací panel hlasov (840 KB). Ovládací panel hlasov SAPI 4 pridá ikonu do vašich Ovládacích panelov a umožní vám získať zoznam inštalovaných Sapi 4 hlasov a nastavovať ich parametre.

Dotaz

Kde je možné získať SAPI 5?

Odpoveď

Windows XP a vyšší už Sapi 5 obsahujú.

Ak používate predchádzajúcu verziu Windows, inštalátor SAPI 5.1 môžete získať tu (6.3 MB).

Dotaz

Ako zistím, ktoré hlasové syntézy mám inštalované v počítači?

Odpoveď

Všetky hlasové syntézy, inštalované v počítači, sú viditeľné v ovládacom paneli prevodu textu na reč.

Dotaz

Ako môžem zaistiť tichú inštaláciu Balabolky?

Odpoveď

K inštalácii Balabolky v tichom režime môžete použiť tichú inštaláciu. Tichá inštalácia je vykonateľná pomocou parametru príkazového riadku -silent.

Dotaz

Otváram súbor s príponou DjVu, no jednako program nezobrazuje žiadny text. Čo je nesprávne?

Odpoveď

Formát DjVu bol vytvorený pre ukladanie naskenovaných dokumentov. Súbor DjVu obsahuje obrazy stránok kníh, časopisov a pod. DjVu môže rovnako obsahovať textovú vrstvu OCR.

Balabolka extrahuje text len z tejto vrstvy. Ak nie je prítomná, jedinou cestou k získaniu textu, je použitie externého programu pre spracovanie OCR, napr. FineReaderu.

Dotaz

V mojom počítači sú inštalované dve zvukové karty. Ako vybrať zariadenie pre prehrávanie syntézy textu?

Odpoveď

Príslušné zariadenie je možné vybrať v Ovládacom paneli Prevodu textu na reč, použitím tlačidla Zvukový výstup. Balabolka rovnako obsahuje položku hlavnej ponuky 'Možnosti / Zvukový výstup'.

Dotaz

V mojom počítači je inštalovaná 64 bitová verzia Windows. Nainštaloval som 64- bitovú verziu balíčku pre Microsoft Speech Platform a anglické hlasy. No jednako zoznam dostupných hlasov je stále prázdny. Kde je problém?

Odpoveď

Balabolka je 32 bitová aplikácia. Pre funkčnosť rozhrania Speech Platform je teda treba nainštalovať jeho 32 bitovú verziu.

Dotaz

Hlas hovorí slovo "medzera" vždy, keď text obsahuje nedeliteľnú medzeru (ALT+0160). Ako to opraviť?

Odpoveď

Program môže nedeliteľné medzery automaticky nahradzovať bežnými medzerami. Zvoľte položku hlavnej ponuky 'Možnosti / Nastavenia' a na karte čítanie začiarknite pole Ignorovať znaky počas čítania. Následne pridajte symbol nedeliteľné medzery do zoznamu ignorovaných znakov stlačením ALT a napísaním "0160" na numerickom bloku.

Dotaz

Ako môžem odstrániť pomlčky na začiatku odsekov?

Odpoveď

Môžete použiť položku hlavnej ponuky 'úpravy / Nahradiť". Do poľa Nájsť napíšte ^p— a do poľa Nahradiť ^p. Program podporuje väčšinu špeciálnych kódov aplikácie Microsoft Word:

^p
Značka odseku
^t
Znak Tabulátoru
^nnn
Znak ASCII (kde nnn je kód znaku)
^0 nnn
Znak ANSI (kde 0 je nula a nnn je kód znaku)
^U nnnnn
Znak Unicode (kde nnnnn je kód znaku)
^+
Dlhšia pomlčka ( — )
^=
Dlhá pomlčka ( – )
^^
Znak Strieška
^s
Nedeliteľná medzera
^?
Ktorýkoľvek znak (platí len pre pole Nájsť)
^#
Ktorákoľvek číslica (platí len pre pole Nájsť)
^$
Ktorékoľvek písmeno (platí len pre pole Nájsť)
^c
Obsah schránky Windows (platí len pre pole Nahradiť)
^&
Obsah poľa Nájsť (platí len pre pole Nahradiť)

Dotaz

Je možné používať regulárne výrazy vo funkciách Nájsť a Nahradiť, dostupných z hlavnej ponuky 'úpravy'?

Odpoveď

Áno, je to možné. Pokiaľ text v poli Nájsť začína reťazcom %rex%, program bude nasledujúci text považovať za regulárny výraz. Napr. ak je treba v dokumente prehodiť dvojice číslic, zvoľte položku hlavnej ponuky 'úpravy / Nahradiť'. Následne do poľa Nájsť zapíšte %rex%(\d)(\d) a do poľa Nahradiť zapíšte $2$1 a stlačte tlačidlo Nahradiť všetko. Ak je použitý regulárny výraz, možnosť 'Len celé slová' nie je dostupná. Je možné použiť len možnosť 'Rozlišovať malé a veľké písmená'.

Dotaz

Čo je Prevod textu na reč Google?

Odpoveď

V prekladači Google na webe je k dispozícii tlačidlo 'Počúvanie', ktoré skonvertuje preložený text na reč. Po stlačení tohto tlačidla začne váš webový prehliadač sťahovať súbor Mp3. Táto služba podporuje prevod textu nie dlhšieho ako 100 znakov. Balabolka je schopná rozdeliť väčší text na malé úseky, z každého vytvoriť zvukový súbor a tie následne opäť spojiť. Sú podporované formáty WAV, MP3 a OGG.

Dotaz

Pre konvertovanie titulkov na zvukové súbory používam hlasy Espeak. No jednako výsledný zvukový súbor obsahuje len hlas bez pomĺk. Kde je problém?

Odpoveď

Dôrazne neodporúčam pre prevod titulkov používať hlasy Espeak! Tieto hlasy nepodporujú značku Xml "silence". Ten istý problém sa vyskytoval u starších verzií niektorých ďalších hlasov. Pre konvertovanie titulkov odporúčam používať najlepšie poslednú verziu komerčných hlasových syntéz (Cepstral, CereProc, IVONA, Speechtech, a pod.).

Dotaz

Nie som spokojný s úrovňou, na ktorej Balabolka extrahuje text zo súborov PDF. Môžem spracovávať PDF nejakým iným spôsobom?

Odpoveď

Extrakcia textu z PDF dokumentov je komplikovaná, pretože súbory PDF často neobsahujú prostý text. Pre extrakciu je možné použiť externý nástroj príkazového riadku, napr. program pdftotext.exe Xpdf. Súbor pdftotext.exe skopírujte do podpriečinku "utils" v priečinku Balabolky, zvoľte položku hlavnej ponuky 'Možnosti | Import textu', karta 'Pokročilý import textu' a kliknite na tlačidlo 'Pridať
%BFolder%\utils\pdftotext.exe -q -nopgbrk -enc UTF-8 %Input% %Output%

Zadajte názov konvertoru (napr. "Konvertor XPDF"), príponu súborov ("PDF") a výstupné kódovanie ("UTF-8"). Po začiarknutí položky Použiť namiesto predvolenej metódy prevodu pre tento typ súborov program bude schopný pre extrakciu textu zo súborov PDF použiť túto externú pomôcku.

Dotaz

Čo je Spritz-Reader?

Odpoveď

Spritz je nová technológia rýchleho čítania. Podporuje rýchle čítanie kdekoľvek, pri rýchlostiach od 100 do 1000 slov za minútu. Pri bežnom čítaní je časovo najnáročnejší hlavne pohyb očí medzi slovami a vetami. Spritz zobrazuje slová na obrazovke spôsobom, pri ktorom je možné čítať s čo najväčším vylúčením pohybu očí.

Dotaz

Windows 10 obsahuje nové hlasy Microsoft Jakub Mobile a Microsoft Zira Mobile, avšak v zozname hlasov nie sú dostupné. Je možné tieto hlasy nejako odomknúť?

Odpoveď

V predvolenom stave sú hlasy Microsoft mobile uzamknuté pre použitie cez SAPI 5. Odomknúť ich môžete jednoduchou úpravou registru. Stiahnite tento archív, rozbaľte súbor, zodpovedajúci vášmu jazyku a vašej verzii systému Windows ("mobile_x86.reg" pre 32 bitovú a "mobile_x64.reg" pre 64 bitovú verziu). Po uplatnení príslušného súboru budú hlasy Microsoft Mobile odomknuté pre použitie cez bežné SAPI.

Dotaz

Niektoré dokumenty obsahujú dlhé adresy URL. Ako je možné zaistiť, aby Balabolka tieto adresy čítala krátko?

Odpoveď

Tento problém môže byť vyriešený použitím slovníku pre úpravu výslovnosti. Do súboru s príponou REX pridajte nasledujúce pravidlo:

((http|ftp|https)://)?(www\.)?([-a-zA-Z0-9@:%._\+~#\=]{2,256}\.[a-z]{2,6}\b)([-a-zA-Z0-9@:%_\+.~#?&//\=]*)=$4

Regulárny výraz nahradí webovú adresu menom domény (napr. "adaptech.cz").

Dotaz

Môžem použiť prvý riadok textu ako názov zvukového súboru (napr. "01 časť 1.mp3", "02 časť 2.mp3")?

Odpoveď

Do poľa "Vzor pre výstupný súbor" v okne "Konvertovať a rozdeliť na zvukové súbory" zapíšte %FirstLine%. Program nahradí túto premennú prvým riadkom každého úseku textu. Pre zmenu pozície poradového čísla v názve súboru použite premennú %Number%.

Dotaz

Čo je rozhranie IFilter?

Odpoveď

Rozhranie IFilter pracuje s textovými dokumentmi. Ponúka filtre pre extrakciu textu z proprietárnych formátov. Toto rozhranie používajú napr. fulltextové vyhľadávače. IFiltre sú dostupné pre Adobe PDF, WordPerfect a mnohé ďalšie populárne formáty súborov. Inštalačné súbory I-filtrov je možné získať od príslušných výrobcov. Viacej informácií je možné získať napr. na stránkach IFilter.org. Pretože Balabolka je 32 bitová aplikácia, inštalujte len 32 bitové verzie I-filtrov.

Dotaz

Ako zmením hlas počas čítania?

Odpoveď

Použite značky XML. Počiatočnú a koncovú značku je odporúčané zapisovať v rámci rovnakého odseku. Príklad:

<voice required="Name=Jakub">Ahoj, ako sa darí?</voice>
<voice required="Name=Miro">Mám sa fajn.</voice>

Dotaz

Môžem súbory vytvorené Balabolkou použiť vo videách na YouTube?

Odpoveď

Balabolka je freeware, takže zvukové súbory môžete vytvárať zadarmo. No jednako ak používate komerčné hlasy, budete musieť kontaktovať výrobcu príslušného hlasu a zakúpiť licenciu pre komerčné použitie či distribúciu zvuku. Licencia pre distribúciu zvuku vám umožní použiť hlas vo videách na Youtube.

Príkladom môže byť informácia na stránkach spoločnosti Cepstral: "Osobné hlasy Cepstral sú určené len pre osobné použitie a nie sú určené pre distribúciu zvuku. To znamená, že zvuky, ktoré vytvoríte, sú určené len pre vaše osobné použitie a nesmú byť zdieľané s ďalšími osobami ani nesmú byť použité vo videách, prezentáciách či na webových stránkach. Ak máte záujem o licenciu pre distribúciu zvuku, kontaktujte, prosím, predajcu."


Pravidlá nahradení

Panel slovníkov

Za účelom zlepšenia výslovnosti je možné v programe použiť špeciálny textový súbor (slovník) s pravidlami nahradení. Každý riadok tohto súboru obsahuje jedno pravidlo nahradenia. Pravidlá môžu byť regulárne výrazy (súbory s príponou *.rex) či vzory (súbory s príponou *.dic). Súbory s príponou *.bxd združujú možnosti oboch predchádzajúcich formátov.

Ak zvolí používateľ možnosť 'čítať', Balabolka podľa použitých slovníkov zistí, ktoré slová v texte vyžadujú úpravu výslovnosti a použije príslušné pravidlá nahradení. Upravený text je nasledovne odoslaný hlasovej syntéze k jeho prečítaniu.

Pre zobrazenie zoznamu programom používaných slovníkov použite položku ponuky 'Vzhľad / Zobraziť / Panel slovníkov' či stlačte kláves F11. Vpravo v hlavnom okne sa zobrazí zoznam názvov súborov, rozdelený na dve časti:

  • Horná časť - súbory so zoznamami nahradení;
  • Dolná časť - súbory so zoznamami homografov.

Rôzne hlasy môžu používať rôzne zoznamy nahradení. Požadované súbory je možné vybrať z príslušného zoznamu.

Pre vytvorenie nového slovníku, kliknite pravým tlačidlom na panel slovníkov a v kontextovej ponuke zvoľte položku 'Nový'. Následne zadajte názov súboru nového slovníku. Súbor bude uložený a jeho názov sa objaví v zozname na paneli slovníkov.

Ak chcete upraviť zoznam nahradení, stačí v ňom vybrať príslušný súbor a zvoliť tlačidlo 'Upraviť'. Bude otvorené okno úprav zoznamu nahradení. Pre pridanie nového pravidla nahradenia zadajte príslušné údaje do polí 'čítať toto:' 'ako toto:' a stlačte tlačidlo 'Pridať'. Po pridaní pravidiel dokončite tento proces použitím tlačidla 'Uložiť' a zatvorte okno úprav.

Všeobecný zoznam pravidiel

Ak je v zozname vybraných viac súborov, pravidlá z týchto slovníkov budú programom automaticky združené do zoznamu umiestnenom v operačnej pamäti počítača. Pre zobrazenie tohto zoznamu kliknite pravým tlačidlom na panel slovníkov a v kontextovej ponuke zvoľte položku 'Zobraziť zoznam'.

Združovanie viacerých slovníkov do spoločného zoznamu prebieha nasledovne:

  • Pravidlá zo súborov s príponou *.bxd sú pridané jedno po druhom, podľa ich umiestnenia v súbore. Súbory sú spracovávané podľa abecedy.
  • To isté platí pre spracovanie súborov s príponou *.rex.
  • Všetky pravidlá zo súborov s príponou *.dic sú pridávané podľa prvého výskytu. Najprv pravidlá rozlišujúce veľkosť písma, následne pravidlá, ktoré veľkosť písma nerozlišujú. Potom sú pravidlá znovu zoradené podľa dĺžky vzoru, dlhšie ako prvé.

Poradie pravidiel v zozname je dôležité v prípadoch, kedy môže byť použitých viac pravidiel na rovnaké slovo v texte. Balabolka používa sekvenčné nahradzovanie. Znamená to, že druhé pravidlo v zozname bude použité na text už upravený prvým pravidlom. Poradie pravidiel je preto veľmi dôležité.

Pravidlá zo súborov s príponou *.rex budú použité prednostne. Pre kontrolu výsledku aplikácie pravidiel na aktuálny dokument, použite položky hlavnej ponuky 'Možnosti / úprava výslovnosti / Zobraziť upravený text' a 'Možnosti / úprava výslovnosti / Štatistika nahradení'.

Ďalšie nástroje

Pre nájdenie dvojíc pravidiel aplikovaných na rovnaký text, zvoľte položku ponuky 'Možnosti / úprava výslovnosti / Nájsť dvojice pravidiel'. Sú zobrazené pravidlá, ktoré neboli použité (Pre úpravu príslušného textu už bolo použité iné pravidlo).

Tieto úpravy sú potrebné najčastejšie pre úpravu výslovnosti mien osôb, miest či zvierat, prezývok, názvov organizácií, a pod. Vyhľadanie týchto slov môže byť zaistené použitím položky hlavnej ponuky 'Možnosti / úprava výslovnosti / Nájsť mená v texte'. Balabolka následne zobrazí tri zoznamy s nájdenými slovami:

  • mená (slová, vždy začínajúce veľkým písmenom),
  • všetky slová začínajúce veľkým písmenom,
  • všetky slová, nájdené v aktuálnom dokumente.

Slová sú pri pohybe v zozname automaticky čítané. Ak je niektoré slovo prečítané nesprávne, môžete vytvoriť príslušnú úpravu výslovnosti pridaním nového pravidla do slovníku. Zoznam nájdených mien môže byť zoradený podľa abecedy alebo podľa množstva výskytov v texte. Navyše je možné zakázať zobrazovanie slov, ktoré sa objavujú v menšej miere, dôjde tým k zrýchleniu kontroly príslušného zoznamu nájdených slov.

Profily

Aktuálny stav nastavení panelu je možné uložiť ako profil. K vytváraniu a úprave profilov použite položku hlavnej ponuky 'možnosti / úprava výslovnosti / Profily'.


Súbory REX pre úpravu výslovnosti

Pre každý riadok súboru platia nasledujúce pravidlá:

Druhá skupina znakov je fonetickým nahradením výslovnosti prvej skupiny znakov.

Skupiny znakov sú oddelené znakom 'Rovno' (=).

Berte na vedomie, že nahradzovanie textu prebieha v poradí definovanom v súbore.

Príklad:

auto=voz
voz=kočiar

Auto sa stane kočiarom, čo nemusí byť žiaduce.

Riadky s komentármi začínajú znakom 'krížik' (#) a sú programom ignorované.

Prvá skupina znakov môže obsahovať regulárny výraz.

Vzory s regulárnymi výrazmi nerozlišujú veľkosť písma. Ak chcete definovať vzor rozlišujúci veľkosť písma, musíte na začiatok riadku pridať symbol 'Dolar' ($).>p> Príklad:

#Ms=Majstrovstvá sveta

Nasledujú znaky a skupiny znakov, ktoré je možné v tomto type súborov použiť.

/TABLE>

Balabolka podporuje špeciálne operátory pre prevod textu na malé či veľké písmená.

Znak | Popis
\ | Definuje nasledujúci znak ako riadiaci, prípadne dáva riadiacemu znaku jeho pôvodnú podobu. Napr. "n" zodpovedá znaku "n". "\n" zodpovedá znaku pre nový riadok. Skupina "\\" zodpovedá "\", "\(" zodpovedá "(" a "\=" zodpovedá "=".
^ | Zodpovedá začiatku vstupu.
$ | Zodpovedá koncu vstupu.
* | Zodpovedá predchádzajúcemu znaku 0 a viackrát. Napr. "zo*" zodpovedá "z" i "zoo".
+ | Zodpovedá predchádzajúcemu znaku raz a viackrát. Napr. "zo+" zodpovedá "zoo" ale nie "z".
? | Zodpovedá predchádzajúcemu znaku nula a jedenkrát. Napr. "o?soba?" zodpovedá "sob" v slove "osoba".
. | Zodpovedá ktorémukoľvek jednotlivému znaku s výnimkou znaku pre nový riadok.
(vzor) | Zodpovedá vzoru a pamätá si jeho výskyt. Nájdený podreťazec je možné získať použitím riadiaceho znaku $N, kde N je Ntý vzor uvedený v zátvorkách. Pre získanie znakov samotných zátvoriek ( ), použite "\(" či "\)".
x|y | Zodpovedá x alebo y. Napr., "k|slon" zodpovedá "k" alebo "slon". "(s|k)lon" zodpovedá "slon" alebo "klon".
{n} | n je celé kladné číslo. Zodpovedá presnému počtu n. Napr. "d{2}" nezodpovedá znaku "d" v slove "voda", ale zodpovedá dvom znakom "d" v slove "oddiel".
{n,} | n je celé kladné číslo. Zodpovedá výskytu najmenej n krát. Napr. "d{2,}" nezodpovedá znaku "d" v slove "voda", ale zodpovedá všetkým znakom d v slove "odddddiel". "o{1,}" je to isté ako "o+". "o{0,}" je to isté ako "o*".
{n,m} | m a n sú celé kladné čísla. Zodpovedá najmenej n a maximálne m výskytov. Napr. "d{1,3}" zodpovedá prvým trom znakom "d" v slove "odddddiel". "o{0,1}" je to isté ako "o?".
[xyz] | Skupina znakov. Zodpovedá ktorémukoľvek z uvedených znakov. Napr. "[abc]" zodpovedá znaku "a" v slove "ako".
[^xyz] | Negatívna skupina znakov. Zodpovedá všetkým znakom, ktoré nie sú obsiahnuté. Napr. "[^abc]" zodpovedá znaku "p" v slove "plyn".
[a-z] | Rozsah znakov. Zodpovedá ktorémukoľvek znaku v uvedenom rozsahu. Napr. "[a-z]" zodpovedá ktorémukoľvek malému písmenu abecedy (a - z).
[^m-z] | Negatívny rozsah znakov. Zodpovedá všetkým znakom mimo uvedený rozsah. Napr. "[m-z]" zodpovedá ktorémukoľvek znaku mimo rozsah m - z.
\b | Zodpovedá hranici slova, čo je pozícia medzi slovom a medzerou. Napr. "las\b" zodpovedá "las" v slove "hlas", ale nezodpovedá "las" v slove "lasička".
\B | Zodpovedá opačnej hranici slova. "ply\B" zodpovedá "ply" vo výraze "plný plyn".
\d | Zodpovedá znaku číslice, rovnaké ako [0-9].
\D | Zodpovedá ktorémukoľvek znaku, ktorý nie je číslicou, to isté ako [^0-9].
\f | Zodpovedá znaku konca strany.
\n | Zodpovedá znaku nový riadok.
\r | Zodpovedá znaku návrat na začiatok riadka.
\s | Zodpovedá všetkým oddeľovačom (medzera, tabulátor, koniec strany a pod.), to isté ako "[ \f\n\r\t\v]".
\S | Zodpovedá všetkým znakom, ktorým nie je oddeľovač, to isté ako "[^ \f\n\r\t\v]".
\t | Zodpovedá znaku tabulátor.
\v | Zodpovedá znaku zvislý tabulátor.
\w | Zodpovedá všetkým písaným znakom, vrátane podčiarknutia (_), to isté ako "[A-Za-z0-9_]".
\W | Zodpovedá všetkým okrem písaných znakov, to isté ako "[^A-Za-z0-9_]".
\num | Zodpovedá num, kde num je kladné celé číslo. Odkazuje späť na zapamätané výskyty. Napr. "(.)\1" zodpovedá dvom nasledujúcim rovnakým znakom.
\n | Zodpovedá n, kde n je osmičková riadiaca sekvencia. Osmičkové riadiace sekvencie musia mať dĺžku 1, 2 alebo 3 číslice. Napr. "\11" a "\011" obe zodpovedajú znaku tabulátor. "\0011" je to isté ako "\001" & "1". Osmičkové riadiace sekvencie nesmú presiahnuť hodnotu 256. Pokiaľ sa tak stane, zodpovedajú výrazu len prvé dve číslice. Hodia sa pre použitie Aski kódov v regulárnych výrazoch.
\xn | Zodpovedá n, kde n je šestnástková riadiaca sekvencia. Šestnástkové riadiace sekvencie musia mať dĺžku presne dve číslice. Napr. "\x41" zodpovedá "A". Hodí sa pre použitie Aski kódov v regulárnych výrazoch.
\x{n} | Zodpovedá n, kde n je šestnástková riadiaca sekvencia. Šestnástkové riadiace sekvencie musia mať dĺžku presne dve číslice. Napr., "\x{00dc}" zodpovedá "Ü". Hodí sa pre použitie kódov Unicode v regulárnych výrazoch.
Operátor | Popis
\U | Skonvertuje všetky nasledujúce znaky až do ďalšieho \L či \E na veľké písmená.
\L | Skonvertuje všetky nasledujúce znaky až do ďalšieho \U či \E na malé písmená.
\E | Vypne prevod veľkosti písma.
\u | Skonvertuje nasledujúci znak na veľké písmeno.
\l | Skonvertuje nasledujúci znak na malé písmeno.

Príklad:

(test)=\U$1\E

skonvertuje "test" na "TEST".


Súbory Dic pre úpravu výslovnosti

Pre každý riadok súboru platia nasledujúce pravidlá:

Druhá skupina znakov je fonetickým nahradením výslovnosti prvej skupiny znakov.

Skupiny znakov sú oddelené znakom 'Rovno' (=).

Riadky s komentármi začínajú znakom 'krížik' (#) a sú programom ignorované.

Vzory nie sú citlivé na veľkosť písma. Ak chcete definovať vzor, citlivý na veľkosť písma, musíte na začiatok riadku pridať symbol 'Dolar' ($).>p> Príklad:

#Ms=Majstrovstvá sveta

V predvolenom stave vzor zodpovedá slovu či viacerým slovám. Pre určenie vzťahu i k ďalším znakom okolo vzoru použite znak hviezdička (*).

Príklad:

fys*=fyz

Tento vzor zodpovedá vyriešeniu skôr písaných pojmov "Fysika", "fysický" atp. Dva po sebe nasledujúce špeciálne symboly ("#", "*", "=", "$") vyjadrujú príslušný znak v jeho pôvodnej podobe.

Príklad:

**=hviezdička


Homografy

Niektorá slová, nazývané homografy predstavujú jeden z najväčších problémov pre systémy TTS. Homografy sú zapísané rovnako, avšak líšia sa vo význame a obvykle i vo výslovnosti. Príkladom môže byť slovo city. V slovenskom kontexte je vyslovované ako city, avšak v anglickom ako sity. V slovenčine sa čisté homografy vyskytujú tam, kde je jedno zo slov cudzieho pôvodu a zachovalo si aspoň čiastočne neobvyklú výslovnosť. Príkladom môže byť slovo panický (vychádza zo slov panic i panika).

U týchto typov slov je k dosiahnutiu správnej výslovnosti treba ďalších sémantických informácií.

Výslovnosť toho istého slova napr. v angličtine môže byť odlišná aj z dôvodu rôzneho kontextu.

Anglické heteronymá sú špeciálnym druhom homografov. Ide o slová, ktoré sú rovnako zapísané, avšak líšia sa vo význame i vo výslovnosti, napr."row" (veslovať) and "row" (hádka). Všetky anglické heteronymá sú zároveň homografmi, avšak nie všetky homografy sú heteronymami. Mnoho heteroným spolu súvisí svojim významom, zatiaľ čo iné sú kompletne odlišné.

Hľadanie správnej výslovnosti vlastných mien, predovšetkým ak sú prevzaté z ďalších jazykov je jednou z najťažších úloh pre systémy TTS. Niektoré mená, napr. Jamy či Nice sú mnohoznačné i vzhľadom ku kontextu závislom na veľkosti písma, vrátane pozície na začiatku vety, mien ako takých či samostatných slov. Napr. veta Jamy vysypal do jamy všetky džemy. je veľmi problematická, pretože slovo jamy môže byť vyslovené ako /džejmí/ alebo /jamy/. Niektoré mená a miesta majú aj špeciálnu výslovnosť, napr. Leicester či Arkansas. Za účelom úpravy výslovnosti týchto druhov slov, môžu príslušné slová byť zahrnuté do špecifických slovníkov výnimiek (súbory s príponou *.hmg, napr. English.hmg).

Pre každý riadok súboru platia nasledujúce pravidlá:

Druhá skupina znakov je fonetickým nahradením výslovnosti prvej skupiny znakov.

Skupiny znakov sú oddelené znakom 'Rovno' (=).

Výslovnosti sú oddelené čiarkami.

Príklad:

Jamy=jamy,džejmí

Vzory nie sú citlivé na veľkosť písma. Ak chcete definovať vzor, citlivý na veľkosť písma, musíte na začiatok riadku pridať symbol 'Dolar' ($).>p> Príklad:

$Jamy=džejmí,Jamy

Balabolka podporuje zoznamy výrazov pre každý homograf (karta "Výrazy s homografmi" v editore homografov). Tieto výrazy budú automaticky nahradené behom vyhľadávania homografov (položka hlavnej ponuky 'Text / Nájsť homografy').

Príklad:

city=city,sity

žiadne city=city
Manchester City=sity

Ak rozlišuje výraz veľkosť písma, musíte na začiatok textu pridať symbol Dolar ($):

$Nice=Niis,Nais

$mesto Nice=Niis
nice to have=najs

Znak Hviezdička "*" môže byť použitý namiesto ktoréhokoľvek slova či jedného a viac znakov :

city=city,sity

nechcem * hrať na city=city


Ovládacie značky (SAPI 4)

Táto kapitola popisuje ovládacie značky hlasovej syntézy, ktoré môžu byť vložené do textu za účelom zlepšenia výslovnosti čítaného textu.

  • Zápis
  • Konvencie
  • Chr
  • Com
  • Ctx (Túto značku niektoré syntézy nemusia podporovať)
  • Dem (Nové v SAPI 4.0 – Túto značku niektoré syntézy nemusia podporovať)
  • Emp (Túto značku niektoré syntézy nemusia podporovať)
  • Eng
  • Mrk
  • Pau
  • Pit
  • Pra (Nové v SAPI 4.0 – Túto značku niektoré syntézy nemusia podporovať)
  • Prn (Túto značku niektoré syntézy nemusia podporovať)
  • Pro (Túto značku niektoré syntézy nemusia podporovať)
  • Prt (Túto značku niektoré syntézy nemusia podporovať)
  • RmS (Nové v SAPI 4.0 – Túto značku niektoré syntézy nemusia podporovať)
  • RmW (Nové v SAPI 4.0 – Túto značku niektoré syntézy nemusia podporovať)
  • RPit (Nové v SAPI 4.0 – Túto značku niektoré syntézy nemusia podporovať)
  • RPrn (Nové v SAPI 4.0 – Túto značku niektoré syntézy nemusia podporovať)
  • RSpd (Nové v SAPI 4.0 – Túto značku niektoré syntézy nemusia podporovať)
  • Rst (Nové v SAPI 4.0)
  • Spd
  • Vce (Túto značku niektoré syntézy nemusia podporovať)
  • Vol

Hlasová syntéza obvykle úspešne prevádza na hovorenú reč samostatné slová. Avšak ako náhle syntéza vyslovuje konkrétnu vetu, kvalita prevodu klesá, pretože syntéza často nemôže presne napodobniť rytmus, moduláciu, prízvuk či presné načasovanie ľudskej reči.

Prejav výsledného hlasu môže byť vylepšený použitím ovládacích značiek hlasovej syntézy za účelom lepšieho napodobnenia skutočného znenia ľudského hlasu.

Táto kapitola popisuje ovládacie značky, ktoré môžu byť použité pre zmenu parametrov prevodu textu na reč. Všetky značky sú voliteľné s výnimkou záložky (značka Mrk), ktorá musí byť podporovaná.

Zápis

Ovládacie značky hlasovej syntézy sa riadia týmito všeobecnými pravidlami zápisu:

  • Všetky značky začínajú a končia znakom opačná lomka (\).
  • Znak opačná lomka (\) nie je možné použiť vo vnútri značky.
  • Nepárny počet opačných lomiek (\) v označenom texte vedie k nedefinovanému chovaniu rozhrania.
  • Značky nerozlišujú veľkosť písma. Napr. \vce\ je to isté ako \VCE\.
  • Značky rozlišujú medzery. Napr. \Rst\ nie je to isté ako \ Rst \.

Pre vloženie znaku opačnej lomky (\) do označeného textu, avšak mimo samotnú značku použite dva znaky opačnej lomky (\\).

Ak chce program prečítať, napr. názov súboru "c:\windows\system\test.txt", mali by znaky opačných lomiek (\) byť zdvojené takto: "c:\\windows\\system\\test.txt".

Príklady:

  • code\ ctx="e-mail" \ – bude spracované ako značka "e-mail".
  • \ctx="e-mail" – bude ignorované, pretože ide o neuzatvorenú značku na konci dokumentu.
  • \\ctx="e-mail"\\ – vysloví "Backslash c t x equals e-mail back-slash"
  • \\\\\\\\ctx="e-mail"\\\\\\\\ – vysloví "backslash backslash backslash backslash c t x equals e-mail backslash backslash backslash backslash"
  • \ctm="e-mail"\ – bude ignorované, pretože ide o neznámu značku.

Ak narazí hlasová syntéza na neznámu značku, bude táto značka ignorovaná.

Konvencie

V tejto sekcii sa používajú nasledujúce typografické konvencie.

Príklad | Popis
Chr | Použitie tučného písma indikuje kľúčové slová zmeny tónu reči.
string | Použitie kurzívy indikuje zástupné symboly pre informáciu, ktorú poskytujete vy, napr. reťazec znakov alebo kontextový reťazec.
[[option]] | Dvojité hranaté zátvorky indikujú voliteľné položky.
[[option...]] | Tri bodky (značka tri bodky) nasledujúce za položkou indikujú, že môžu nasledovať ďalšie položky rovnakého typu.
"C" | Úvodzovky sa používajú pre uzatvorenie reťazcov.

Chr

\Chr=string[[,string...]]\

Nastaví charakter hlasu.

Príklad: \Chr="Angry"\

Parameter | Popis
string | Reťazec, ktorý špecifikuje charakter hlasu.

Ako predvolený charakter hlasu je nastavená hodnota "Normálny" a hlas bude znieť normálnym tónom. Aj keď značka Chr neumožňuje tak špecifické nastavenie, ako v prípade, kedy zmeny tónu, prízvuk, nástup hlasivkového tónu alebo kvalita šepotu sú nastavované samostatne, je použitie tohto nastavenia jednoduchšie a hlasová syntéza s ním poskytuje flexibilnejšiu a inteligentnejšiu odpoveď.

V rámci jednej značky je možné špecifikovať niekoľko charakterov hlasu oddelených čiarkami. V závislosti na svojich schopnostiach nemusí hlasová syntéza podporovať všetky charaktery hlasu, ktoré sú tu uvedené, alebo môže naopak podporovať i tu neuvedené charaktery hlasu. Medzi bežné charaktery hlasu patrí nasledujúci:

"Angry" "Business" "Calm" "Depressed" "Excited" "Falsetto" "Happy" "Loud" "Monotone" "Perky" "Quiet" "Sarcastic" "Scared" "Shout" "Tense" "Whisper"

Com

\Com=string\

Vloží do textu komentár. Komentáre nie sú prevádzané na reč.

Príklad: \com="Toto je komentár."\

Parameter | Popis
string | Text komentára.

Ctx

\Ctx=string\
Poznámka: Niektoré hlasové syntézy nemusia túto značku podporovať.

Nastaví kontext pre text, ktorý nasleduje a ten určí, ako majú byť symboly vyslovené.

Príklad: \ctx="Unknown"\

Parameter | Popis
string | Reťazec, ktorý určuje kontext.

Týmto parametrom môže byť jeden z nasledujúcich reťazcov:

Kontextový reťazec | Popis
"Address" | Adresy alebo telefónne čísla
"C" | Kód v programovacom jazyku C alebo C++
"Document" | Textový dokument
"E-Mail" | E-mail
"Numbers" | Čísla, dátumy, časy atď.
"Spreadsheet" | Tabuľkový dokument
"Unknown" | Kontext je neznámy (predvolený)
"Normal" | Normálny/predvolený režim reči.

Dem

\Dem\
Poznámka: Niektoré hlasové syntézy nemusia túto značku podporovať.

Ďalšie slovo vysloví bez dôrazu.

Emp

\Emp\
Poznámka: Niektoré hlasové syntézy nemusia túto značku podporovať.

Ďalšie slovo vysloví s dôrazom.

Príklad: the \Emp\truth, the \Emp\whole truth, and nothing \Emp\but the truth.

Eng

\Eng;GUID:command\
\Eng:command\

Vloží príkaz špecifický pre konkrétnu hlasovú syntézu, ktorý ovplyvní len hlasovú syntézu s konkrétnym globálne jedinečným identifikátorom (GUID). U ďalších následných značiek určených pre danú hlasovú syntézu je možné GUID vynechať. Je treba ho uviesť až pre značku, ktorá je určená pre inú hlasovú syntézu.

Parameter | Popis
GUID | Globálne jedinečný identifikátor hlasovej syntézy
command | Príkaz určený špeciálne pre zadanú hlasovú syntézu.

Mrk

\Mrk=number\

Indikuje záložku v texte.

Príklad: \Mrk=75000\

Parameter | Popis
number | Číslo záložky.

Značka Mrk akceptuje desiatkovú sústavu. Záložka s číslom nula (\Mrk=0\) je vyhradená.

Pau

\Pau=number\

Pozastaví hlasový výstup počas zadanej doby v milisekundách.

Príklad: \Pau=1000\

Parameter | Popis
number | Počet milisekúnd, počas ktorých sa má hlasový výstup pozastaviť.

Pit

\Pit=number\

Nastaví základnú hodnotu výšky hlasu režimu prevodu textu na reč na hodnotu zadanú v hertzoch (Hz).

Príklad: \Pit=90\

Parameter | Popis
number | Výška hlasu v hertzoch.

Skutočná výška hlasu sa pohybuje nad a pod touto základnou hodnotou.

Pra

\Pra=value\
Poznámka: Niektoré hlasové syntézy nemusia túto značku podporovať.

Nastaví rozsah výšky hlasu.

Parameter | Popis
value | Rozsah výšky hlasu v hertzoch.

Prn

\Prn=text=pronunciation\
Poznámka: Niektoré hlasové syntézy nemusia túto značku podporovať.

Poskytuje hlasovej syntéze fonetický ekvivalent určitého textu.

Příklad: \Prn=tomato=tomaato\

Parameter | Popis
text | Text, ktorý sa má vysloviť.
pronunciation | Fonetický ekvivalent pre vyslovenie určitého textu.

Ak použijete značku Prn bez zadania výslovnosti slova (\Prn=text\), vrátia sa zmeny výslovnosti späť; to znamená, že slovo bude vyslovené s pôvodnou výslovnosťou.

Táto značka je platná len pre hlasové syntézy, ktoré podporujú medzinárodnú fonetickú abecedu. Hlasová syntéza by mala novú výslovnosť ďalej používať v aktuálnom režime prevodu textu na reč a mala by ju uložiť do svojho slovníku pre neskoršie použitie. Pokiaľ už položka v slovníku pre dané slovo existuje, značka Prn bude pre dané slovo ignorovaná.

Pro

\Pro=number\
Poznámka: Niektoré hlasové syntézy nemusia túto značku podporovať.

Aktivuje a deaktivuje prozodické pravidlá, ktoré ovplyvňujú výšku hlasu, rýchlosť reči a hlasitosť nezávisle na ovládacích značkách vložených v texte. Prozodické pravidlá sú aplikované hlasovou syntézou.

Príklad: \Pro=0\

Parameter | Popis
number | Číslo, ktoré označuje, či sa majú prozodické pravidlá aktivovať alebo deaktivovať. Nastavenie čísla 1 (predvolené nastavenie) prozodické pravidlá aktivuje. Nastavenie čísla 0 prozodické pravidlá deaktivuje.

Prt

\Prt=string\
Poznámka: Niektoré hlasové syntézy nemusia túto značku podporovať.

Určuje slovný druh nasledujúceho slova.

Príklad: \prt= "Abbr" \

Parameter | Popis
string | Reťazec, ktorý označuje slovný druh.

Týmto parametrom môže byť jeden z nasledujúcich reťazcov:

String | Popis
"Abbr" | Skratka
"Adj" | Prídavné meno
"Adv" | Príslovka
"Card" | Základná číslovka
"Conj" | Spojka
"Cont" | Skrátený tvar
"Det" | Determinant
"Interj" | Citoslovce
"N" | Podstatné meno
"Ord" | Radová číslovka
"Prep" | Predložka
"Pron" | Zámeno
"Prop" | Vlastné meno
"Punct" | Znamienko
"Quant" | Kvantifikátor
"V" | Sloveso

RmS

\RmS=number\
Poznámka: Niektoré hlasové syntézy nemusia túto značku podporovať.

Nastaví režim čítania na hláskovanie každého písmena každého slova alebo ho vypne. Túto značku nepodporujú všetky hlasové syntézy. Konzistentnejšie výsledky je možné teda získať skôr štandardizáciou vlastného textu a uvedením medzier medzi písmenami.

Parameter | Popis
number | Číslo, ktoré udáva, či sa má hláskovať každé písmeno každého slova. Číslo 1 nastaví režim čítania na hláskovanie každého písmena každého slova. Číslo 0 (predvolené nastavenie) režim hláskovania každého písmena každého slova deaktivuje.

RmW

\RmW=number\
Poznámka: Niektoré hlasové syntézy nemusia túto značku podporovať.

Nastaví počuteľnú pauzu medzi jednotlivé slová alebo túto funkciu vypne. Túto značku nepodporujú všetky hlasové syntézy. Konzistentnejšie výsledky je možné teda získať skôr štandardizáciou vlastného textu a vložením medzier medzi slová.

Parameter | Popis
number | Číslo, ktoré udáva, či sa má medzi jednotlivé slová vložiť počuteľná pauza. Číslo 1 nastaví režim čítania na vloženie počuteľnej pauzy medzi jednotlivé slová. Číslo 0 (predvolené nastavenie) režim vloženia počuteľnej pauzy medzi jednotlivé slová deaktivuje.

RPit

\RPit=value\
Poznámka: Niektoré hlasové syntézy nemusia túto značku podporovať.

Nastaví relatívnu výšku hlasu.

Parameter | Popis
value | Relatívna výška hlasu. Predvolené/pôvodné nastavenie pre hlas je 100.

RPrn

\RPrn=value\
Poznámka: Niektoré hlasové syntézy nemusia túto značku podporovať.

Nastaví rozsah relatívnej výšky hlasu.

Parameter | Popis
value | Rozsah relatívnej výšky hlasu. Predvolené/pôvodné nastavenie pre hlas je 100.

RSpd

\RSpd=value\
Poznámka: Niektoré hlasové syntézy nemusia túto značku podporovať.

Nastaví relatívnu rýchlosť reči. Predvolené/pôvodné nastavenie pre hlas je 100.

Parameter | Popis
value | Relatívna rýchlosť reči. Predvolené/pôvodné nastavenie pre hlas je 100.

Rst

\Rst\

Obnoví predvolené nastavenie hlasovej syntézy pre aktuálny režim zhodné s tým, aké mal pri svojom vytvorení.

Spd

\Spd=number\

Nastaví základnú hodnotu priemernej rýchlosti reči režimu prevodu textu na reč na hodnotu zadanú ako počet slov za minútu.

Príklad: \Spd=120\

Parameter | Popis
number | Základná hodnota priemernej rýchlosti reči uvedená ako počet slov za minútu.

Vce

\Vce=charact=value[[,charact=value]]\
Poznámka: Niektoré hlasové syntézy nemusia túto značku podporovať.

Hlasová syntéza dostane pokyn, že má zmeniť hlas reči na taký hlas, ktorý splňuje zadané charakteristiky.

Parameter | Popis
charact | Jedna z charakteristík uvedených v tabuľke nižšie.
value | Reťazec, ktorý špecifikuje charakteristiku.

Poradie charakteristík určuje ich dôležitosť. Hlasová syntéza vyberie taký hlas, ktorý najviac zodpovedá charakteristikám uvedeným na začiatku zoznamu.

Argument charact=value môže byť akýkoľvek z nasledujúcich:

  • Language=language. Požaduje, aby hlasová syntéza hovorila v zadanom jazyku.
  • Accent=accent. Požaduje, aby hlasová syntéza hovorila so zadaným prízvukom. Pokiaľ je napríklad zadaný jazyk = "English" a prízvuk = "French", hlasová syntéza bude hovoriť anglicky s francúzskym prízvukom.
  • Dialect=dialect. Požaduje, aby hlasová syntéza hovorila v zadanom dialekte.
  • Gender=gender. Nastaví, či má hlasová syntéza hovoriť mužským, ženským alebo neutrálnym hlasom. "Male", "Female" alebo "Neutral".
  • Speaker=speakername. Nastaví meno hlasu alebo nastaví hodnotu NULL, pokiaľ meno hlasu nie je dôležité.
  • Age=age. Určuje vek hlasu z nižšie uvedeného zoznamu.
  • Style=style. Osobnosť hlasu – napríklad: "Business", "Casual", "Computer", "Excited" alebo "Singsong".
Reťazec veku | Popis
"Baby" | Vek asi 1 rok
"Toddler" | Vek asi 3 roky
"Child" | Vek asi 6 rokov
"Adolescent" | Vek asi 14 rokov
"Adult" | Vek medzi 20 až 60 rokov
"Elderly" | Vek asi 60 rokov

Vol

\Vol=number\

Nastaví základnú hodnotu hlasitosti reči pre režim prevodu textu na reč.

Príklad: \Vol=32768\

Parameter | Popis
number | Základná hodnota hlasitosti.

Úroveň hlasitosti predstavuje lineárny rozsah od 0 (absolútne ticho) po 65535 (maximálna hlasitosť monofónneho zvuku). Ako predvolená je nastavená hodnota 65535.

Ak zadáte hodnotu vyššiu než 65535, hlasová syntéza bude predpokladať, že chcete nastaviť ľavý a pravý kanál samostatne a prevedie hodnotu na dve hodnoty – nižšiu hodnotu použije pre ľavý kanál a vyššiu hodnotu pre pravý kanál. Ak zadáte napríklad hodnotu 65536, nastaví sa pre ľavý kanál maximálna základná hlasitosť a pravý kanál bude nastavený na minimum.


Značky XML (SAPI 5)

SAPI 5 synthesis markup je kolekcia rozširujúcich značiek XML, ktoré je možné vložiť do textu, za účelom úpravy jeho syntézy. Tieto značky, ktoré prinášajú funkcie ako napr. ovládanie hlasitosti či zmenu prízvuku sú automaticky detekované XML parserom rozhrania Sapi. V prípade chybnej štruktúry XML môže program zobraziť chybovú správu.

Každý prvok XML pozostáva z úvodnej značky <Značka> a koncovej značky </Značka> a obsahu medzi týmito značkami. Značky xml nerozlišujú veľkosť písma.

Všetky prvky XML musia byť správne vnorené.

Nesprávne vnorenie:

<značka1><značka2> text </značka1></značka2>

Správne vnorenie:

<značka1><značka2> text </značka2></značka1>

Prvok XML musí byť vždy otvorený i uzatvorený rovnakou značkou XML.

Pre vloženie značiek XML do textu použite položku hlavnej ponuky 'Text / Vložiť značku XML'. Počiatočná a koncová značka XML bude vložená pred a za vybraný text.

Značky XML SAPI text-to-speech (TTS) sa delia do niekoľkých kategórií.

  • Ovládanie stavu hlasu
  • Priame vloženie položky
  • Ovládanie kontextu hlasu
  • Výber hlasu
  • Vlastná výslovnosť

Ovládanie stavu hlasu

SAPI TTS XML podporuje päť značiek, ktoré ovládajú stav aktuálneho hlasu (volume, rate, pitch, emph a spell).

Volume

Značka Volume ovláda hlasitosť hlasu. Môže byť prázdna, v tom prípade ovplyvní všetok nasledujúci text, alebo ak má obsah, vzťahuje sa len naň.

Značka Volume má jeden požadovaný atribút (Level). Jeho hodnota môže byť v rozsahu 0 - 100. Hodnoty mimo tento rozsah budú príslušne orezané.

<volume level="50"> Tento text bude vyslovený hlasitosťou 50. <volume level="100"> Tento text bude vyslovený hlasitosťou 100. </volume> </volume>
<volume level="80"/> Všetok nasledujúci text bude vyslovený hlasitosťou 80.

Hodnota 100 reprezentuje predvolenú hlasitosť hlasu. Nižšie hodnoty určujú percentá tejto predvolenej hodnoty. Hlasitosť 50 teda zodpovedá päťdesiatim percentám celkovej hlasitosti.

Rate

Značka Rate určuje rýchlosť hlasu. Môže byť prázdna, v tom prípade ovplyvní všetok nasledujúci text, alebo ak má obsah, vzťahuje sa len naň.

Značka Rate má dva atribúty, Speed a AbsSpeed, musí byť prítomný minimálne jeden z nich. Hodnota oboch týchto atribútov musí byť v rozsahu -10 - 10. Hodnoty mimo tento rozsah budú príslušne orezané. Atribút AbsSpeed riadi absolútnu rýchlosť hlasu, takže hodnota 10 vždy zodpovedá hodnote 10, hodnota 5 hodnote 5.

<rate absspeed="5">Tento text bude prečítaný rýchlosťou 5. <rate absspeed="-5"> Tento text bude prečítaný rýchlosťou -5. </rate> </rate>
<rate absspeed="10"/> Všetok nasledujúci text bude prečítaný rýchlosťou 10.

Atribút Speed riadi relatívnu rýchlosť hlasu. Hodnota absolútnej rýchlosti je súčtom súčasnej rýchlosti a relatívnej hodnoty.

<rate speed="5"> Tento text bude prečítaný rýchlosťou 5. <rate speed="-5"> Tento text bude prečítaný rýchlosťou 0. </rate> </rate>

Hodnota 0 určuje predvolenú rýchlosť hlasu. Kladné hodnoty sú rýchlejšie a záporné pomalšie.

Pitch

Značka Pitch riadi výšku hlasu. Môže byť prázdna, v tom prípade ovplyvní všetok nasledujúci text, alebo ak má obsah, vzťahuje sa len naň.

Značka Pitch má dva atribúty, Middle a AbsMiddle, musí byť prítomný minimálne jeden z nich. Hodnota oboch týchto atribútov musí byť v rozsahu -10 - 10. Hodnoty mimo tento rozsah budú príslušne orezané.

Atribút AbsMiddle riadi absolútnu výšku hlasu, takže hodnota 10 vždy zodpovedá hodnote 10, hodnota 5 hodnote 5.

<pitch absmiddle="5"> Tento text bude prečítaný výškou 5. <pitch absmiddle="-5"> Tento text bude prečítaný výškou -5. </pitch> </pitch>
<pitch absmiddle="10"/> Všetok nasledujúci text bude prečítaný výškou 10.

Atribút Middle riadi relatívnu výšku hlasu. Hodnota absolútnej výšky je súčtom súčasnej výšky a relatívnej hodnoty.

<pitch middle="5">Tento text bude prečítaný výškou 5. <pitch middle="-5">Tento text bude prečítaný výškou 0.</pitch> </pitch>

Hodnota 0 určuje predvolenú výšku hlasu. Kladné hodnoty sú vyššie a záporné nižšie.

Emph

Značka Emph prikazuje hlasu zdôrazniť slovo či úsek textu. Táto značka nesmie byť prázdna. Nasledujúce slovo bude zdôraznené.

<emph> haló </emph>!

Spôsob zdôraznenia sa môže líšiť podľa použitej hlasovej syntézy.

Spell

Značka Spell prikazuje hlasu hláskovať daný text namiesto používania bežných pravidiel pre spracovanie slov a viet, pravidiel normalizácie textu a pod. Všetky znaky vrátane interpunkčných znamienok, čísiel a podobne by mali byť nahradené zodpovedajúcimi slovami. Značka nesmie byť prázdna.

<spell> Tieto slová budú vyhláskované. </spell>
Tieto slová vyhláskované nebudú.

Značky pre priame vloženie položky

Pre priame vkladanie položky sú podporované 3 značky: Silence, Pron, a Bookmark.

Silence

Značka Silence do výstupného zvukového prúdu vkladá v milisekundách definovanú pomlku. Značka musí byť prázdna a musí mať jeden atribút, Msec.

500 milisekúnd ticha<silence msec="500"/> práve prebehlo.

Pron

Značka Pron vkladá definovanú výslovnosť. Hlas spracuje sekvenciu foném presne tak ako sú určené. Značka môže byť prázdna, ale môže mať i obsah. Ak je obsah prítomný, bude interpretovaný s definovanou výslovnosťou.

Značka Pron má jeden atribút, Sym. Jeho hodnotou je reťazec medzerami oddelených foném.

<pron sym="h eh l l ow & w er l l d "/>
<pron sym="h eh l l ow & w er l l d"> hello world </pron>

Použitie Foném je popísané tu.

Bookmark

Značka Bookmark do výstupného zvukového prúdu vkladá udalosť záložky. Udalosť dáva aplikácii vedieť, že v texte bolo dosiahnuté umiestnenie, ktoré zodpovedá danej záložke. Značka musí byť prázdna.

Značka Bookmark má jeden atribút, Mark. Jeho hodnotou je reťazec. Táto hodnota môže byť následne použitá pre rozlíšenie udalostí záložiek. Každá z nich bude obsahovať hodnotu reťazca zodpovedajúcu príslušnej značke záložky.

Tu dôjde k výskytu udalosti

<bookmark mark="záložka 1"/>

a ďalší tu

<bookmark mark="záložka 2"/>

Značky pre ovládanie kontextu hlasu

Kontext hlasu určujú dve značky: PartOfSp a Context. Vďaka týmto značkám môže hlas určiť ako zachádzať so spracovávaným textom. Spôsob spracovania oboch týchto značiek sa môže líšiť v závislosti na použitom hlase.

PartOfSp

Značka PartOfSp určuje hlasu spôsob spracovania časti uvedeného textu, typicky jedného či viacerých slov. Výsledkom je možnosť vysloviť jedno slovo viacerými spôsobmi v závislosti na jeho kontexte. Značka PartOfSp nesmie byť prázdna.

Značka PartOfSp má jeden atribút, Part. Jeho hodnotou je reťazec, zodpovedajúci SAPI part of speech. Sú podporované len časti, definované v SAPI: "Unknown", "Noun", "Verb", "Modifier", "Function", "Interjection".

<partofsp part="noun"> A </partofsp> is the first letter of alphabet.

Did you <partofsp part="verb"> record </partofsp> that <partofsp part="noun"> record </partofsp>?

Context

Značka Context odovzdáva hlasu spôsob, ktorým môže interpretovať špeciálne položky ako dátumy, čísla, či hodnoty meny. Použitie tejto značky pomáha príslušnému hlasu rozlíšiť napr. rozličné interpretácie formátu dátumu. Značka Context nesmie byť prázdna.

Značka Context má jeden atribút, Id. Jeho hodnotou je reťazec definujúci kontext určeného textu. Niekoľko kontextov je definované v SAPI. Tieto všeobecne definované kontexty by mali byť platné pre všetky SAPI hlasy, ale jednako je možné použiť ktorýkoľvek reťazec. Viac informácií vám poskytne dokumentácia k príslušnému hlasu.

<context id="date_mdy"> 03/04/01 </context> bude prečítané ako March fourth, two thousand one.
<context id="date_dmy"> 03/04/01 </context> bude prečítané ako April third, two thousand one.
<context id="date_ymd"> 03/04/01 </context> bude prečítané ako April first, two thousand three.

Preddefinované typy kontextov sú popísané tu.

Značky pre výber hlasu

Pre výber hlasu sú definované dve značky: Voice a Lang.

Voice

Značka Voice vyberá hlas na základe jeho atribútov, Age, Gender, Language, Name, Vendor, a VendorPreferred. Môže byť prázdna, v tom prípade zmení hlas pre všetok nasledujúci text, alebo ak má obsah, vzťahuje sa zmena hlasu len naň.

Značka Voice má dva atribúty: Required a Optional. Atribúty aktuálneho hlasu sú vždy pridávané ako voliteľné. Znamená to, že hlas, ktorý viac zodpovedá aktuálnemu hlasu, bude mať pri výbere prednosť pred menej zodpovedajúcimi hlasmi.

Ak nie je nájdený hlas, ktorý zodpovedá všetkým vyžadovaným atribútom, k zmene hlasu nedôjde.

Táto veta bude prečítaná predvoleným hlasom. <voice required="Gender=Female;Age!=Child"> Túto vetu prečíta dospelá žena, ak je ako hlas prítomná. <voice required="Age=Teen"> Túto vetu prečíta hlas s atribútom Adolescent, no jednako ak je prítomný mužský i ženský hlas tohto typu, bude ženský hlas použitý prednostne. </voice> </voice>

Lang

Značka Lang vyberá hlas čisto na základe jeho atribútu Language. Môže byť prázdna, v tom prípade zmení hlas pre všetok nasledujúci text, alebo ak má obsah, vzťahuje sa zmena hlasu len naň.

Značka Lang má jeden atribút, LangId. Jeho hodnotou je Id jazyka (LANGID), napr. 409 (americká angličtina) alebo 411 (japončina). Berte na vedomie, že tieto čísla sú šestnástkové, no jednako bez typického prefixu "0x".

Značka Lang je skrátenou variantou značky Voice s vyžadovaným atribútom obsahujúcim "Language=xxx", takže nasledujúce príklady by mali mať rovnaký výsledok:

<voice required="Language=409"> Táto veta by mala byť prečítaná hlasom, podporujúcim americkú angličtinu. </voice>
<lang langid="409"> Táto veta by mala byť prečítaná hlasom, podporujúcim americkú angličtinu. </lang>

Vlastná výslovnosť

Vlastná výslovnosť je alternatívou k použitiu značky výslovnosti s atribútmi DISP a PRON. Použitie značiek vlastnej výslovnosti je nasledujúce:

<p disp="disp" pron="pron">word</p>

môže byť zapísané ako

<p>/disp/word/pron;</p>

Pre väčšie spresnenie: Ak chcete rozpoznať slovo hello len ak je vyslovené ako ah a zobraziť greeting ak je rozpoznané, bežne by ste použili niečo ako:

<p disp="greeting" pron="ah">hello</p>

To isté s použitím vlastnej výslovnosti bude vypadať nasledovne:

<p>/greeting/hello/ah;</p>


Definície kontextových značiek (SAPI 5)

Kontextová značka určuje normalizáciu bloku textu. Jej špecifikácia určuje preddefinované atribúty SAPI (ID) kontextovej značky. Tieto ID sú zapísané ako reťazce. SAPI nevykonáva kontrolu parametrov, predaných jeho rozhraniu, program môže určiť normalizačné ID, špecifické pre konkrétne rozhranie hlasovej syntézy. Reťazce špecifické pre rozhranie hlasovej syntézy začínajú menom rozhrania príslušného hlasu, za účelom vylúčenia zámen naprieč rozhraniami.

Príklad:

<context id="My_Context"> text </context>

Presná implementácia týchto hodnôt závisí na príslušnom rozhraní hlasovej syntézy, použitom v SAPI 5. Za účelom vynútenia danej normalizácie, môžu vývojári aplikácií zvoliť normalizáciu textu, použiť inú značku SAPI či ID, prislúchajúcu konkrétnemu rozhraniu. Každá kontextová značka môže obsahovať viac než jeden reťazec.

Príklad:

<context id="date_mdy"> 12/21/99 11/21/99 10/21/99 </context>

bude normalizované na "December twenty first nineteen ninety nine November twenty first nineteen ninety nine October twenty first nineteen ninety nine."

Podporované sú nasledujúce preddefinované typy kontextov:

  • Date
  • Time
  • Number
  • Web
  • E-mail
  • Address

Date

Tento kontext určuje, že číslo odovzdané rozhraniu je dátum. Všeobecný formát dátumu je číslo [oddeľovač] číslo [oddeľovač] číslo či číslo [oddeľovač] číslo, kde oddeľovačom môže byť '.', '/' či '-' a čísla sú typicky v rozsahu 01 - 12 pre mesiace a 01 - 31 pre dni. Rok je všeobecne dvoj- či štvorčíselný.

Nasledujú správne typy reťazcov pre údaje:

date_mdy

Dátum bude normalizovaný tak, že prvá skupina číslic je mesiac, druhá deň a tretia rok. V prípade, že rok je dvojčíselný, rozhranie ho bude chápať ako dvojčíselný a štvorčíselný ako štvorčíselný.

Príklad:

<context id="date_mdy">12/21/99</context>

bude normalizované na "December twenty first ninety nine"
či "December twenty first nineteen ninety nine"

<context id="date_mdy">12/21/1999</context>

bude normalizované na "December twenty first nineteen ninety nine"

date_dmy

Dátum bude normalizovaný tak, že prvá skupina číslic je deň, druhá mesiac a tretia rok. V prípade, že rok je dvojčíselný, rozhranie ho bude chápať ako dvojčíselný a štvorčíselný ako štvorčíselný.

Príklad:

<context id="date_dmy">21.12.99</context>

bude normalizované na "December twenty first ninety nine"
či "December twenty first nineteen ninety nine"

<context id="date_dmy">21-12-1999</context>

bude normalizované na "December twenty first nineteen ninety nine"

date_ymd

Dátum bude normalizovaný tak, že prvá skupina číslic je rok, druhá mesiac a tretia deň. V prípade, že rok je dvojčíselný, rozhranie ho bude chápať ako dvojčíselný a štvorčíselný ako štvorčíselný.

Príklad:

<context id="date_ymd">99-12-21</context>

bude normalizované na "December twenty first ninety nine"
či "December twenty first nineteen ninety nine"

<context id="date_ymd">1999.12.21</context>

bude normalizované na "December twenty first nineteen ninety nine"

date_ym

Dátum bude normalizovaný tak, že prvá skupina číslic je rok, a druhá mesiac. V prípade, že rok je dvojčíselný, rozhranie ho bude chápať ako dvojčíselný a štvorčíselný ako štvorčíselný.

Príklad:

<context id="date_ym">99-12</context>

bude normalizované na "December ninety nine"
či "December nineteen ninety nine"

<context id="date_ym">1999.12</context>

bude normalizované na "December nineteen ninety nine"

date_my

Dátum bude normalizovaný tak, že prvá skupina číslic je mesiac a druhá rok. V prípade, že rok je dvojčíselný, rozhranie ho bude chápať ako dvojčíselný a štvorčíselný ako štvorčíselný.

Príklad:

<context id="date_my">12/99</context>

bude normalizované na "December ninety nine"
či "December nineteen ninety nine"

<context id="date_my">12/1999</context>

bude normalizované na "December nineteen ninety nine"

date_dm

Dátum bude normalizovaný tak, že prvá skupina číslic je deň a druhá mesiac.

Príklad:

<context id="date_dm">21.12</context>

bude normalizované na "December twenty first"

date_md

Dátum bude normalizovaný tak, že prvá skupina číslic je mesiac a druhá deň.

Príklad:

<context id="date_md">12/21</context>

bude normalizované na "December twenty first"

date_year

Dátum bude normalizovaný tak, že zadané číslo je rok.

Príklad:

<context id="date_year">1999</context>

bude normalizované na "nineteen ninety nine"

<context id="date_year">2001</context>

bude normalizované na "Two thousand one"

chs_date_ymdhm

Text určujúci dátum je normalizovaný tak, že prvá skupina číslic je rok, druhá mesiac, tretia deň, štvrtá hodina a piata minúta. V prípade, že rok je dvojčíselný, rozhranie ho bude chápať ako dvojčíselný a štvorčíselný ako štvorčíselný. Formát času musí určovať hodinu ako číslo v rozsahu 00 - 23 a minúty ako číslo v rozsahu 01 - 59.

Táto kontextová značka je špecifická pre čínštinu.

Time

Tento kontext určuje, že číslo odovzdané rozhraniu je čas. Všeobecný formát času je číslo [oddeľovač] číslo [oddeľovač] číslo či číslo [oddeľovač] číslo, kde oddeľovačom môže byť ':', ' ' ' či ' " '. Čísla sú typicky v rozsahu 01 - 24 pre hodiny a 01 - 59 pre minúty a sekundy.

Ak je 0 prítomná v číslach v rozsahu 01 - 09, môže byť rozhraním ignorovaná či normalizovaná na "oh". Rozhranie môže do normalizovaných časov umiestniť reťazec "and".

time

Príklad:

<context id="time">12:30</context>

bude normalizované na "twelve thirty"

<context id="time">01:21</context>

bude normalizované na "one twenty one"
či "oh one twenty one"

<context id="time">1'21"</context>

bude normalizované na "one minute twenty one seconds"
či "one minute and twenty one seconds"

chs_time_hms

Text určujúci čas je normalizovaný tak, že prvá skupina číslic je hodina, druhá minúta a tretia sekunda.

Táto kontextová značka je špecifická pre čínštinu.

chs_time_hm

Text určujúci čas je normalizovaný tak, že prvá skupina číslic je hodina a druhá minúta.

Táto kontextová značka je špecifická pre čínštinu.

Number

number_cardinal

Text je normalizovaný ako číslo s použitím regulárneho formátu jednotiek, desiatok a pod. Rozhranie do normalizovaného textu môže umiestniť reťazec "and".

Príklad:

<context id="number_cardinal">3432</context>

bude normalizované na "three thousand four hundred thirty two"

<context id="number_cardinal">3432</context>

bude normalizované na "three thousand four hundred and thirty two"

number_digit

Text je normalizovaný podľa číslic, jedna po druhej.

Príklad:

<context id="number_digit">3432</context>

bude normalizované na "three four three two"

number_fraction

Text je normalizovaný ako fraktál.

Príklad:

<context id="number_fraction">3/15</context>

bude normalizované na "three fifteenths" či "three over fifteen"

number_decimal

Text je normalizovaný ako desiatková hodnota.

Príklad:

<context id="number_decimal">423.1243</context>

bude normalizované na "four hundred and twenty three point one two four three"

phone_number

Text je normalizovaný ako telefónne číslo. Implementácia je ponechaná na vývojároch hlasových syntéz. Môže byť spresnená v ďalších verziách rozhrania Sapi.

currency

Text je normalizovaný ako mena. Implementácia je ponechaná na vývojároch hlasových syntéz. Môže byť spresnená v ďalších verziách rozhrania Sapi.

Príklad:

<context id="currency">$34.90</context>

bude normalizované na "thirty four dollars and ninety cents"

chs_number_percentage

Text je normalizovaný ako hodnota v percentách.

Táto kontextová značka je špecifická pre čínštinu.

chs_number_scientific

Text je normalizovaný ako vedecká notácia.

Táto kontextová značka je špecifická pre čínštinu.

chs_phone_postal

Telefónne číslo a poštová adresa je takmer totožná so značkou number_cardinal. Jediným rozdielom je, že "1" je čítaná ako "yao1".

Táto kontextová značka je špecifická pre čínštinu.

Web

Text je normalizovaný ako URL. Implementácia je ponechaná na vývojároch hlasových syntéz. Môže byť spresnená v ďalších verziách rozhrania Sapi.

web_url

Príklad:

<context id="web_url">www.Microsoft.com</context>

bude normalizované na "w w w dot Microsoft dot com"

E-mail

Text je normalizovaný ako e-mail. Implementácia je ponechaná na vývojároch hlasových syntéz. Môže byť spresnená v ďalších verziách rozhrania Sapi.

e-mail_address

Text je normalizovaný ako e-mailová adresa. Implementácia je ponechaná na vývojároch hlasových syntéz. Môže byť spresnená v ďalších verziách rozhrania Sapi.

Príklad:

<context id="e-mail_address">someone@microsoft.com</context>

bude normalizované na "Someone at Microsoft dot com"

Address

Text je normalizovaný ako adresa. Implementácia je ponechaná na vývojároch hlasových syntéz. Môže byť spresnená v ďalších verziách rozhrania Sapi.

address

Príklad:

<context id="address">One Microsoft Way, Redmond, WA, 98052</context>

bude normalizované na "One Microsoft Way Redmond Washington nine eight zero five two"

address_postal

Text je normalizovaný ako poštová adresa. Implementácia je ponechaná na vývojároch hlasových syntéz. Môže byť spresnená v ďalších verziách rozhrania Sapi.

Príklad:

<context id="address_postal">A2C 4X5</context>

bude normalizované na "A 2 C 4 X 5"


Universal Tags

It is recommended to use the control tags for SAPI 4 and the XML tags for SAPI 5 and Microsoft Speech Platform. But in addition Balabolka supports its own universal tags to modify the speech synthesis.

Audio

Balabolka podporuje vkladanie odkazov na externé zvukové súbory (audio klipy) do textu. Pre výber súborov použite položku hlavnej ponuky 'Text / Audio klip'.

Podporované formáty: WAV, MP3, OGG.

Značka audio klipu vypadá nasledovne:

{{Audio=D:\Zvuky\ring.wav}}

Je možné použiť i relatívnu cestu k zvukovému súboru. Relatívna cesta je cesta k umiestneniu súborov vzhľadom k aktuálnemu dokumentu. Príklad:

{{Audio=..\moje zvuky\ring.mp3}}

Pri nájdení značky audio klipu Balabolka pozastaví čítanie, prehrá príslušný zvuk a opäť čítanie obnoví. Počas konvertovania do zvukových súborov budú audio klipy zahrnuté na príslušné miesta vo výsledných súboroch.

Voice

If it is necessary to change a voice or its properties during reading aloud, a special tag can be used for SAPI 5 and Microsoft Speech Platform (SAPI 4 voices will ignore this tag).

The tag format:

{{Voice=Name;Rate;Pitch;Volume}}

  • Name - the name of a voice (one word or the part of a word is enough);
  • Rate - the rate of a voice (values range from -10 to 10);
  • Pitch - the pitch of a voice (values range from -10 to 10);
  • Volume - the volume (values range from 0 to 100).

A tag applies to all subsequent text. The values are separated by semicolons. For example:

This text will be spoken by the default voice of Balabolka. {{Voice=Kimberly;0;0;100}} The voice 'Kimberly' will read the other text.

The tag's content is case insensitive. Values for some properties can be omitted:

{{voice=eric;;;50}}

{{Voice=Hans;-1}}

{{Voice=Rachel}}

To return to the default voice, use this tag:

{{Voice=}}

Warning! It is impossible to switch between SAPI 5 voices and voices of the Microsoft Speech Platform.

Pause

Je možné do výstupného zvukového súboru vložiť definovaný počet milisekúnd ticha. Príklad:

120 ms ticha. {{Pause=120}} Práve prebehlo.


-fonetické abecedy

Fonetická abeceda obsahuje zoznam písmen, číslic a znakov, známych ako fonémy. Fonéma reprezentuje jedinečný zvuk v hovorenom jazyku. Fonémy je možné použiť pre jednoznačné určenie výslovnosti slova v konkrétnom jazyku. Pre tento účel hlasové syntézy podporujú obecne definované fonetické abecedy.

  • International Phonetic Alphabet (IPA)
  • Speech API (SAPI) Phone Set
  • Universal Phone Set (UPS)

International Phonetic Alphabet (IPA) je systém fonetického zápisu, založený primárne na latinskej abecede, určenej ako štandard pre reprezentáciu zvukov hovoreného jazyka. Túto fonetickú abecedu je možné použiť pre určenie výslovnosti ktoréhokoľvek jazyka.

Prvé jazyky pre prevod textu na reč prostredníctvom počítačom definovanej výslovnosti slov s použitím SAPI Phone Setu boli vytvorené spoločnosťou Microsoft. Fonéma pozostáva z jedného či viac znakov fonetickej abecedy, popisujúcej diskrétne zvuky hovoreného jazyka. Nasledujúce jazyky používajú k popísaniu svojich zvukov SAPI Phone Set: čínština, angličtina, francúzština, nemčina, japončina, španielčina.

V priebehu času Microsoft vyvinul Universal Phone Set (UPS), strojovo čitateľnú fonetickú abecedu, založenú na medzinárodnej fonetickej abecede (IPA). Abeceda UPS je oveľa výkonnejšou fonetickou abecedou ako SAPI Phone Set. Môže byť použitá pre popis zvukov ktoréhokoľvek nového jazyka a je oveľa jednoduchšie priradiť ju k ďalším strojovo čitateľným fonetickým abecedám ako napr. X-SAMPA, SAMPA, či ASCII-IPA.

Používateľ tvorí výslovnosť použitím značky výslovnosti XML. Napr. tu sú dva fonetické prepisy, ktoré môžu byť hlasovou syntézou použité k vysloveniu slova "hello" v americkej angličtine:

<pron sym="h eh - l ow 1"/>

<pron sym="H EH S1 L O"/>

Prvý z príkladov používa fonémy SAPI phone setu. "1" je symbol pre dôraz. Určuje, ktorá slabika by mala byť zdôraznená. Fonémy sú oddelené medzerou a "-" oddeľuje slabiky v slove. 'Druhý príklad používa fonémy z Universal Phone Setu. Písmená určujú vyslovované úseky, tvoriace slovo. "S1" je symbol pre dôraz. Určuje, ktorá slabika by mala byť zdôraznená.

Pretože fonetické abecedy SPS a UPS v súčasnej dobe nepodporujú slovenčinu, ponechávame ich referenčné príručky prevažne v anglickej podobe.

The current versions of IVONA voices do not support SAPI phonemes. The PRON tag is ignored. It is recommended to use the Speech Synthesis Markup Language (SSML) tag to provide a phonetic pronunciation for the specific text.

<phoneme alphabet="ipa" ph="təˈmeɪtoʊ">tomato</phoneme>

The PHONEME tag can be shortened:

<phoneme alphabet="ipa" ph="pəˈteɪtoʊ"/>

The SSML tag supports phonetic alphabets:

  • International Phonetic Alphabet (IPA)
  • Extended Speech Assessment Methods Phonetic Alphabet (X-SAMPA)

IPA symbols are difficult to enter from the keyboard. Balabolka allows to choose characters from the list of IPA symbols. Also the application can convert words to IPA symbols. The phonetic transcriptions are supported for languages:

  • English
  • French
  • German
  • Italian
  • Polish
  • Portuguese
  • Russian
  • Spanish
  • Turkish
  • Ukrainian

Text should be written in lower case; the capital vowels can be used to indicate a primary stress in words.


SAPI Phone Set

Microsoft Speech API využíva fonetickú abecedu k vyjadreniu reči formou foném. Vo fonetickej abecede sú definované všetky fonémy používané daným jazykom spolu s ich vlastnosťami a údajmi potrebnými k výslednému výstupu formou zvukov. Používatelia môžu tvoriť výslovnosti slov, ktoré nie sú aktuálne v slovníku, používaním foném uvedených v nasledujúcich tabuľkách. Súbor foném pozostáva z fonetickej reprezentácie (SYM).

Používateľ môže vložiť SYM reprezentáciu pre vytvorenie výslovnosti použitím značky výslovnosti XML. Každý záznam foném by mal byť oddelený medzerou.

Príklad: Výslovnosť slova "hello":

Za účelom spresnenia výslednej podoby môžu byť k výslovnosti pridané značky pre dôraz či značky slabík.

Príklad. Výslovnosť slova "hello" s použitím značky dôrazu a slabiky:

SAPI Phone Set je použiteľný pre nasledujúce jazyky:

  • Angličtina Spojené štáty
  • Francúzština
  • Nemčina
  • Taliančina
  • Španielčina
  • Čínština
  • Japončina

Fonémy pre angličtinu Spojené štáty

Symbol fonémy | Príklad | Transkripcia
1 | Primárny prízvuk |
2 | Sekundárny prízvuk |
- | Hranica slabiky (pomlčka) |
& | Hranica slova |
! | Zakončenie vety (výkričník) |
, | Zakončenie vety (čiarka) |
. | Zakončenie vety (bodka) |
? | Zakončenie vety (otáznik) |
_ | Ticho (podčiarknutie) |
aa | father | f aa 1 dh er
ae | cat | k ae 1 t
ah | but | b ah 1 t
ao | bought | b ao 1 t
aw | house | h aw 1 s
ax | about | ax b aw 1 t
ay | bite | b ay 1 t
b | book | b uh 1 k
ch | catch | k eh 1 ch
d | done | d ah 1 n
dh | breathe | b r i dh
eh | bet | b eh 1 t
er | bird | b er 1 d
ey | ate | ey 1 t
e@ | fairly | f e@ 1 l i
f | fog | f ao 1 g
g | good | g uh 1 d
h | hello | h eh l ow 1
ih | bit | b ih 1 t
iy | beat | b iy 1 t
i@ | here | h i@ 1
jh | jump | jh ah 1 mp
k | cat | k ae 1 t
l | lot | l aa 1 t
m | Mom | m aa 1 m
n | nod | n aa 1 d
ng | sing | s ih 1 ng
ow | boat | b ow 1 t
oy | boy | b oy 1
p | pot | p aa 1 t
r | rat | r ae 1 t
s | sit | s ih 1 t
sh | shut | sh ah 1 t
t | top | t aa 1 p
th | thick | th ih 1 k
uh | book | b uh 1 k
uw | boot | b uw 1 t
v | various | v eh 1 r i ih s
w | won | w ah 1 n
y | you | y uw 1
z | zoo | z uw 1
zh | casual | k ae 1 zh uw ah l

Fonémy pre francúzštinu

Symbol fonémy | Príklad | Transkripcia
1 | Primárny prízvuk |
2 | Sekundárny prízvuk |
- | Hranica slabiky (pomlčka) |
& | Hranica slova |
! | Zakončenie vety (výkričník) |
, | Zakončenie vety (čiarka) |
. | Zakončenie vety (bodka) |
? | Zakončenie vety (otáznik) |
_ | Ticho (podčiarknutie) |
a | patte | p a 1 t
aan | abandon | a b aan d aon 1
ao | comme | k ao 1 m
aon | bon | b aon 1
ax | le | l ax 1
b | bouche | b u 1 sh
ch | charlie | ch a 1 r l i
d | dame | d a 1 m
dz | jeudi | j oe dz i 1
e | marché | m a r sh e 1
eh | chere | sh eh 1 r
ehn | main | m ehn 1
eo | feu | f eo 1
f | fille | f i 1 j
g | garde | g a 1 r d
i | libre | l i 1 b r
j | pierre | p j e 1 r
jh | George | jh ao 1 r jh
k | chique | sh i k
l | langage | l aan g a 1 zh
m | mois | m w a 1
n | nonne | n ao 1 n
ng | shopping | sh ao p i 1 ng
nj | campagne | k aan p a 1 nj
o | animaux | a n i m o 1
oe | leur | l oe 1 r
oen | parfum | p a r f oen 1
p | pile | p i 1 l
q | hacher | q a sh e 1
r | route | r u t
s | adresser | a d r e s e 1
sh | chaise | sh eh 1 z
t | technique | t eh k n i 1 k
ts | énergétique | e n eh r zh e ts i 1 k
u | doux | d u 1
ue | une | ue 1 n
uh | Bush | b uh 1 sh
v | vive | v i 1 v
w | boire | b w a 1 r
yw | huile | yw i 1 l
z | zone | z ao 1 n
zh | juste | zh ue 1 s t

Fonémy pre nemčinu

Symbol fonémy | Príklad | Transkripcia
1 | Primárny prízvuk |
2 | Sekundárny prízvuk |
- | Hranica slabiky (pomlčka) |
& | Hranica slova |
! | Zakončenie vety (výkričník) |
, | Zakončenie vety (čiarka) |
. | Zakončenie vety (bodka) |
? | Zakončenie vety (otáznik) |
_ | Ticho (podčiarknutie) |
a | Achtung | q a 1 x t uh ng
A | Name | n A 1 m ah
aan | Chance | sh aan 1 s ah
ah | bitte | b ih 1 t ah
ao | Hoffnung | h ao 1 f n uh ng
aon | Pompon | p aon 1 p aon 1
aw | Raum | rq aw 1 m
ay | Zeit | ts ay 1 t
b | besonders | b ah z ao 1 n d e@ s
c | China | c i 1 n A
ch | deutsch | d oy 1 ch
d | das | d a 1 s
e | mehr | m e 1 r
eh | Enkel | q eh 1 ng k el
EH | erklären | q eh r k l EH 1 rq en
ehn | Bassin | b a s ehn 1
el | Einzelnen | q ay 1 n ts el n en
em | einem | q ay 1 n em
cs | einen | q ay 1 n en
er | Surfer | s er 1 f e@
ey | Display | d ih s p l ey 1
e@ | Kindern | k ih 1 n d e@ n
f | Fall | f a 1 l
g | glaube | g l aw 1 b ah
h | Haupt | h aw 1 p t
i | sieben | z i 1 b en
ih | immer | q ih 1 m e@
j | ja | j A 1
jh | Dschungel | jh uh 1 ng el
k | Kultur | k uh l t u 1 r
l | lieber | l i 1 b e@
m | mein | m ay 1 n
n | Name | n A 1 m ah
ng | Junge | j uh 1 ng ah
o | oder | q o 1 d e@
oe | öffnete | q oe 1 f n ah t ah
OE | Österreich | q OE 1 s t ah rq ay c
oen | Parfum | p a r f oen 1
oy | Europa | q oy rq o 1 p A
p | Parlament | p a r l a m eh 1 n t
pf | Pflicht | pf l ih 1 c t
q | aber | q A 1 b e@
r | Berliner | b eh r l i 1 n e@
rq | Runde | rq uh 1 n d ah
s | Szene | s ts e 1 n ah
sh | sprach | sh p rq A 1 x
t | tol | t ao 1 l
ts | Zimmer | ts ih 1 m e@
u | Uhren | q u 1 rq en
ue | hübsch | h ue 1 p sh
UE | über | q UE 1 b e@
uh | Schutz | sh uh 1 ts
v | wichtig | v ih 1 c t ih c
w | Mademoiselle | m a d ah m w a z eh 1 l
x | Buch | b u 1 x
z | selbst | z eh 1 l p s t
zh | Spionage | sh p i o n A 1 zh ah

Fonémy pre taliančinu

Symbol fonémy | Príklad | Transkripcia
1 | Primárny prízvuk |
2 | Sekundárny prízvuk |
- | Hranica slabiky (pomlčka) |
& | Hranica slova |
! | Zakončenie vety (výkričník) |
, | Zakončenie vety (čiarka) |
. | Zakončenie vety (bodka) |
? | Zakončenie vety (otáznik) |
_ | Ticho (podčiarknutie) |
a | campo | k a 1 m p o
ao | nove | n ao 1 v e
b | barra | b a 1 rr a
ch | percento | p e r ch eh 1 n t o
d | mondo | m o 1 n d o
dz | zeta | dz eh 1 t a
e | venire | v e n i 1 r e
eh | lento | l eh 1 n t o
f | fine | f i 1 n e
g | gruppi | g r u 1 p i
i | si | s i
j | funzione | f u n ts j o 1 n e
jh | generazione | jh e n e r a ts j o 1 n e
k | economia | e k o n o m i 1 a
l | libri | l i 1 b r i
ll | gli | ll i
m | mai | m a 1 i
n | nord | n ao r d
nj | signor | s i 1 nj ao r
o | otto | ao 1 t t o
p | primo | p r i 1 m o
r | arrivederci | a rr i v e d e 1 r ch i
rr | arrivederci | a rr i v e d e 1 r ch i
s | sinistra | s i n i 1 s t r a
sh | scienza | sh eh 1 n ts a
t | tre | t r eh
ts | grazie | g r a 1 ts j e
u | punto | p u 1 n t o
v | venti | v e 1 n t i
w | Washington | w a 1 sh i ng t o n
z | svolta | z v o 1 l t a

Fonémy pre španielčinu

Symbol fonémy | Príklad | Transkripcia
1 | Primárny prízvuk |
2 | Sekundárny prízvuk |
- | Hranica slabiky (pomlčka) |
& | Hranica slova |
! | Zakončenie vety (výkričník) |
, | Zakončenie vety (čiarka) |
. | Zakončenie vety (bodka) |
? | Zakončenie vety (otáznik) |
_ | Ticho (podčiarknutie) |
a | aquí | a k i 1
b | Brasil | b r a s i 1 l
ch | Chile | ch i 1 l e
d | grande | g r a 1 n d e
e | este | e 1 s t e
f | función | f u n s xi o 1 n
g | segundo | s e g u 1 n d o
i | identidad | i d e n t i d a 1 d
j | yo | j o 1
k | casa | k a 1 s a
l | los | l o 1 s
ll | llamada | ll a m a 1 d a
m | manos | m a 1 n o s
n | no | n o 1
nj | ano | a 1 nj o
o | bueno | b xu e 1 n o
p | para | p a 1 r a
r | para | p a 1 r a
rr | radio | rr a 1 d xi o
s | solo | s o 1 l o
sh | Bush | b u 1 sh
t | importante | i m p o r t a 1 n t e
u | uno | u 1 n o
w | Hollywood | o 1 l i w u d
x | general | x e n e r a 1 l
xi | iogur | xi o g u 1 r
xu | puedo | p xu e 1 d o

Fonémy pre čínštinu

Symbol fonémy | Príklad
- | Hranica slabiky (pomlčka)
! | Zakončenie vety (výkričník)
& | Hranica slova
, | Zakončenie vety (čiarka)
. | Zakončenie vety (bodka)
? | Zakončenie vety (otáznik)
_ | Ticho (podčiarknutie)
+ | Primárny prízvuk
* | Sekundárny prízvuk
1 | Zvuk 1
2 | Zvuk 2
3 | Zvuk 3
4 | Zvuk 4
5 | Zvuk 5
a | a 1 fei 1 (rúž)
ai | ai 4 ren 2 (milenec)
an | an 1 quan 2 (bezpečný)
ang | ang 1 zang 1 (špinavý)
ao | jiao 1 ao 4 (hrdý)
ba | ba 4 ba 5 (otec)
bai | bai 2 se 4 (biela)
ban | mu 4 ban 3 (doska)
bang | bang 3 jia 4 (únos)
bao | yong 1 bao 4 (objatie)
bei | bei 3 fang 1 (sever)
ben | ben 4 dan 4 (hlupák)
beng | beng 4 tiao 4 (skok)
bi | bi 2 zi 5 (nos)
bian | bian 4 hua 5 (zmena)
biao | biao 3 ge 2 (stôl)
bie | li 2 bie 2 (prenechať)
bin | bin 1 ke 4 (hosť)
bing | shi 4 bing 1 (vojak)
bo | bo 2 dou 4 (zápas)
bu | bu 4 xing 2 (chodiť)
ca | ca 1 gan 1 (utierať)
cai | cai 1 ce 4 (odhadovať)
can | can 1 jia 1 (spojiť)
cang | cang 1 ying 5 (letieť)
cao | cao 1 chang 3 (ihrisko)
ce | ce 4 liang 2 (merať)
cen | cen 1 ci 1 (nerovnomerné)
ceng | ceng 2 jing 1 (raz)
cha | jian 3 cha 2 (skontrolovať)
chai | chai 1 hui 3 (zbúrať)
chan | chan 3 ye 4 (priemysel)
chang | jing 1 chang 2 (často)
chao | chao 1 yue 4 (prekročiť)
che | qi 4 che 1 (automobil)
chen | chen 2 jiu 4 (starý)
cheng | cheng 2 che 1 (jazda)
chi | chi 2 dao 4 (neskoro na)
chong | chong 1 man 3 (plný)
chou | chou 2 hen 4 (nenávisť)
chu | chu 2 fa 3 (rozdelenie)
chuai | chuai 3 ce 4 (odhadovať)
chuan | lun 2 chuan 2 (loď)
chuang | chuang 4 ye 4 (vybojovať si)
chui | tie 3 chui 2 (kladivo)
chun | chun 1 tian 1 (jar)
chuo | wo 4 chuo 4 (špinavý)
ci | ci 2 qi 4 (porcelán)
cong | cong 2 lin 2 (krovie)
cou | jin 3 cou 4 (kompaktný)
cu | cu 4 xiao 1 (podpora predaja)
cuan | tao 2 cuan 4 (utiecť)
cui | cui 1 cu 4 (tlačiť)
cun | xiang 1 cun 1 (zem)
cuo | cuo 4 wu 4 (chyba)
da | da 4 (veľký)
dai | dai 4 biao 3 (delegát)
dan | dan 4 shi 4 (ale)
dang | dang 1 ran 2 (iste)
dao | dao 1 (nôž)
de | de 5 (funkčné slovo)
dei | dei 3 (musieť)
den | den 4 (vytrhnúť)
deng | ban 3 deng 4 (drevená stolička)
di | di 2 que 4 (iste)
dia | dia 3 (koketný hlas)
dian | dian 3 (bodka)
diao | diao 4 (visieť)
die | die 1 dao 3 (spadnúť)
ding | jue 2 ding 4 (rozhodnúť)
diu | diu 1 qi 4 (vyhodiť)
dong | dong 1 fang 1 (východ)
dou | zhan 4 dou 4 (usilovať)
du | du 4 jue 2 (zastaviť)
duan | duan 3 (krátky)
dui | dui 4 (vpravo)
dun | ting 2 dun 4 (zastaviť)
duo | duo 1 yu 2 (zbytočný)
e | e 4 (hladný)
ei | ei 4 (áno)
en | en 1 hui 4 (láskavosť)
er | er 3 (ucho)
fa | fa 1 zhan 3 (vývoj)
fan | fan 4 (ryža)
fang | fang 2 jian 1 (izba)
fei | fei 1 (mucha)
fen | fen 1 bie 2 (samostatný)
feng | feng 1 (vietor)
fo | fo 2 (Budha)
fou | fou 3 ding 4 (odmietnutie)
fu | fu 4 qin 1 (otec)
ga | gan 1 ga 4 (trápny)
gai | ying 1 gai 1 (mal by)
gan | gan 1 jing 4 (čistota)
gang | gang 1 cai 2 (len)
gao | gao 1 (vysoký)
ge | pin 3 ge 2 (znak)
gei | gei 3 yu 3 (dať)
gen | gen 1 (koreň)
geng | geng 4 jia 1 (oveľa viac)
gong | gong 1 ren 2 (pracovník)
gou | zu 2 gou 4 (dosť)
gu | gu 4 xiang 1 (rodné mesto)
gua | xi 1 gua 1 (melón)
guai | qi 2 guai 4 (zvláštny)
guan | guan 1 bi 4 (zatvoriť)
guang | guang 1 (svetlo)
gui | gui 3 (duch)
gun | gun 4 (tyč)
guo | guo 4 qu 4 (minulosť)
ha | ha 1 (zvuk smiechu)
hai | hai 2 zi 5 (dieťa)
han | chu 1 han 4 (sladký)
hang | hang 2 xing 2 (plachtenie)
hao | hao 3 (dobrý)
he | he 2 (rieka)
hei | hei 1 (čierna)
hen | hen 3 (veľmi)
heng | heng 2 xiang 4 (orientácia na šírku)
hong | hong 2 (červená)
hou | hou 2 zi 5 (opica)
hu | hu 2 xu 1 (medveď)
hua | hua 4 (obrázok)
huai | huai 4 (zlý)
huan | huan 2 jing 4 (životné prostredie)
huang | huang 2 se 4 (žltá)
hui | hui 1 huang 2 (lesk)
hun | hun 2 zhuo 2 (blatistý)
huo | huo 3 (oheň)
ji | ji 2 shi 2 (včas)
jia | jia 4 qi 1 (prázdniny)
jian | jian 3 dan 1 (jednoduchý)
jiang | jiang 1 (rieka)
jiao | jiao 1 tong 1 (prevádzka)
jie | jie 2 ri 4 (sviatok)
jin | jin 3 zhang 1 (napätie)
jing | gan 1 jing 4 (čistota)
jiong | jiong 3 po 4 (zahanbený)
jiu | jiu 3 (deväť)
ju | ju 4 zi 5 (veta)
juan | juan 3 qu 1 (kučeravý)
jue | jue 2 ding 4 (rozhodnúť)
jun | jun 1 dui 4 (armáda)
ka | ka 3 che 1 (nákladné auto)
kai | kai 3 xuan 2 (triumf)
kan | kan 4 (vidieť)
kang | di 3 kang 4 (odolávať)
kao | kao 3 shi 4 (test)
ke | ke 3 (smädný)
kei | kei 1 (vynadať)
ken | ken 3 ding 4 (uistiť)
keng | keng 1 hai 4 (polapiť)
kong | kong 1 qi 4 (vzduch)
kou | kou 3 (ústa)
ku | jian 1 ku 3 (útrapy)
kua | kua 1 jiang 3 (chváliť)
kuai | kuai 4 (rýchlo)
kuan | kuan 1 kuo 4 (otvorenosť)
kuang | kong 1 kuang 4 (prázdny)
kui | kui 1 qian 4 (dlžiť)
kun | kun 4 nan 2 (tvrdý)
kuo | kuo 4 da 4 (zväčšiť)
la | la 4 jiao 1 (feferónka)
lai | lai 2 (prísť)
lan | lan 2 se 4 (modrá)
lang | lang 2 (vlk)
lao | lao 3 (starý)
le | kuai 4 le 4 (šťastný)
lei | lei 2 (hrom)
leng | leng 3 ku 4 (nezlomnosť)
li | li 2 (hruška)
lia | lia 2 (dve)
lian | lian 3 (tvár)
liang | li 4 liang 4 (napájanie)
liao | zuo 2 liao 4 (korenie)
lie | lin 3 lie 4 (závažný)
lin | lin 3 lie 4 (závažný)
ling | ling 2 mu 4 (mauzóleum)
liu | liu 2 dong 4 (tok)
lo | lo 5 (funkčné slovo)
long | long 2 (drak)
lou | lou 4 (únik)
lu | lu 4 di 4 (zem)
luan | hun 4 luan 4 (chaos)
lue | ce 4 lue 4 (taktika)
lun | yi 4 lun 4 (diskutovať)
luo | xia 4 luo 4 (miesto pobytu)
lv | lv 4 se 4 (zelená)
ma | ma 3 (kôň)
mai | mai 2 zang 4 (pochovať)
man | man 3 zu 2 (uspokojiť)
mang | cong 1 mang 2 (ponáhľať sa)
mao | mao 1 (mačka)
me | shen 2 me 5 (čo)
mei | mei 2 you 3 (nie)
men | wo 3 men 2 (my)
meng | meng 4 (sen)
mi | hun 1 mi 2 (kóma)
mian | mian 4 ji 5 (plocha)
miao | miao 4 (chrám)
mie | mie 4 jue 2 (vyhladenie)
min | ren 2 min 2 (ľudia)
ming | ming 2 bai 2 (zrozumiteľnosť)
miu | huang 1 miu 4 (nezmyselný)
mo | mo 4 shui 3 (atrament)
mou | mou 2 lue 4 (lesť)
mu | mu 4 biao 1 (cieľ)
na | na 4 li 3 (tam)
nai | nai 3 nai 5 (babička)
nan | nan 2 fang 1 (juh)
nang | nang 2 kuo 4 (zahŕňať)
nao | re 4 nao 4 (temperament)
ne | mu 4 ne 4 (znecitlivený)
nei | nei 4 bu 4 (vo vnútri)
nen | nen 4 lv 4 (svetlozelená)
neng | neng 2 gou 4 (schopný)
ni | ni 3 (ty)
nian | nian 2 (rok)
niang | gu 1 niang 5 (dievča)
niao | niao 3 (vták)
nie | nie 4 (uhryznúť)
nin | nin 2 (ty)
ning | an 1 ning 2 (mier)
niu | niu 2 (býk)
nong | nong 2 min 2 (farmár)
nou | nou 4 (odburiňovanie)
nu | nu 3 li 4 (snažiť)
nuan | wen 1 nuan 3 (teplý)
nue | nue 4 dai 4 (týranie)
nuo | nuo 4 yan 2 (sľub)
nv | nv 3 zi 3 (žena)
o | o 5 (funkčné slovo)
ou | ou 1 yang 2 (čínske krstné meno)
pa | hai 4 pa 4 (vydesený)
pai | pai 4 qian 3 (poslať)
pan | pan 4 tu 2 (zradca)
pang | pang 2 da 4 (obrovský)
pao | pao 3 (beh)
pei | pei 2 ban 4 (odprevadiť)
pen | pen 2 di 4 (panva)
peng | peng 2 pai 4 (príval)
pi | pi 2 fu 1 (koža)
pian | qi 1 pian 4 (podvod)
piao | piao 4 liang 4 (pekný)
pie | pie 1 kai 1 (odložiť)
pin | pin 2 fan 2 (frekvencia)
ping | ping 2 zi 5 (fľaša)
po | po 4 huai 4 (poškodenie)
pou | pou 2 (podržať niečo v dlani)
pu | pu 2 tao 5 (hrozno)
qi | qi 3 qiu 2 (žobroniť)
qia | qia 4 dang 4 (vhodný)
qian | qian 1 xu 1 (skromnosť)
qiang | qiang 2 da 4 (výkonný)
qiao | qiao 3 miao 4 (vynaliezavosť)
qie | xiu 1 qie 4 (plachosť)
qin | qin 1 zi 4 (osobne)
qing | qing 1 song 1 (ľahký)
qiong | qiong 2 (chudoba)
qiu | qiu 2 fan 4 (vezeň)
qu | qu 1 dong 4 (pohon)
quan | quan 2 bu 4 (všetko)
que | que 4 ding 4 (zaručiť)
qun | qun 2 zhong 4 (dav)
ran | ran 2 hou 4 (potom)
rang | tu 3 rang 3 (pôda)
rao | wei 2 rao 4 (okolie)
re | re 4 (horúco)
ren | ren 2 lei 4 (človek)
reng | reng 2 ran 2 (rovnaký)
ri | ri 4 chu 1 (východ slnka)
rong | rong 2 yao 4 (sláva)
rou | niu 2 rou 4 (hovädzí)
ru | ru 2 guo 3 (ak)
ruan | rou 2 ruan 3 (mäkký)
rui | rui 4 zhi 4 (šikovný)
run | shi 1 run 4 (vlhkosť)
ruo | ruo 4 xiao 3 (malosť)
sa | sa 1 (tri)
sai | bi 3 sai 4 (konkurovať)
san | fen 1 san 4 (rozptýliť sa)
sang | sang 4 (zomrieť)
sao | da 3 sao 3 (zametať)
se | yan 2 se 4 (farba)
sen | sen 1 lin 2 (les)
seng | seng 1 lv 3 (mních)
sha | sha 1 chang 3 (bojisko)
shai | ri 4 shai 4 (byť vystavený slnku)
shan | shan 4 liang 2 (láskavosť)
shang | shang 4 mian 4 (hore)
shao | shao 4 nian 2 (mládež)
she | she 2 (had)
shei | shei 2 (kto)
shen | shen 2 me 5 (čo)
sheng | sheng 1 yin 1 (hlas)
shi | shi 4 fei 1 (spor)
shou | shou 3 (ruka)
shu | shu 4 mu 4 (strom)
shua | shua 1 zi 5 (kartáč)
shuai | shuai 1 da 3 (biť)
shuan | men 2 shuan 1 (západka)
shuang | shuang 1 (pár)
shui | shui 3 (voda)
shun | shun 4 li 4 (dobre)
shuo | shuo 1 (hovoriť)
si | si 4 (štyri)
song | song 4 bie 2 (rozlúčenie)
sou | sou 1 cha 2 (hľadať)
su | su 4 du 4 (rýchlosť)
suan | suan 4 fa 3 (výpočet)
sui | sui 1 ran 2 (hoci)
sun | sun 3 shi 1 (strata)
suo | suo 3 yi 3 (takže)
ta | ta 1 men 2 (oni)
tai | tai 4 (tiež)
tan | tan 2 hua 4 (hovor)
tang | tang 2 (cukor)
tao | tao 2 pao 3 (utiesť)
te | te 4 bie 2 (zvláštny)
tei | tei 1 (veľmi)
teng | ben 1 teng 2 (výtržnosť)
ti | ti 1 zi 5 (rebrík)
tian | tian 1 (nebo)
tiao | tiao 4 yue 4 (skočiť)
tie | tie 3 (železo)
ting | ting 1 (počúvať)
tong | tong 3 yi 1 (zjednotiť)
tou | tou 2 (hlava)
tu | tu 3 di 4 (zem)
tuan | tuan 2 jie 2 (stuhnúť)
tui | tui 1 dong 4 (tlačiť)
tun | tun 2 ji 1 (hromadiť)
tuo | tuo 1 yi 1 (vyzliecť)
wa | qing 1 wa 1 (žaba)
wai | wai 4 mian 4 (vonku)
wan | wan 4 (desaťtisíc)
wang | si 3 wang 2 (smrť)
wei | wei 3 da 4 (skvelý)
wen | wen 2 hua 4 (kultúra)
weng | lao 3 weng 1 (starec)
wo | wo 3 (I)
wu | wu 2 lun 4 (bez ohľadu na to, čo)
xi | xi 1 fang 1 (západ)
xia | xia 4 mian 4 (spodok)
xian | xian 4 zai 4 (teraz)
xiang | xiang 4 (ako)
xiao | xiao 3 (malý)
xie | xie 3 (písať)
xin | xin 1 (nový)
xing | xing 2 dong 4 (čin)
xiong | xiong 2 (medveď)
xiu | xiu 1 xi 5 (prestávka)
xu | xu 1 yao 4 (potrebovať)
xuan | xuan 1 bu 4 (prehlásiť)
xue | xue 3 (sneh)
xun | xun 2 wen 4 (žiadať)
ya | ya 4 zhou 1 (Ázia)
yan | yan 4 zi 5 (prehltnúť)
yang | tai 4 yang 2 (slnce)
yao | yao 1 qiu 2 (požadovať)
ye | ye 2 ye 5 (deduško)
yi | yi 1 (jedna)
yin | yin 1 yue 4 (hudba)
ying | ying 1 gai 1 (mal by)
yo | yo 5 (funkčné slovo)
yong | yong 3 yuan 3 (navždy)
you | you 2 yu 2 (vzhľadom k)
yu | yu 2 (ryba)
yuan | yuan 2 lai 2 (skôr)
yue | yue 4 (mesiac)
yun | yun 2 (mrak)
za | za 2 luan 4 (neporiadok)
zai | zai 4 jian 4 (zbohom)
zan | zan 2 men 5 (náš)
zang | ang 1 zang 1 (špinavý)
zao | zao 3 chen 2 (ráno)
ze | ze 2 ren 4 (odozva)
zei | zei 2 (zlodej)
zen | zan 4 yang 2 (chváliť)
zeng | zeng 1 jia 1 (pridať)
zha | zha 4 dan 4 (bomba)
zhai | qian 4 zhai 4 (dlžiť)
zhan | zhan 4 li 4 (štát)
zhang | zhang 1 kai 1 (otvoriť)
zhao | zhao 1 huan 4 (povolať)
zhe | zhe 4 li 3 (tu)
zhei | zhei 5 (toto)
zhen | zhen 1 zheng 4 (reálne)
zheng | zheng 4 yi 4 (spravodlivosť)
zhi | yi 4 zhi 4 (zabrániť)
zhong | zhong 1 guo 2 (Čína)
zhou | si 4 zhou 1 (okolo)
zhu | zhu 1 (prasa)
zhua | zhua 1 (chytiť)
zhuai | zhuai 4 (ťahať)
zhuan | zhuan 1 (tehla)
zhuang | zhuang 1 (predstierať)
zhui | zhui 1 (naháňačka)
zhun | zhun 3 (presný)
zhuo | zhuo 1 (stôl)
zi | zi 4 (charakter)
zong | zong 3 (celkom)
zou | zou 3 (ísť)
zu | zu 1 (nájom)
zuan | zuan 4 (diamant)
zui | zui 4 (väčšina)
zun | zun 1 (rešpekt)
zuo | zuo 4 (sedieť)

Fonémy pre japončinu (Katakana)

Symbol | Fonetika | Unicode | Poznámky
' |  | U+0027 | Pozícia prízvuku
+ |  | U+002B | Hranica prízvuku
| |  | U+007C | Hranica frázy
. |  | U+002E | Koniec vety (štandardný)
? |  | U+003F | Koniec vety (opytovací)
! |  | U+0021 | Koniec vety (výkričník)
_ |  | U+005F | Jedna mora pauza
? |  | U+309C | Poloznelý zvuk
? | a | U+30A1 | Modifikátor
? | a | U+30A2 |
? | i | U+30A3 | Modifikátor
? | i | U+30A4 |
? | u | U+30A5 |
? | u | U+30A6 |
? | e | U+30A7 | Modifikátor
? | e | U+30A8 |
? | o | U+30A9 | Modifikátor
? | o | U+30AA |
? | ka | U+30AB |
? | ga | U+30AC |
? | ki | U+30AD |
? | gi | U+30AE |
? | ku | U+30AF |
? | gu | U+30B0 |
? | ke | U+30B1 |
? | ge | U+30B2 |
? | ko | U+30B3 |
? | go | U+30B4 |
? | sa | U+30B5 |
? | za | U+30B6 |
? | shi | U+30B7 |
? | ji | U+30B8 |
? | su | U+30B9 |
? | zu | U+30BA |
? | se | U+30BB |
? | ze | U+30BC |
? | so | U+30BD |
? | zo | U+30BE |
? | ta | U+30BF |
? | da | U+30C0 |
? | chi | U+30C1 |
? | di | U+30C2 | Zastarané - použiť 30B8
? | q | U+30C3 |
? | tsu | U+30C4 |
? | du | U+30C5 | Zastarané - použiť 30BA
? | te | U+30C6 |
? | de | U+30C7 |
? | to | U+30C8 |
? | do | U+30C9 |
? | na | U+30CA |
? | ni | U+30CB |
? | nu | U+30CC |
? | ne | U+30CD |
? | no | U+30CE |
? | ha | U+30CF |
? | ba | U+30D0 |
? | pa | U+30D1 |
? | hi | U+30D2 |
? | bi | U+30D3 |
? | pi | U+30D4 |
? | hu | U+30D5 |
? | bu | U+30D6 |
? | pu | U+30D7 |
? | he | U+30D8 |
? | be | U+30D9 |
? | pe | U+30DA |
? | ho | U+30DB |
? | bo | U+30DC |
? | po | U+30DD |
? | ma | U+30DE |
? | mi | U+30DF |
? | mu | U+30E0 |
? | me | U+30E1 |
? | mo | U+30E2 |
? | ya | U+30E3 | Modifikátor
? | ya | U+30E4 |
? | yu | U+30E5 | Modifikátor
? | yu | U+30E6 |
? | yo | U+30E7 | Modifikátor
? | yo | U+30E8 |
? | ra | U+30E9 |
? | ri | U+30EA |
? | ru | U+30EB |
? | re | U+30EC |
? | ro | U+30ED |
? | wa | U+30EE | Modifikátor
? | wa | U+30EF |
? | wi | U+30F0 | Zastarané - použiť 30A4
? | we | U+30F1 | Zastarané - použiť 30A8
? | wo | U+30F2 |
? | nn | U+30F3 |
? | vu | U+30F4 |
? | ka | U+30F5 |
? | ke | U+30F6 |
? | va | U+30F7 |
? | vi | U+30F8 |
? | ve | U+30F9 |
? | vo | U+30FA |
· |  | U+30FB | Bodka uprostred
— |  | U+30FC | Predĺžený zvuk
? |  | U+30FD | Iterácia
? |  | U+30FE | Znelá iterácia


Universal Phone Set

Medzinárodná sada foném (Universal Phone Set – UPS) pre Speech API (SAPI) je strojovo čitateľná sada foném, ktorá je založená na medzinárodnej fonetickej abecede (IPA).

Zásady vytvárania sady UPS

Pre výber označení SAPI a ID foném pre UPS boli použité nasledujúce princípy vytvárania.

  1. Sada UPS zahrňuje sadu znakov IPA 1993 Unicode a navyše niekoľko ďalších foném SAPI vrátane označenia niektorých suprasegmentálnych javov, ktoré sa používajú v značkovacích jazykoch pre hlasové syntézy, ale nenachádzajú sa v IPA.
    • Vo väčšine prípadov funguje medzi UPS a IPA jednoznačné mapovanie. V týchto prípadoch môže ID fonémy SAPI jednoducho použiť šestnástkovú hodnotu Unicode IPA.
    • V niektorých prípadoch môže byť sada UPS nadradená sade IPA. Sada UPS napríklad obsahuje niektoré unikátne označenia foném pre bežne používané zvuky, ako sú dvojhlásky a nazálne samohlásky, s ktorými IPA zachádza ako so zloženinami. Tieto zloženiny sú reprezentované pomocou symbolu zloženiny "+". S týmto symbolom sa zachádza rovnako ako s akoukoľvek inou fonémou, preto musí byť v slovníku oddelený medzerami: zloženina A a B sa zapisuje A + B, nie AB alebo A+B. ID fonémy SAPI týchto zloženín sa tvorí sekvenciou ID foném, z ktorých je zloženina vytvorená.
  2. Výslovnosť UPS sa skladá z reťazca foném UPS, ktoré sú vzájomne oddelené medzerami. SAPI nerozlišuje medzi segmentálnymi fonémami a diakritikou, suprasegmentálnymi javmi a tónmi, a preto je treba ich tiež oddeliť prázdnymi znakmi ako akúkoľvek inú fonému SAPI.
  3. Označenia foném UPS nemusia používať len označenia foném SAPI z americkej angličtiny, španielčiny, francúzštiny, nemčiny, japončiny alebo čínštiny; ale tam, kde je to možné, sa súčasné označenia SAPI môžu použiť opakovane. Pre vytváranie názvov označení foném boli použité dva postupy:
    • Sada foném UPS zohľadňuje všade tam, kde je to možné, pravopis, ale nie je nijak špeciálne zameraná na angličtinu.
    • Označenia foném dodržujú pravidlá značenia platné pre všetky fonetické triedy (napr. laxné samohlásky používajú znak "H" napríklad v 'IH', 'UH' a 'AH').
  4. Sada foném UPS rozlišuje veľké a malé písmená. Znaky foném UPS sú definované pomocou reťazcov znakov ASCII.
    • Segmentálne fonémy (spoluhlásky, samohlásky, trené a výbuchové spoluhlásky) sú vyjadrené veľkými abecednými symbolmi. Tie môžu mať odlišnú dĺžku od jedného do troch znakov. Obecne platí, že pre častejšie fonémy sa používajú kratšie symboly.
    • Diakritika je vyjadrená malými abecednými symbolmi v dĺžke troch znakov.
    • Suprasegmentálne javy a tóny sa môžu líšiť v dĺžke a obsahujú neabecedné znaky.

Sada UPS by sa mala používať pre všetky jazyky podporované spoločnosťou Microsoft okrem siedmich jazykov, ktoré v súčasnosti podporuje SAPI: čínština, angličtina (Spojené štáty), francúzština, nemčina, taliančina, japončina, španielčina.

Symbol pre viazanie zloženín

Sada UPS ponúka unikátne označenia foném pre bežné zložené zvuky, ako sú polotrené (afrikáty) a nazálne samohlásky. V niektorých jazykoch sa však môžu vyskytovať i menej časté zložené zvuky a tie musia byť v slovníkoch SAPI zastúpené. Sada UPS ponúka zlučovací alebo viazací symbol "+", ktorý je možné použiť k popisu zvukov a je zložený z akýchkoľvek dvoch foném.

Nemecký afrikát "PF", dvojhláska "AI" a nazálna samohláska "AN" sú v sade UPS zastúpené ako unikátne fonémy. Mohli by však byť prezentované i formou zloženín. Znamená to teda, že príklady "PF" a "P + F" sú ekvivalentné, ale odlišné od sekvencie foném "P F".

Unikátna fonéma | Zloženina
PF | P + F
AI | A + I

Nazálna samohláska "AN" môže byť popísaná tiež pomocou samohlásky "O" s diakritickým znamienkom pre nazálu. Všetky diakritické znamienka musia nasledovať až po segmentálnej fonéme, takže "A nas" a "A + nas" sú ekvivalentné. Preferuje sa prvý z uvedených príkladov, lebo SAPI si nevynucuje žiadny konkrétny spôsob použitia "+" alebo diakritických znamienok.

Unikátna fonéma | Zloženina
AN | A nas
AN | A + nas

Spoluhlásky

Toto je výpočet a krížové odkazy foném spoluhlások používaných tromi fonetickými abecedami.

Pravidlá značenia spoluhlások UPS

Symboly spoluhlások môžu mať dĺžku jedného, dvoch alebo troch znakov. Označenia v dĺžke jedného znaku sa používajú pre vysoko frekventované jazykovo univerzálne spoluhlásky. Všeobecne platí, že prvý znak označuje miesto a znelosť a druhý označuje spôsob artikulácie. Pravidlá značenia sa prevádzajú medzi jednotlivými fonetickými triedami nasledujúcimi spôsobmi:

Pravidlá pre značenie miesta artikulácie a znelosti:

  • U dentálnych a alveolárnych spoluhlások sa používa D pre znelé a T pre neznelé
  • Pre alveolárne spoluhlásky sa používa N pre nazály a R pre aproximanty
  • U labiodentálnych spoluhlások sa používa V pre znelé a F pre neznelé
  • Pre velárne spoluhlásky sa používa G pre znelé a K pre neznelé, NG pre nazály
  • Pre bilabiálne spoluhlásky sa používa B pre znelé a P pre neznelé plozívy, M pre nazály
  • Pre laterálne spoluhlásky sa používa L
  • Pre uvulárne spoluhlásky sa používa Q
  • Pre faryngálne spoluhlásky sa používa H
  • Pre palatálne spoluhlásky sa používa X pre neznelé a Y pre znelé

Pravidlá pre značenie spôsobu artikulácie:

  • Spôsob artikulácie je vyjadrený voľbou symbolu označenia (jedným znakom): napríklad M predstavuje nazálu
  • Zdvojenie prvého symbolu označuje trilky
  • Pre frikatívy sa používa H
  • Pre aproximanty sa používa X
  • Pre retroflexné spoluhlásky sa používa R

Tabuľka spoluhlások

Uvedené sú dve tabuľky, z ktorých každá obsahuje výpočet inej kategórie spoluhláskových foném:

  • Spoluhlásky
  • Afrikáty

Stĺpce tabuľky obsahujú nasledujúce informácie:

  • UPS. Označenie fonémy podľa medzinárodnej sady foném Microsoft (UPS).
  • IPA. Označenie fonémy podľa medzinárodnej fonetickej abecedy (IPA).
  • Unicode. Hodnota Unicode podľa sady foném IPA.
  • Popis podľa IPA. Tento stĺpec popisuje funkčné charakteristiky fonémy, ako je miesto artikulácie, spôsob artikulácie, typ fonácie a mechanizmus prúdenia vzduchu.
  • ASCII-IPA. Ekvivalentná fonéma podľa sady foném ASCII-IPA pre referenciu.
  • X-SAMPA. Ekvivalentná fonéma podľa X-SAMPA pre referenciu.
  • Príklad. Slovo, ktoré fonéma používa a ilustruje jeho zvuk.
  • Jazyk. Jazyk, do ktorého príkladové slovo patrí.

Spoluhláskové fonémy

Spoluhlásky (konsonanty) sú rečové zvuky, ktoré sa vyslovujú s kompletným (neznelé) alebo čiastočným uzatvorením hlasového ústrojenstva.

UPS | IPA | Unicode | Popis IPA | ASCII-IPA | X-SAMPA | Príklad | Jazyk
P | p | U+0070 | {blb,stp,vls} | p | p | put | Angličtina
B | b | U+0062 | {blb,stp,vcd} | b | b | big | Angličtina
M | m | U+006D | {blb,nas} | m | m | mat | Angličtina
BB | ʙ | U+0299 | {blb,trl,vcd} | B<trl> | B\ |  |
PH | ɸ | U+0278 | {blb,frc,vls} | P | p\ |  |
BH | β | U+03B2 | {blb,frc,vcd} | B | B | kabra | Španielčina
MF | ɱ | U+0271 | {lbd,nas} | M | F |  |
F | f | U+0066 | {lbd,frc,vls} | f | f | fork | Angličtina
V | v | U+0076 | {lbd,frc,vcd} | v | v | vat | Angličtina
VA | ʋ | U+028B | {lbd,apr,vcd} | r<lbd> | v\ |  |
TH | θ | U+03B8 | {dnt,frc,vls} | T | T | thin | Angličtina
DH | ð | U+00F0 | {dnt,frc,vcd} | D | D | then | Angličtina
T | t | U+0074 | {alv,stp,vls} | t | t | talk | Angličtina
D | d | U+0064 | {alv,stp,vcd} | d | d | dig | Angličtina
N | n | U+006E | {alv,nas} | n | n | žádný | Angličtina
RR | r | U+0072 | {alv,trl,vcd} | r<trl> | r | torre, rojo | Španielčina
DX | ɾ | U+027E | {alv,flp,vcd} | * | 4 | butter | Angličtina Spojené štáty
S | s | U+0073 | {alv,frc,vls} | s | s | sit | Angličtina Spojené štáty
Z | z | U+007A | {alv,frc,vcd} | z | z | zap | Angličtina Spojené štáty
LSH | ɬ | U+026C | {alv,lat,frc,vls} |  | K |  |
LH | ɮ | U+026E | {alv,lat,frc,vcd} | z<lat> | K\ | caballo | Španielčina/Zulu
RA | ɹ | U+0279 | {alv,apr} | r | r\ | puro | Španielčina
L | l | U+006C | {alv,lat,apr,vcd} | l | l | lid | Angličtina Spojené štáty
L vel | ɫ | U+026B | {alv,lat,apr,vcd} vel |  | 5 |  |
SH | ʃ | U+0283 | {pla,frc,vls} | S | S | she | Angličtina Spojené štáty
SH pal | ʆ | U+0286 | {pla,frc,vls} pal |  |  |  |
ZH | ʒ | U+0292 | {pla,frc,vcd} | Z | Z | pleasure | Angličtina Spojené štáty
ZH pal | ʓ | U+0293 | {pla,frc,vcd} pal |  |  |  |
TR | ʈ | U+0288 | {rfx,stp,vls} | t. | t` |  |
DR | ɖ | U+0256 | {rfx,stp,vcd} | d. | d` |  |
NR | ɳ | U+0273 | {rfx,nas,vcd} | n. | n` |  |
DXR | ɽ | U+027D | {rfx,flp,vcd} | *. | r` |  |
SR | ʂ | U+0282 | {rfx,frc,vls} | s. | s` |  |
ZR | ʐ | U+0290 | {rfx,frc,vcd} | z. | z` |  |
R | ɻ | U+027B | {rfx,apr,vcd} | r. | r\` | red | Angličtina Spojené štáty
LR | ɭ | U+026D | {rfx,lat,vcd} | l. | l` |  |
RR rho | ɼ | U+027C | {rfx,trl} |  |  |  |
CT | c | U+0063 | {pal,stp,vls} | c | c |  |
JD | ɟ | U+025F | {pal,stp,vcd} | J | J\ |  |
NJ | ɲ | U+0272 | {pal,nas,vcd} | J |  | oignon | Francúzština
C | ç | U+00E7 | {pal,frc,vls} | C | C | sicher | Nemčina
CJ | ʝ | U+029D | {pal,frc,vcd} | C<vcd> | j\ |  |
J | j | U+006A | {pal,apr,vcd} | j | j | yard | Angličtina Spojené štáty
LJ | ʎ | U+028E | {pal,lat,apr,vcd} | l^ | L | gli | Taliančina
W | w | U+0077 | {lbv,apr,vcd} | w | w | s | Angličtina Spojené štáty
K | k | U+006B | {vel,stp,vls} | k | k | cut | Angličtina Spojené štáty
G | g | U+0067 | {vel,stp,vcd} | g | g | gut | Angličtina Spojené štáty
NG | ŋ | U+014B | {vel,nas} | N | N | sing | Angličtina Spojené štáty
X | x | U+0078 | {vel,frc,vls} | x | x | mujer | Španielčina
GH | ɣ | U+0263 | {vel,frc,vcd} | Q | G | luego | Španielčina
GA | ɰ | U+0270 | {vel,apr,vcd} | j<vel> | M\ |  |
GL | ʟ | U+029F | {vel,lat,vcd} | L | L\ |  |
QT | q | U+0071 | {uvl,stp,vls} | q | q |  |
QD | ɢ | U+0262 | {uvl,stp,vcd} | G | G\ |  |
QN | ɴ | U+0274 | {uvl,nas,vcd} | n" | N\ |  |
QQ | ʀ | U+0280 | {uvl,trl,vcd} | - | R\ |  |
QH | χ | U+03C7 | {uvl,frc,vls} | X | X |  |
RH | ʁ | U+0281 | {uvl,frc,vcd} | g" | R | rond | Francúzština
HH | ħ | U+0127 | {phr,frc,vls} | H | X\ |  |
HG | ʕ | U+0295 | {phr,frc,vcd} | H<vcd> | ?\ |  |
GT | ʔ | U+0294 | {glt,stp,vls} | ? | ? |  |
H | h | U+0068 | {glt,frc,vls} | h | h | help | Angličtina Spojené štáty
WJ | ɥ | U+0265 | {lbp,apr,vcd} | j<rnd> | H | huit;juin | Francúzština

Afrikáty

Afrikáty (polotrené spoluhlásky) sú spoluhlásky vznikajúce prvotným krátkym záverom (ako explozívy) s následným uvoľnením (ako frikatívy).

Sada SAPI UPS obsahuje explicitné fonémy pre najfrekventovanejšie afrikáty v hlavných jazykoch. Špecifikácia IPA Unicode niektoré z týchto foném zahŕňa, ale nie všetky.

Tabuľka obsahuje základne fonémy (zloženiny UPS), ktoré po svojom zložení vytvárajú výslednú explicitnú fonému (UPS).

UPS | Zloženina UPS | IPA | Unicode | Popis IPA | Príklad | Jazyk
PF | P + F | p.f |  | {lbd,aff,vls} | Pfahl | Nemčina
TS | T + S | t.s / ʦ | U+02A6 | {den,aff,vls} | Zahl | Nemčina
CH | T + SH | t.ʃ / ʧ | U+02A7 | {pla,aff,vls} | chin | Angličtina
JH | D + ZH | d.ʒ / ʤ | U+02A4 | {pla,aff,vcd} | joy | Angličtina
JJ | J + J | j.j |  | {pal,aff,vcd} | hielo | Španielčina
DZ | D + Z | d.z / ʣ | U+02A3 | {den,aff,vcd} | zona | Taliančina
Kópia | T + SC | t.ɕ / ʨ | U+02A8 | {pla,aff,vls} |  | Mandarínska čínština
TSR | T + SR | t.ʂ |  | {rfx,aff,vls} |  | Mandarínska čínština
JC | D + ZC | d.ʑ / ʥ | U+02A5 | {pla,aff,vcd} |  |

Existuje rad ďalších afrikát alebo zložených spoluhlások, ktoré môžu iné jazyky vyžadovať. Napríklad taliančina obsahuje asi 20 geminačných (párových) spoluhlások. Sada UPS tieto špeciálne fonémy nezahŕňa, ale umožňuje ich definovanie pomocou symbolu "+" alebo diakritického znamienka pre dĺžku "lng" v prípade párových spoluhlások.

Samohlásky

Toto je výpočet a krížové odkazy foném samohlások používaných tromi fonetickými abecedami.

Pravidlá značenia samohlások podľa UPS

Pravidlá značenia samohlások podľa UPS sú navrhnuté tak, aby boli fonémy pokiaľ možno intuitívne a udržala sa fonetická podobnosť medzi jednotlivými triedami. Označenia sa riadia týmito pravidlami:

  • Pre kardinálne alebo hlavné samohlásky sa používajú označenia v dĺžke jedného znaku.
  • Pre nekardinálne samohlásky a bežné dvojhlásky sa používajú označenia v dĺžke dvoch znakov.
  • Maximálna dĺžka označenia sú tri znaky.
  • Označenia pre stredné samohlásky obsahujú znak X, napríklad AX, IX, UX.
  • Označenia pre samohlásky v zatvorenej slabike (obvykle po nej musí nasledovať spoluhláska v prízvučnej slabike) obsahujú H, napríklad IH, UH.
  • U alebo O znamená zaokrúhlenie pier, napríklad u AU, AO, EU.

Tabuľka samohlások

Uvedené sú štyri tabuľky, z ktorých každá obsahuje výpočet inej kategórie samohláskových foném:

  • jednoduché samohlásky,
  • dvojhlásky,
  • nemecké dvojhlásky,
  • nazály.

Fonémy jednoduchých samohlások (monoftongy)

Jednoduché samohlásky (monoftong – doslova "jeden zvuk" alebo "jeden tón") sú tie, ktorých počiatočná a konečná artikulačná pozícia je pomerne fixná a nekĺže nahor alebo dolu na novú artikulačnú pozíciu.

UPS | IPA | Unicode | Popis IPA | ASCII-IPA | X-SAMPA | Príklad | Jazyk
I | i | U+0069 | {hgh,fnt,unr,vwl} | I | i | feel | Angličtina
Y | y | U+0079 | {hgh,fnt,rnd,vwl} | Y | y | du | Francúzština
IX | ɨ | U+0268 | {hgh,cnt,unr,vwl} | i" | I\ |  |
YX | ʉ | U+0289 | {hgh,cnt,rnd,vwl} | U" | } |  |
UU | ɯ | U+026F | {hgh,bck,unr,vwl} | u- | M |  |
U | u | U+0075 | {hgh,bck,rnd,vwl} | u | u | too | Angličtina
IH | ɪ | U+026A | {smh,fnt,unr,vwl} | I | I | fill | Angličtina
YH | ʏ | U+028F | {smh,fnt,rnd,vwl} | I. | Y | hübsch | Nemčina
UH | ʊ | U+028a | {smh,bck,rnd,vwl} | U | U | book | Angličtina
E | e | U+0065 | {umd,fnt,urd,vwl} | e | e | ses | Francúzština
EU | ø | U+00F8 | {umd,fnt,rnd,vwl} | Y | 2 | blöd | Nemčina
EX | ɘ | U+0258 | {umd,cnt,urd,vwl} | @<umd> | @\ |  |
OX | ɵ | U+0275 | {umd,cnt,rnd,vwl} |  | 8 |  |
OU | ɤ | U+0264 | {umd,bck,urd,vwl} | o- | 7 |  |
O | o | U+006F | {umd,bck,rnd,vwl} | o | o | go | Angličtina
AX | ə | U+0259 | {mid,cnt,unr,vwl} | @ | @ | ago | Angličtina
AX rho | ɚ | U+025a | {mid,cnt,rho,vwl} | R |  | forensic | Angličtina
EH | ɛ | U+025B | {lmd,fnt,unr,vwl} | E | E | pet | Angličtina
OE | œ | U+0153 | {lmd,fnt,rnd,vwl} | W | 9 | plötzlich | Nemčina
ER | ɜ | U+025C | {lmd,cnt,unr,vwl} | V" | 3 | bird | Angličtina Veľká Británia
ER rho | ɝ | U+025D | {lmd,cnt,unr,rho,vwl} | @. |  | bird | Angličtina Spojené štáty
UR | ɞ | U+025E | {lmd,cnt,rnd,vwl} | O" | 3\ |  |
H | ʌ | U+028C | {lmd,bck,unr,vwl} | V | V | cut | Angličtina
AO | ɔ | U+0254 | {lmd,bck,rnd,vwl} | O | O | dog | Angličtina
AE | æ | U+00E6 | {sml,fnt,unr,vwl} | & | { | cat | Angličtina
AEX | ɐ | U+0250 | {sml,cnt,unr,vwl} | 6 |  | Besser | Nemčina
A | a | U+0061 | {low,fnt,unr,vwl} | a | a | valle | Španielčina
AOE | ɶ | U+0276 | {low,fnt,rnd,vwl} | &. | & |  |
AA | ɑ | U+0251 | {low,bck,unr,vwl} | A | A | father | Angličtina
Q | ɒ | U+0252 | {low,bck,rnd,vwl} | A. | Q | hot | Angličtina

Fonémy dvojhlások (diftongy)

Okrem monoftongov sú v rade jazykov obsiahnuté aj diftongy (dvojhlásky) alebo dokonca triftongy (trojhlásky). Dvojhlásky (diftong – doslova "dva zvuky" alebo "dva tóny") sú samohlásky, ktoré menia behom artikulácie svoju zvukovú štruktúru, obsahujú "polovokál", dochádza pri nich k plynulému pohybu jazyka z jednej artikulačnej polohy do druhej, napríklad u anglických slov eye, boy alebo cow.

Dvojhlásky a trojhlásky môžu byť v UPS prezentované ako zloženina samohlások s využitím symbolu "+". Sada UPS jednako obsahuje fonémy pre bežné dvojhlásky, čo zlepšuje čitateľnosť slovníkov. Nižšie uvedená tabuľka obsahuje ako zloženiny z dvoch foném s využitím symbolu "+", tak i následné fonémy UPS.

Zloženina UPS | UPS | IPA | X-SAMPA | Príklad | Jazyk | Príklad | Jazyk
E + I | EI | e.ɪ | eI | late | Angličtina | late | Angličtina
A + UH | AU | ɑ.ʊ | aU | foul | Angličtina | Haus | Nemčina
AO + I | OI | ɔ.ɪ | OI | toy | Angličtina | Kreuz | Nemčina
A + I | AI | ɑ.ɪ | ai | bite | Angličtina | Eis | Nemčina
I + AX | IYX | i.ə | i:6 | Tier | Nemčina | fear | Angličtina
Y + AX | UYX | y.ə | y:6 | Tür | Nemčina |  |
EH + AX | EHX | ɛ.ə | E6 | Berg | Němčina | stairs | Angličtina
U + AX | UWX | u.ə | u:6 | Kur | Nemčina | lure | Angličtina
O + AX | OWX | o.ə | o:6 | Ohr | Nemčina | boa | Angličtina
AO + AX | AOX | ɔ.ə | O6 | dort | Nemčina | four | Angličtina

Nemecké dvojhlásky

Nemecký jazyk má niekoľko stredových dvojhlások, ktoré nemajú priradenú explicitnú UPS fonému a musia byť prezentované vo forme zloženín fonémových hlások. Fonetickú kompletnosť doplňuje použitie diakritického znamienka "lng".

Zloženina UPS | IPA | X-SAMPA | Príklad | Jazyk
IH + AX | ɪ.ə | I6 | Wirt | Nemčina
YH + AX | ʏ.ə | Y6 | Türke | Nemčina
EY lng + AX | e.ə | e:6 | schwer | Nemčina
EH lng + AX | ɛ:.ə | E:6 | Bär | Nemčina
EU lng + AX | ø.ə | 2:6 | Föhr | Nemčina
OE + AX | œ.ə | 96 | Wörter | Nemčina
A lng + AX | a.ə | a:6 | Haar | Nemčina
A + AX | a.ə | a6 | hart | Nemčina
UH + AX | ʊ.ə | U6 | kurz | Nemčina

Fonémy nazálnych hlások

Sada UPS obsahuje fonémy štyroch nazálnych samohlások. Tieto fonémy obsahuje nasledujúca tabuľka spolu s príkladmi francúzskych slov.

Zloženina | UPS | X-SAMPA | Príklad | Jazyk
E nas | CS | e~ | vin | Francúzština
A nas | AN | a~ | vent | Francúzština
O nas | ON | o~ | bon | Francúzština
OE nas | OEN | 9~ | brun | Francúzština

Diakritické fonémy

Toto je výpočet a krížové odkazy diakritických foném používaných tromi fonetickými abecedami.

Diakritická fonéma

Diakritické fonémy sa používajú k modifikácii segmentálnych foném (samohlások, spoluhlások, trených a výbuchových spoluhlások) pomocou ďalších fonetických informácií. Diakritické fonémy nemožno použiť samostatne. Diakritické fonémy vždy modifikujú predchádzajúcu segmentálnu fonému. Segmentálny symbol môže byť nasledovaný ľubovoľným počtom diakritických foném.

UPS | IPA | Unicode | Popis IPA | ASCII-IPA | X-SAMPA
+ | ͡ | U+0361 | Viazanie |  | _
adv | o̟ | U+031F | Dôležitejší |  | _+
api | t̺ | U+033A | Apikálny |  | _a
asp | tʰ | U+02B0 | Prídych | ^lt;h> {asp} | _h
atr | e̘ | U+0318 | Posun koreňa jazyku dopredu |  | _A
bvd | b̤ | U+0324 | Dychová fonácia |  | _t
cen | ë | U+0308 | Stredná | " | _"
cvd | b̰ | U+0330 | Chrapľavá fonácia |  | _k
den | t̪ | U+032A | Dentálna | [ / {dnt} | _d
ejc | pʼ | U+02BC | Výbuchová | {ejc} | _>
lab | tʷ | U+02B7 | Labializovaná | <w> {lzd} | _w
lam | t̻ | U+033B | Laminálna |  | _m
lar | dˡ | U+02E1 | Laterálna explózia |  | _l
lla | n̼ | U+033C | Lingvolabiálna |  | _N
low | e̞ | U+031E | Nízka |  | _o
lrd | o̜ | U+031C | Menej zaokrúhlená |  | _c
mcn | e̽ | U+033D | Prostredná |  | _x
mrd | o̹ | U+0339 | Viac zaokrúhlená |  | _O
nar | d̚ | U+031A | Bez počuteľnej explózie |  | _}
nas | ñ | U+0303 | Nazalizovaná | ~ / <nzd> | ~ / _~
nsr | oⁿ | U+207F | Nosná explózia |  | _n
nsy | n̯ | U+032F | Neslabičná |  | _^
pal | tʲ | U+02B2 | Palatalizovaná | ; / {pzd} | '
phr | nˤ | U+02E4 | Faryngalizovaná |  | _?\
rai | e̝ | U+031D | Vysoká |  | _r
ret | o̱ | U+0331 | Zadná |  | _-
rho | ə˞ | U+02DE | Zafarbenie do r |  | `
rtr | e̙ | U+0319 | Posun koreňa jazyku dozadu |  | _q
syl | n̩ | U+0329 | Slabikotvorná | {syl} | = / _=
vcd | s̬ | U+032C | Znelá |  | _v
vel | tˠ | U+02E0 | Velarizovaná | {vzd} | _G
vls | n̊ | U+030A | Neznelá |  | _0
vph | l̴ | U+0334 | Velarizovaná alebo faryngalizovaná | {fzd} | _e

Suprasegmentálne javy

Toto je výpočet a krížové odkazy foném suprasegmentálnych javov používaných tromi fonetickými abecedami.

Suprasegmentálne fonémy

Suprasegmentálne javy popisujú javy v jazyku presahujúce úroveň jednotlivých spoluhlások a samohlások, ako prozódia, tón, dĺžku hlások a prízvuk.

Prvá sada suprasegmentálnych symbolov vrátane mapy "prepojení" priamo na sadu suprasegmentálnych javov podľa IPA s hodnotami IPA Unicode. Táto sada obsahuje dĺžku diakritických znamienok – dlhé, polodlhé a extrakrátke. Dĺžka sa vo fonematike používa často, takže značky dĺžky by mohli patriť tiež do tabuľky diakritických znamienok. Z tohto dôvodu sú označenia diakritiky uvedené malými písmenami.

Ostatné suprasegmentálne symboly sa v sade UPS používajú k popisu intonačných kontúr v značkovacích jazykoch hlasových syntéz ("prompt" dokumenty SSML). Tieto symboly UPS boli vytvorené pridaním prefixu s podčiarknutím k pôvodným označeniam SAPI. Vďaka tomu sú jednoduchšie identifikovateľné ako trieda a obmedzí sa tým akákoľvek nejednoznačnosť v odlíšení od iných symbolov IPA. Napríklad starý symbol SAPI pre zakončenie vety "!" je v IPA symbolom pre alveolárnu trenú spoluhlásku.

UPS | IPA | Unicode | Popis IPA | X-SAMPA | Ekvivalent SAPI
S1 | ˈ | U+02C8 | Primárny prízvuk | " | 1
S2 | ˌ | U+02CC | Sekundárny prízvuk | % | 2
. | . | U+002E | Slabičný predel | . |
_| | | | U+007C | Malá pauza | | |
_|| | ‖ | U+2016 | Veľká pauza | || |
lng | ː | U+02D0 | Dlhá | : |
hlg | ˑ | U+02D1 | Polodlhá | :\ |
xsh | ˘ | U+02D8 | Extra-krátka | _X |
_^ | ‿ | U+203F | Viazanie (absencia pauzy) | -\ |
_! |  |  | Intonácia – výkričník |  | ! Zakončenie vety (výkričník)
_& |  |  | Intonácia - pokračovacia |  | & Hranica slova
_, |  |  | Intonácia - nekoncová stúpavá |  | , Zakončenie vety (čiarka)
_s |  |  | Ticho |  | _ Ticho (podčiarknutie)
_. | ↘ | U+2198 | Intonácia – klesavá | <F> | . Zakončenie vety (bodka)
_? | ↗ | U+2197 | Intonácia - opytovacia stúpavá | <R> | ? Zakončenie vety (otáznik)

Trené a výbuchové spoluhlásky

Toto je výpočet a krížové odkazy foném trených a výbuchových spoluhlások používaných tromi fonetickými abecedami.

Fonémy trených a výbuchových spoluhlások

IPA používa k popisu výbuchových spoluhlások diakritické znamienka, ale pre frikatívy a implozívy má vytvorené špeciálne fonémy. Trené a výbuchové spoluhlásky sú neznelé spoluhlásky, zatiaľ čo implozívy môžu byť čiastočne znelé.

UPS | IPA | Unicode | Popis IPA | X-SAMPA
PCK | ʘ | U+0298 | blb,clk | O\
TCK | ǀ | U+01C0 | dnt,clk | |\
NCK | ! | U+0021 | alv,clk | !\
CCK | ǂ | U+01C2 | pla,clk | =\
LCK | ǁ | U+01C1 | alv,lat,clk | |\|\
BIM | ɓ | U+0253 | blb,imp,vcd | b_<
DIM | ɗ | U+0257 | dnt-alv,imp,vcd | d_<
QIM | ʛ | U+029B | uvl,imp,vcd |
QIM vls | ʠ | U+02A0 | uvl,imp,vls |
GIM | ɠ | U+0260 | vel,imp,vcd | g_<
JIM | ʄ | U+0284 | pal,imp,vcd |
P ejc | pʼ | 0070 02BC | blb,ej | b_>
T ejc | tʼ | 0074 02BC | dnt-alv, ej | t_>
K ejc | kʼ | 006B 02BC | vel ej | g_>
S ejc | sʼ | 0073 02BC | alv fric ej | s_>
QT ejc | qʼ | 0071 02BC | uvl,ej |

Tóny

Toto je výpočet a krížové odkazy foném tónov používaných tromi fonetickými abecedami.

Fonémy tónov

Tón popisuje využívanie výšky rečových zvukov v hláskach k rozlíšeniu lexikálneho alebo gramatického významu. Lexikálne tóny môžu nasledovať po samohláske alebo tiež po slabikotvornej spoluhláske. Môžu byť formované z jednoduchých úrovní na univerzálnej škále, ktorá má maximálne päť úrovní kontrastu, alebo sa môže jednať o kontúry zložené zo sekvencií tónov. Sekvencia troch tónov by mala byť pre popis akejkoľvek tónovej kontúry dostatočná.

IPA obsahuje súbor lexikálnych tónov a tónových kontúr. V sade UPS nájdete päť lexikálnych tónov nachádzajúcich sa v IPA a ďalej vzostup a zostup tónu. Všetky tónové kontúry môžu byť v sade UPS prezentované formou tónových zloženín.

Sada UPS neobsahuje tonálne symboly pre nasledujúce symboly IPA: extra nízky, vysoký, stredný, nízky, extra nízky. Všetky tieto symboly môžu byť definované v sade UPS pomocou tónových sekvencií. Stúpavá intonácia a klesavá intonácia sú ekvivalenty k javom "intonácia – zostup" a "intonácia – vzostupná otázka" v sade UPS ("Suprasegmentálne javy").

UPS | IPA | Unicode | Popis IPA | X-SAMPA
T5 | e̋ | U+030B | Extra vysoký | _T
T4 | é | U+0301 | Vysoký | _H
T3 | ē | U+0304 | Stredný | _M
T2 | è | U+0300 | Nízky | _L
T1 | ȅ | U+030F | Extra nízky | _B
T- | ↓ | U+2193 | Pokles tónu | !
T+ | ↑ | U+2191 | Vzostup tónu | ^

Ostatné fonémy

Toto je výpočet a krížové odkazy málo používaných foném, ktoré nie sú uvedené v iných tabuľkách foném, ale sú používané tromi fonetickými abecedami.

Ostatné fonémy

UPS | IPA | Unicode | Popis IPA | ASCII-IPA | X-SAMPA
WH | ʍ | U+028D | lbv,frc,vls | w | W
ESH | ʜ | U+029C | epl,frc,vls |  | H\
EZH | ʢ | U+02A2 | epl,frc,vcd |  | <\
ET | ʡ | U+02A1 | epl,stp |  | >\
SC | ɕ | U+0255 | pla,frc,vls |  | s\
ZC | ʑ | U+0291 | pla,frc,vcd |  | z\
LT | ɺ | U+027A | alv,lat,flp | * | l\
SHX | ɧ | U+0267 | simultánny SH a X |  | x\
HZ | ɦ | U+0266 | glt,frc,vcd |  | h\